HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


3.0.7 released

3.0.7 released Version 3.0.7 has now been released. This version is a patch release that introduces a number of bug fixes since the last release. Upgrading is strongly advised due to WYSIWYG editor and Internet Explorer fixes.

To upgrade from any previous 3.0.x release, simply upload the files inside the attached zip file over existing files. After this is done, run http://mybaseurl/force_upgrade.php and choose to clear caches.
Unfortunately the automatic-extraction method introduced in the last patch release had a bug, so can't be used until the next release.
For more details, see our upgrading tutorial.

Attachment
» Download: 3.0.0-3.0.7.zip (1.07 Mb, 1266 downloads so far)


Fixes have been made to the following issues (Described in more detail):
  • Catalogue upload-field bug
  • Comcode page search returns extra results with broken links
  • Difficulty in selecting usergroup leader
  • Error when viewing page source for a valid page
  • FTP connection in new upgrading script does not work.
  • Guest Captcha broken in some areas in some situations
  • HTTP/LDAP authentication bug
  • IE6 rendering problem (protruding white strip on the right)
  • IPB cookie integration slightly broken
  • Member directory search broken
  • Personal galleries and guests
  • Recommend site e-mails look a little wrong
  • Shoutbox taking over an instant-messaging conversation
  • Site-Tree interface broken in Internet Explorer
  • Stats pie chart bugs
  • The link to add a gallery for a newly added member is broken
  • The next links in the tease blocks do not work.
  • The side_root_galleries block does not work.
  • Unvalidated images as rep-images
  • WYSIWYG problems

View all

Trackbacks

There have been no trackbacks yet