HTML Logo by World Wide Web Consortium ( Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.

2.6.1 released

2.6.1 released Version 2.6.1 has now been released. This version is a minor release that introduces a number of bug fixes since the last release. Upgrading is suggested due to a number of fixes for minor issues that most users will experience at some point.

To upgrade from any previous 2.6.x release, simply upload the files inside the attached zip files over existing files. After this is done, run http://mybaseurl/force_upgrade.php.
For more details, see our upgrading tutorial.

Note: Before upgrading a registered site you should check to make sure that your upgrade period is still active. If if is not you should not upload sources/version.php.

» Download: (514 Kb, 592 downloads so far)

Fixes have been made to the following issues (Described in more detail):
  • Abstract file manager default settings
  • Categorise personal topics broken
  • Chat room log downloading broken
  • Comcode thumb tag on Comcode pages
  • Editing a signature redirection problem
  • Error mails sent for external downloads
  • Error when joining an OCF site
  • Flow mode page thumbnails
  • In OCF, IP address probing is imperfect
  • List custom profile field editing
  • Minor installation glitch
  • Mixing manual and alphabetical forum ordering in 2.6
  • On a multi-language site, untranslated Comcode pages give error
  • Quotes editing problem (1)
  • Quotes editing problem (2)
  • Staff checklist forum moderation link
  • User group deletion broken
  • Username character filtering does not work correctly
  • WYSIWYG select causes error after choosing to edit
  • and imports/mods
  • font and size Comcode tags
  • main_feedback block broken
  • main_random_image block problem
  • mySQL 5 not supported
Note that some of these problems were also fixed in a almost-immediate re-release of 2.6.0.

View all