HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


ocPortal Version 3.2.6 (#downloads_183)

Login / Search

 [ Join | More ]
 
 
This is a spacer post for an ocPortal comment topic. The content this topic relates to: ocPortal Version 3.2.6
 


Query on "sources/global2.php"

Avatar
Please confirm.

Line 154 doesn't have an ampersand preceding 'ini_set', like the three lines preceeding it.

Is it meant to be that way?

Thanks.

Avatar
 I think you mean the 'AT' symbol.
It's an interesting question; I believe the answer is "only if you have an unofficially modified version of PHP". I think we put the '@'s in there for the other lines for a version of PHP we once experienced that had been modified by the webhosts to restrict what their customers could change (giving out errors if anything was changed). "@" suppresses error messages. We should probably have done the same with this, but you should be fine either way.

Avatar
Thanks Chris. And yes, I DID mean the 'AT' symbol.

 :$

Question re: FLV player ...

Avatar
I apologise for posting this question here, but I cannot locate the page on which you posted your 'dire warnings' in respect of updating to 3.2.6.

I have installed 3.2.6 and I am pleased to report that absolutely nothing seems to have gone wrong.

I rushed reading the 'fixes' and 'improvements', but I did note something about the FLV player working as long as the player module by (a Scandinavian name) was in the data folder.

I would be grateful for more information about how the FLV player is activated.

 ;)

Avatar
 That would be this news article.

Download the zip from http://www.jeroenwijering.com/?item=JW_FLV_Player
there'll be an flvplayer.swf in there - just upload it to 'data'.

EDIT: Actually I left out a template which is attached.



Attachment
» Download: GALLERY_VIDEO_FLV.tpl (1.10 Kb, 177 downloads so far)

Avatar
Thanks for that.

I'll take it for a spin as I have a few FLV files that I've been unable to use - until now?

I'll try and remember to report back whether or not my attempt was successful.

 :thumbs:

Avatar
Tried to upload an FLV video via the [Galleries | Add video] feature and got this 'recoverable' error:
A language entry is missing: NOT_VIDEO
Just don't know where to look to correct it …!

Also, 'forcing' the upload threw up an error page that says:
The referenced file is not a valid video filetype.

I have set "flv" as an uploadable file type.

Any pointers, please?

Avatar
Please check data/flv_player.swf exists. If it does, then it might be due to how your server is configured.
Please try changing line 495 of sources/support.php from:

Code

   if (file_exists('data/flv_player.swf'))
to:

Code

   if (file_exists(get_file_base().'/data/flv_player.swf'))

I have to admit to throwing in that line very quickly, just to make sure I didn't break things for people without the FLV player (which I don't think we have a licence to distribute at the moment).

Avatar





Getting SOMEWHERE.

1. I made the changes to sources/support.php and cleared caches - just in case - before attempting this test.

2. The "flv_player.swf" file you refer to is actually downloaded from source as "flvplayer.swf" and as a consequence it was not being called up!

3. Some extra information:
  • FLV wil NOT upload from the Gallery "Add video" page. It has to be FTP'd.
  • The entry appears in the Video Gallery - (attachment '_FLV-2')
  • The video (swf -or- flv) is now given a placeholder, but it refuses to be activated - (attachment '_FLV-1')

What else should I try?

Edit: I've remembered that I did not give the vid any height/width parameters, assuming it would find this information automatically, just as it does for the other video extensions. Perhaps I should have done so? In any case the placeholder (attachment '_FLV-1') seems to have allocated the correct height/width space, so I am hoping that that wasn't the problem.


Last edit: by Fletch

Avatar

Code

error [/media/New Volume/quick.zip]:  missing 1448 bytes in zipfile
  (attempting to process anyway)
error [/media/New Volume/quick.zip]:  attempt to seek before beginning of zipfile
  (please check that you have transferred or created the zipfile in the
  appropriate BINARY mode and that you have compiled UnZip properly)
  (attempting to re-compensate)
 bad CRC d1267df7  (should be 27799ba3)
file #2:  bad zipfile offset (local header sig):  10118771
  (attempting to re-compensate)

Avatar
Tried it a second time.

Code

Archive:  /media/New Volume/quick.zip   10204586 bytes   2 files
error [/media/New Volume/quick.zip]:  missing 1448 bytes in zipfile
  (attempting to process anyway)
-rw-r--r--  2.3 unx 19165346 tx defX 20071125.031628 data.ocp
-rw-r--r--  2.3 unx   519987 tx defX 20071125.031628 install.php
2 files, 19685333 bytes uncompressed, 10205754 bytes compressed:  48.2%

Avatar
Duhhhh!

Am I missing something, Amy?

Avatar
just having trouble unzipping the zip file.
Thats the error I am getting.

Avatar
It worked this time.

Avatar
Ok Fletch, I made a real mess of this. Please rename flvplayer.swf back to how it was originally. Now I will go through the full set of fixes/changes needed to make this work:
  • Copy in the template file I posted above (you've done this already)
  • Save flvplayer.swf to the 'data' directory (you'll just need to rename yours)
  • Edit line 495 of sources/support.php to reference flvplayer.swf not flv_player.swf.
  • Add 'flv' to the list of allowed file types in your configuration. (In the configuration it's under the 'Security/group options' section)
  • When you add you will need to give a width/height/length, as this is not auto-detectable for our FLV files support.

Avatar
Bingo!

Works like a charm. You can see it here if you're interested. She does have LONG legs!

Virtually all the steps you mentioned were already in place. The only thing that needed changing was "flv_player.swf" to "flvplayer.swf". It even put in the 'width/height' parameters, defaulting to '320/200' but left the 'length' at 0, which doesn't seem to affect the playback. Using the edit menu I changed the width to '235' to suit the width of the vid and it displays perfectly. I haven't tried uploading an 'flv' using the upload feature, but I shall try it out and let you know if things go awry!

This feature is going to save site owners masses of bandwidth. Good one!

 :thumbs:




FullScreen in FLV video

Avatar
And, don't forget the new FullScreen features available with Flash!

FlvPlayer support this, but Template just don't say the appropriate tag.

Please, add this line on GALLERY_VIDEO_FLV.tpl files above:

Code

<param name="allowFullScreen" value="true" />

on line 3 and 10, so your final GALLERY_VIDEO_FLV.tpl look like:

Code

<object width="{WIDTH*}" height="{HEIGHT*}" type="application/x-shockwave-flash" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab">
   <param name="movie" value="{$BASE_URL}/data/flvplayer.swf?file={URL£*}&amp;autoStart=false" />
   <param name="allowFullScreen" value="true" />
   <param name="quality" value="high" />
   <param name="wmode" value="transparent" />
   <param name="pluginspage" value="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" />

   <!--[if !IE]> -->
      <object width="{WIDTH*}" height="{HEIGHT*}" data="{$BASE_URL}/data/flvplayer.swf?file={URL£*}&amp;autoStart=false" type="application/x-shockwave-flash">
         <param name="allowFullScreen" value="true" />
         <param name="movie" value="{$BASE_URL}/data/flvplayer.swf?file={URL£*}&amp;autoStart=false" />
         <param name="quality" value="high" />
         <param name="wmode" value="transparent" />
         <param name="pluginspage" value="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" />

         {!ANIMATION}
      </object>
   <!-- <![endif]-->
</object>

Now you have full screen mode ON !

 :thumbs:

Avatar
Thanks, lgdesign.

I added the line(s) to the template and sure enough I get the 'full screen' icon appearing. I can't remember if the feature was there before my edit, but it sure is there NOW!

 :thumbs:

Avatar
Hi Fletch,

yes, FullScreen icon was there even before template change, but without that line of code it was useless! :thumbs:

Well, we can't ask for Chris know even flash code!  :lol:  :lol:  :lol:

I'm jokin', of course!
 :thumbs:

Avatar
Sorry, I forget that:
just delete lines 5 and 13, where you can read that param:

Code

<param name="wmode" value="transparent" />

So, your (really) final GALLERY_VIDEO_FLV.tpl should look like:

Code

<object width="{WIDTH*}" height="{HEIGHT*}" type="application/x-shockwave-flash" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab">
   <param name="movie" value="{$BASE_URL}/data/flvplayer.swf?file={URL£*}&amp;autoStart=false" />
   <param name="allowFullScreen" value="true" />
   <param name="quality" value="high" />
   <param name="pluginspage" value="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" />

   <!--[if !IE]> -->
      <object width="{WIDTH*}" height="{HEIGHT*}" data="{$BASE_URL}/data/flvplayer.swf?file={URL£*}&amp;autoStart=false" type="application/x-shockwave-flash">
         <param name="allowFullScreen" value="true" />
         <param name="movie" value="{$BASE_URL}/data/flvplayer.swf?file={URL£*}&amp;autoStart=false" />
         <param name="quality" value="high" />
         <param name="pluginspage" value="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" />

         {!ANIMATION}
      </object>
   <!-- <![endif]-->
</object>


Fletch, just change that template and on your page Anglo-Indian Portal - Home , and (now) FullScreen will work!
I'll wait your reply! (and sorry for early error…)
 :thumbs:

Avatar
lgdesign,

You've now managed to confuse me - just a little.

The 'fullscreen' mode is available to me WITH or WITHOUT the "wmode" line in the template.

What does removing that parameter achieve?

Avatar
Sorry Flecth for that..  :$

Just copy the last template, the one WITHOUT "wmode" line.

Windows mode trasparent don't support FullScreen.
If you try on click on your FLV Player button (BEFORE of change template to the last version I write above) nothing happen..

WITHOUT "wmode" line, it work fine!

I'll repeat here: just copy that below GALLERY_VIDEO_FLV.tpl:

Code

<object width="{WIDTH*}" height="{HEIGHT*}" type="application/x-shockwave-flash" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab">
   <param name="movie" value="{$BASE_URL}/data/flvplayer.swf?file={URL£*}&amp;autoStart=false" />
   <param name="allowFullScreen" value="true" />
   <param name="quality" value="high" />
   <param name="pluginspage" value="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" />

   <!--[if !IE]> -->
      <object width="{WIDTH*}" height="{HEIGHT*}" data="{$BASE_URL}/data/flvplayer.swf?file={URL£*}&amp;autoStart=false" type="application/x-shockwave-flash">
         <param name="allowFullScreen" value="true" />
         <param name="movie" value="{$BASE_URL}/data/flvplayer.swf?file={URL£*}&amp;autoStart=false" />
         <param name="quality" value="high" />
         <param name="pluginspage" value="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" />

         {!ANIMATION}
      </object>
   <!-- <![endif]-->
</object>

 :thumbs:

Avatar
Thanks. You're a star!

 :thumbs:

1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Expand