HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


3.2.0 released (#news_125)

Login / Search

 [ Join | More ]
 
 
This is a spacer post for an ocPortal comment topic. The content this topic relates to: 3.2.0 released
 


Avatar
Downloaded the upgrade.
  • Checked all files against my 'modded' ones
  • FTP'd the relevant files
  • Ran the force_upgrade
  • Cleared cache
  • Checked permissions
  • Did a 'file integrity' check
  • Did a 'core upgrade'

Called up the site. Checked the Admin Zone. It is still showing '3.1.6 information' and inviting me to get 3.2.0.

Where do I go from here?

Edit: Belay that whinge! Did everything EXCEPT upload the new files . . . What a dipstick!


Last edit: by Fletch

Avatar
Is it possible you missed sources/version.php?

Avatar
All OK now, Chris . . . sort of!

It's broken my carefully crafted display, but I think I know where to start looking ti fix the minor changes.

Wonder what happened to my 'neat' Zone-Menu? Do I have to do it all over again?

Avatar
As long as you put your TOP.tpl and global.css back (I'm guessing you've removed your customised ones), it should be alright.

Avatar
yep should be. I am going to do what I always do which is easier for me. Just going to reinstall ocPortal and import the data, I have been doing the upgrades that why for a while.

Avatar

Chris Graham said

As long as you put your TOP.tpl and global.css back  . . .

1. The global.css introduced a new property .global_side in 3.2 that 'broke' my page background-color. That's been fixed now.

2. I'd completely forgotten that TOP.tpl got hacked to display the 'zone_menu', even though a comparison check showed a change in the overall content. The customised template has been restored and everything is as it was before. That's a  :thumbs:

I think I messed up because I interpreted the 'explanation' about the 'zone_menu' for 3.2 as being something that was accessible from the Admin Zone, and I assumed that since I had already made the change that the 'new' script would automatically pick that up. Must make a more detailed note that TOP.tpl needs to be customised each time there is an upgrade or patch!

Haven't put the enhanced WYSIWYG editor through its paces, and I probably won't. I prefer to use a mixture of 'semihtml', 'HTML' and 'Comcode' when I post, but I'm sure my users will leave feedback if things are 'easier'. I'll try and remember to leave my own feedback here if it appears that users are finding it 'different' or 'easier'.

Avatar
I my self am finding it much easier I mean the WYSIWYG. Specially on this site where firefox did not work all that well so I am really happy thats been fixed.
I still can not wait until 4 though

Avatar
 I have upgraded (I think).

I found it a bit disconcerting when the upgrader found 'alien' files I should delete included my zones I had added… I didn't delete them, of course.

Avatar
 

Reggie said

 I have upgraded (I think).

I found it a bit disconcerting when the upgrader found 'alien' files I should delete included my zones I had added… I didn't delete them, of course.
  ya it does that, its just a security feature and as long as you know the files are ones you made it is fine.

Avatar
It's a very fair point - I'll amend that text to be more clear.

Avatar
cool, reminds me of ipb's antivirus feature and when they first made it, it was so messed up it found files that were part of IPB that it was telling people to delete. LOL, and some people did delete them and wondered why the forum was no longer working.

There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: