HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


ocPortal 9.0.7 released - Comments

Login / Search

 [ Join | More ]
 

ocPortal 9.0.7 released

Posted 14 May 2013, 2:46 AM

9.0.7 released. Read the full article for a list of changes, and upgrade information.

Read more


Install worked the first time

Avatar
Expected to get some errors due to all of the issues arising with applying too many patches (most of them not needed). 9.07 worked fine right out the box using the normal upgrade and no issues so far ...

Success

Avatar
Did the upgrade on my personal site (9.0.5-9.0.7) and no issues whatsoever.

Will consider upgrading a production site thats also currently on 9.0.5.

Wish I had more confidence in upgrading the 8.1.6 site, but it's WAYYY to busy and customised now to take any chances :(

Avatar
There has been 3 months between the last patch release and this one, so a large number of fixes have been rolled into this patch releases.

Please make especially sure you have a backup, and allocate enough time for the upgrade. We have fully gone through our test set, but the more issues fixed, the higher the chance we will have made a mistake somewhere. If any issues are spotted, we will resolve ASAP – but it is always good to be able to revert should you feel a need to for any reason.
Avatar
version 9.0.6 -> 9.0.7
well I got a critical bailing, but will look first why this is happen, it look that some files are newer then….

Let you know.
Avatar
Oh dear, what's the error?
Avatar
See this picture Chris….



Harry
Avatar
This may not be related to the version itself, but perhaps some change in process or the server. Harry, if you'd like to send me the FTP details, and upgrader password (chris@ocportal.com), I'll ensure the upgrade completes and report back.
Avatar
Oke Chris will send you the data. Thanks for help.

Avatar

Harry-S said

Oke Chris will send you the data. Thanks for help.
The upgrade is now complete :).

I just had to remove these files, which had been left around by a previous upgrade somehow:
data_custom/upgrader.tar.tmp
data_custom/upgrader.tmp

It's not specific to this patch release. We'll make the next upgrader be able to handle the anomaly.

Avatar

Chris Graham said

The upgrade is now complete :).

I just had to remove these files, which had been left around by a previous upgrade somehow:
data_custom/upgrader.tar.tmp
data_custom/upgrader.tmp

It's not specific to this patch release. We'll make the next upgrader be able to handle the anomaly.
Rhanks again Chris. I have not seen this both files.

Harry





Avatar
Ran the upgrader. Took action on files identified during the file integrity scan. Caches 'n' stuff cleared.

System refuses to acknowledge that it has been upgraded to 9.0.7



Observations, please.
Avatar
Please try this process:
  1. download the TAR file to your computer
  2. upload it onto your own hosting space
  3. upgrade using the URL to it on your hosting space

(Perhaps the ~9MB file was not able to download within the upgrader)
Avatar
Sorry, doesn't work for me.

I don't see that the 9MB file failed to load, because the upgrade process took me through all the steps. It even adjusted the results when I took action on files identified during the file integrity scan.

The site appears to be running fine, except for the Admin page refusing to acknowledge that the upgrader has been run.

bummer
Avatar
Does sources/version.php contain:

Code

   return '0.7';

That would mean it has upgraded.

Did you clear the caches (step 7 of the upgrader)?
(Although even if you didn't, it should automatically refresh the upgrade info after 3 hours and it has been that long)
Avatar
Did all the upgrader asked me to, and in the correct order, so this time I'm sure it wasn't me.

HOWEVER

Took a look at 'sources/version.php' and it was blatantly declaring '0.6'.

Overwrote the server version of the file with the manually downloaded version, and bingo, it's all correct now!

Don't understand why it didn't upgrade that file, nor report it during the integrity check. It has peaked my curiosity, but not sufficiently enough to go hunting down a solution - even if there is one!

 :thumbs:

Avatar

Fletch said

Did all the upgrader asked me to, and in the correct order, so this time I'm sure it wasn't me.

HOWEVER

Took a look at 'sources/version.php' and it was blatantly declaring '0.6'.

Overwrote the server version of the file with the manually downloaded version, and bingo, it's all correct now!

Don't understand why it didn't upgrade that file, nor report it during the integrity check. It has peaked my curiosity, but not sufficiently enough to go hunting down a solution - even if there is one!

 :thumbs:
This actually suggests to me nothing extracted at all. I remember you mentioning a similar issue before actually.

I've just gone over the code, and I can't think how this could be. I'm happy therefore to conduct the upgrade for you (and try and work out what's going on) – just drop me an email if you'd like this. I'd need to know all the settings you used to login to the upgrader, and the TAR URL you used. It would be good to work out what's happening here.

Avatar

Chris Graham said

This actually suggests to me nothing extracted at all. I remember you mentioning a similar issue before actually.

I've just gone over the code, and I can't think how this could be. I'm happy therefore to conduct the upgrade for you (and try and work out what's going on) – just drop me an email if you'd like this. I'd need to know all the settings you used to login to the upgrader, and the TAR URL you used. It would be good to work out what's happening here.
Always happy to have you drop by. You are still registered as a Super-mod, but I can forward all the details again if required.

The settings were relatively simple:
  • launched upgrader from Admin page
  • the TAR URL is the one generated by the system (http://ocportal.com/upgrades/9.0.6-9.0.7.tar)
  • the time taken to complete each step was similar to all previous upgrades
  • FIVE anomalies appear during the file integrity check, and no amount of overwriting via FTP seems to change the status of the files reported

Can't think of anything else that is relevant …


Avatar

Fletch said

Always happy to have you drop by. You are still registered as a Super-mod, but I can forward all the details again if required.

The settings were relatively simple:
  • launched upgrader from Admin page
  • the TAR URL is the one generated by the system (http://ocportal.com/upgrades/9.0.6-9.0.7.tar)
  • the time taken to complete each step was similar to all previous upgrades
  • FIVE anomalies appear during the file integrity check, and no amount of overwriting via FTP seems to change the status of the files reported

Can't think of anything else that is relevant …

Hi,

First let me say, I'm always so impressed when I look at your site :).

The upgrade extract went fine for me. I wonder if perhaps you have a browser addon that is blocking the extraction frame from refreshing through the files, or perhaps even blocking the frame.
Here's what you should have seen:

Avatar

Chris Graham said

First let me say, I'm always so impressed when I look at your site :).
That's a wooo-freakin'-hooo as far as I am concerned. Thank you!

Chris Graham said

I wonder if perhaps you have a browser addon that is blocking the extraction frame from refreshing through the files, or perhaps even blocking the frame.
I am completely unaware of anything in the browser (Chrome) that would do that, especially since it worked first time on the clone site. However, I will take another jaundiced look at the 'add-ons' and 'bolt-ons' to see if there may be a bit of naughtiness going on under the hood.

Thanks for taking a look and actioning the upgrader. I'll breathe a sigh of relief until the next time I screw-up!

 :thumbs:






Avatar
As patch releases go, there are some major changes in this one, including (off the top of my head):
  • Rewritten Wordpress importing
  • Better attachment thumbnail design for non-island attachments
  • Font resizer in the footer (because we realised tablets don't have the easy browser option desktops have)
  • Solved a number of performance issues on very large databases that had crept in
  • Greatly improved performance under stressed scenarios, ability to deal with locked databases and still be able to render pages, and so on

first install fails

Avatar
Hello there,

I am currently in a decision process for a portal software. So i tried yours, but while the install ran  so far - i get an critical Error beyond last step:

Unfortunately a query has failed [SHOW OPEN TABLES FROM XXXXXXX-XXX WHERE `Table`='ocp_sessions' AND In_use>=1] [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-tyrol WHERE `Table`='ocp_sessions' AND In_use>=1' at line 1] (version: 9.0.7, PHP version: 5.3.17, URL: /)
 
The XXXX were edited by me for sure.

Seems it won't work with my dbname, so i found a solution to get it work:

in:
sources/database.php LINE 1332 I changed this:

//$locks=$db->query('SHOW OPEN TABLES FROM '.$db_name.' WHERE `Table`=\''.$db->get_table_prefix().$tbl.'\' AND In_use>=1');
//RK FIX
$locks=$db->query('SHOW OPEN TABLES WHERE `Table`=\''.$db->get_table_prefix().$tbl.'\' AND In_use>=1');


good luck ya all.
Avatar
Thanks very much! You're right, we are incorrectly assuming database names don't contain special characters. This is a new issue, to do with our lock contention avoidance code that's just been added. I believe your fix is fine in most cases, although we will actually now do:

Code

$locks=$db->query('SHOW OPEN TABLES FROM `'.$db_name.'` WHERE `Table`=\''.$db->get_table_prefix().$tbl.'\' AND In_use>=1');
Avatar
The quick and manual installers have been re-released with this fix. It will have only affected a minority, but for those minority, a nasty issue.
Avatar
I'm happy to have helped.

By the way: Nice response time!




There are too many online users to list.
Control functions:

Quick reply   Expand