HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


ocPortal 8 RC2 released - Comments

Login / Search

 [ Join | More ]
 

ocPortal 8 RC2 released

Posted 29 March 2012, 11:12 PM

8 RC2 released. Read the full article for a list of changes, and upgrade information.

Read more


Avatar
I don't know if you want new issues post install found, here, but yeah... found something right away.

Expand: Profile Profile



What I find most interesting is that my access is denied to my own profile, with me being admin. Fun stuff.
Avatar
That is one of the templates that is completely changed, due to the new tabbed profiles. Most of it now belongs in OCF_MEMBER_PROFILE_ABOUT.tpl, whilst OCF_MEMBER_PROFILE_SCREEN.tpl is a tab wrapper IIRC.
Avatar
Alright, so what do I do in this case to make it use the right template?
Avatar

mythus said

Alright, so what do I do in this case to make it use the right template?


You'll need to delete your override, then rebuild your changes back into the new default versions of the template(s.

There are only a few templates in v8 that require this, but this is one of them.
Avatar
Aye, that fixed that issue.

Funny thing was, I never made a modification to the template. I may have looked at that template before some time ago, but never changed anything in there. Interesting.

There is only one error left on that screen ATM:

Code

A parameter, ID, is referenced in the template, OCF_FORUM, but not passed

And I also want to investigate putting a notepad in there again for member use like before (or maybe a tab that holds a note pad?).

Other than that, it's all gold - as far as the member profile goes. So thanks!
Avatar

mythus said

Aye, that fixed that issue.

Funny thing was, I never made a modification to the template. I may have looked at that template before some time ago, but never changed anything in there. Interesting.

There is only one error left on that screen ATM:

Code

A parameter, ID, is referenced in the template, OCF_FORUM, but not passed

And I also want to investigate putting a notepad in there again for member use like before (or maybe a tab that holds a note pad?).

Other than that, it's all gold - as far as the member profile goes. So thanks!

OCF_FORUM.tpl is another that has had quite a few changes, this time due to the threading. I made a tutorial on using a diff tool the other day, which got uploaded to CEDI under video tutorials by Jean.

Regarding the notepad, you could always make a CPF.

Show 3 more replies




Avatar
So I've done the following:

* Removed the Personal Zone zone

* made sure to check several times the file integrity checker. Besides 2 files that are marked as out of date (minor files) and some other file that wants merging, its pretty clean. None of the marked files have any reference to the member profile page.

* Looked at the OCF_MEMBER_PROFILE_SCREEN.tpl , but am lost about what to do with it…

* Cleaned brower chaches

*Used website cleanup tools.

Still - no go here.

*Disclaimer: These steps are privided to shopw what I have tried.



Avatar
Contextual css editor no longer shows a preview of your changes.

The theme debugger addon gives an error - The requested page (theme_debug) is missing. 
Avatar

Brian Hay said

Contextual css editor no longer shows a preview of your changes.

The theme debugger addon gives an error - The requested page (theme_debug) is missing. 


Fixed:
Attachment
themes/default/templates/JAVASCRIPT_THEMEING.tpl
» Download: JAVASCRIPT_THEMEING.tpl (13 Kb, 266 downloads so far)
Attachment
sources/hooks/systems/snippets/css_compile.php
» Download: css_compile.php (905 Bytes, 268 downloads so far)

Avatar

Brian Hay said

Contextual css editor no longer shows a preview of your changes.

The theme debugger addon gives an error - The requested page (theme_debug) is missing. 


Replying on theme debugger first— Fixed version uploaded, thanks.


Avatar
In the menu editor expanding the choice of links for a zone with lots of links produces the results in the screen shot....can not scroll, can not exit it.

Show 2 replies


Avatar
After fresh install I got this:

http://tmp.sterngeist.de/

PHP NOTICE [8] Trying to get property of non-object in sources/permissions.php on line 587 (version: 8-RC2, PHP version: 5.2.17-0.dotdeb.0, URL: /)

I didn't install a forum/member system. I don't need this for my homepage.

I already took a look in the mentioned permissions.php. But couldn't find the issue.

Best regards
Falko

Avatar
Uh oh, I broke my site lol

Fatal error: Class 'BaseFacebook' not found in /home/ocportal/public_html/sources_custom/facebook_connect.p
hp on line 21

The upgrade went smooth until I did a file integrity check. I checked the suggested sources_custom files that had been superseded by new versions and click automatically handle and now get the above error.

I imagine I just have to go replace those files with the new versions but figured I should report it anyways.

….145 updated/new files already! Wow! Thank you for all the hard work.  :thumbs:  
Avatar
That happened from inside the upgrader itself? It sounds like it only deleted some of the old facebook files. I think if you manually delete sources_custom/users.php, that will get rid of what is calling this.
Avatar
The upgrader still worked but the site went down, even in safe mode.

When I first ran the integrity check I only checked off the files it said where outdated…thinking that maybe the alien ones were from the facebook addon and still needed. After getting rid of all the alien files it works great now.


Avatar
Fixed it  :thumbs:

Deleted all files the integrity checker said were alien not just the ones that have been superseded (except of course the ones I knew I put there/need)

Edit:

May have been a bad idea to delete the facebook block files.

A block file is missing: main_facebook_like (sources/blocks/main_facebook_like.php or an overridden equivalent to this path)



Last edit: by Brian Hay


Avatar
We have a successful upgrade!

Some theme parts weren't upgraded right, but that's minor stuff really, and is something I was expecting - ie, some colors of my theme were not kept thus reverting to the default theme settings.

Anyways, looking good, looking good. I am going to go through my site and check things out, and then probably reopen it for live use tomorrow!

Points, they be coming your way.

Avatar
I just did an upgrade from version 7.1.6 to RC2. The following installed add-ons were not updated from version 7 to 8(-RC2):

Admin search stemmer
GeSHi
lightbox2
ocDatamap
ocUsermap


Shouldn't these be automatically upgraded the add-ons are installed at the time of the upgrade?

Bob


Last edit: by BobS
Avatar

BobS said

I just did an upgrade from version 7.1.6 to RC2. The following installed add-ons were not updated from version 7 to 8(-RC2):

Admin search stemmer
GeSHi
lightbox2
ocDatamap
ocUsermap


Shouldn't these be automatically upgraded the add-ons are installed at the time of the upgrade?

Bob


Non-bundled addons are outside the scope of the upgrader and may need re-installing manually. I suspect all but lightbox2 are v8 compatible but I've not checked.

What the upgrader will do is detect the alien files and offer to delete them for you.

I would agree that some kind of non-bundled addon versioning manager would be nice.

Show 2 replies



Avatar
Just noticed that the lightbox is giving me two overlays - old style and new style:

2012-03-29_1816 - BobS702's library

Bob
Avatar

BobS said

Just noticed that the lightbox is giving me two overlays - old style and new style:

2012-03-29_1816 - BobS702's library

Bob


You'll need to remove the old lightbox2 addon. It's now surplus to requirements, lightboxes are a standard feature, powered via the new unified overlays system.

Show 1 reply



Avatar
Calendar display is still incorrect and inconsistent.

Below are images of the box from my live site (left) and test site (right) which is a clone of my live site. Notice the time discrepancy.

     













Below is the calendar detail for the test site (right, above). Again, notice that the time is not consistent:


Finally, when clicking the "edit" link in the calendar detail, I get the following error:

Code

An error has occurred

PHP ERROR [1] Call to undefined function find_timezone_end_minute() in cms/pages/modules/cms_calendar.php on line 348 (version: 8-RC2, PHP version: 5.2.17, URL: /cms/cms_calendar/_ed/12.htm)

Below is the stack trace:

Expand: Stack Trace Stack Trace




Bob

Show 3 replies


Avatar
Changed this topic to the linear view and quoting didn't work. Clicking the button causes the page to scroll down to the quick reply box, but the box remains quote free.
Avatar
This topic is covered in this thread starting with this port: View topic: ocPortal.com upgraded - ocPortal.com

As you can see, not everyone is anamored with the way quotes now works but, if you try it, it does seem to work.

Bob
Avatar
Yeah, I read that after I made the above post.



Avatar
While I am still waiting on/trying to figure out how I fix the member profile issue, I've found another.

Avatar
This one was actually discussed in the v8 RC1 released thread... silly me. Simple cache cleaning fixes it.
Avatar
Nope, was wrong.

Cleaning the cache didn't solve this probllme. It soon came back to haunt me.


Show 1 more reply


Avatar
The entry points selection that you typically get when making a new menu link seems to be absent.


Show 29 more replies

There are too many online users to list.
Control functions:

Quick reply   Expand