HTML Logo by World Wide Web Consortium ( Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.

ocPortal 8.1.3 released - Comments

Login / Search

 [ Join | More ]

ocPortal 8.1.3 released

Posted 09 August 2012, 12:10 PM

8.1.3 released. Read the full article for a list of changes, and upgrade information.

Read more

All good!


Updated to 9.0 - how do I go back?

I updated to 9.0 and my site looks horrible! I want to revert back to the previous version. How do I do it?

Problem with bottom_rss

After upgrading from 8.1.2 to 8.1.3 I get the following error in bottom_rss block:

XML error when parsing RSS/Atom stream: not well-formed (invalid token) at line 1

using the rss stream which shows the latest 20 catalogue entries within a 5 day margin.

It worked right fine till the upgrade. Adding a new block and switching any caching off didn't help either, I get the same error in preview as well.

Is it happening still? I tried to reproduce on my local install and couldn't, and couldn't see an error on your site (I could see a scroller at the top).

I wonder if maybe it was failing due to the site still being closed before. In that scenario it is possible the RSS would be a closed message and fail to load up (as it's going through an unauthenticated web lookup). We normally try and prevent that by not subjecting the server itself to the closed site message, but some network configurations can make that undetectable.
Hello Chris,

tried from two different computers from IE9, FF and Opera. Get the same error on both. :S
I know I've looked directly on the server a couple of of times – if I still have access please ping the PT or ticket with the details to help me locate, and mention where to go on the site to reproduce the problem.


Another thing to try is see if maybe your server is blocked from connecting to itself. If it somehow got in the IP ban list that could happen.

See what happens when you type this into OcCLE:


:echo http_download_file('');
I just checked it out and it works properly now. Don't know what was the problem but I didn't do anything. Guess it had something to do with caching. Works perfect now, sorry to bother you. As always your response was instant. ocportal ftw  :thumbs:
I'll bother you more in the near future when I'll have to retheme everything for 9,  :lol:  

1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: