HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


ocPortal 8.0.1 released - Comments

Login / Search

 [ Join | More ]
 

ocPortal 8.0.1 released

Posted 06 May 2012, 8:09 PM

8.0.1 released. Read the full article for a list of changes, and upgrade information.

Read more


Avatar
During the upgrade I got this when I did the file integrity scan.

These files are actually missing and need uploading (you can find them in the manual installer ZIP for the version you're running):

uploads/auto_thumbs/index.html
uploads/auto_thumbs/.htaccess

Well I can't find them????
Avatar
They always go missing during upgrades and I've got so used to that report that I automatically transfer them across - even before it tells me to!  :lol:

You will certainly find them in the 'manual' installer if you downloaded it to your computer.

 :thumbs:
Avatar
Ya , I got them now.
I'm not even gonna say what I did the first time  :$
Just pretend I didn't even make this post :lol:
Thanx
Avatar
 :lol:  :lol:  :lol:  :lol:  :lol:

 :thumbs:




Avatar
Nice to see v8 out the door! Just upgraded chriswarbo.net from 7.something :)

The "theme upgrader" gives a fatal error since it doesn't have permission over some of my templates_custom Javascript files, so I'll have to run fixperms when I get home. Hasn't caused any problems though.

Avatar

When trying to add a comment to an event date, the "preview comment" works but posting the comment does not. IE8 gives the following error message:

 

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E)
Timestamp: Tue, 8 May 2012 20:11:07 UTC


Message: Object doesn't support this action
Line: 2016
Char: 196
Code: 0
URI: http:///site/calendar/view/leadership-workshop.htm?day=2012-05-19&date=2012-05&back=month


Message: Object doesn't support this action
Line: 2016
Char: 196
Code: 0
URI: http:///site/calendar/view/leadership-workshop.htm?day=2012-05-19&date=2012-05&back=month


Message: Object doesn't support this action
Line: 2016
Char: 196
Code: 0
URI: http:///site/calendar/view/leadership-workshop.htm?day=2012-05-19&date=2012-05&back=month


Message: Object doesn't support this action
Line: 2016
Char: 196
Code: 0
URI: http:///site/calendar/view/leadership-workshop.htm?day=2012-05-19&date=2012-05&back=month

 It also might be related to forum postings as well. I cannot comment on topics previously created using 'quick reply:

 

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E)
Timestamp: Tue, 8 May 2012 20:13:12 UTC


Message: Object doesn't support this action
Line: 730
Char: 196
Code: 0
URI: http:///forum/topicview/misc/general-chat/test-message.htm


Message: Object doesn't support this action
Line: 730
Char: 196
Code: 0
URI: http:///forum/topicview/misc/general-chat/test-message.htm


Message: Object doesn't support this action
Line: 730
Char: 196
Code: 0
URI: http:///forum/topicview/misc/general-chat/test-message.htm


Message: Object doesn't support this action
Line: 730
Char: 196
Code: 0
URI: http:///forum/topicview/misc/general-chat/test-message.htm


Message: Object doesn't support this action
Line: 730
Char: 196
Code: 0
URI: http:///forum/topicview/misc/general-chat/test-message.htm

Avatar
It must be my lucky day, I learned an IE bug I never knew about over a very enjoyable hour. I'll have to thank Microsoft sometime ;).

All the templates in the attached zip need extracting to themes/default/templates/.
Attachment
» Download: Archive.zip (51 Kb, 398 downloads so far)
Avatar
You mean that these 10 templates actually had the 'Variable + Assignment + Element + HandlerProperty + CallOperator + Argument ' that triggers the error, and that you had to hunt down 'where' in the several hundred ocP templates?



 Whoooosh! exhales


Congrats!

 :thumbs:
Avatar
Hunting down wasn't too bad, a regular expression search can do that. Trying to work out what the heck was going on before finding that discussion was another matter ;). IE loves to give completely cryptic arbitrary errors when its Javascript engine fails to work properly, and the fact that this one was so fragile made it hard to narrow down.




Avatar
Live site upgraded.

Personally, all previous 'issues' are no longer a cause for concern. IF any gremlins creep in, they will be reported under a new post.

Congrats!

 :thumbs:

Avatar
Oke after upgrading I got a problem with the notifications. After removing messages from profile they are  stay in the pm box on the frontpage.



Stacktrace:
File     '/home/talkpoint/domains/talkpoint.nl/public_html/sources/fa
ilure.php'
 Line     '684'
 Function     'get_html_trace'
 Args    

 File     '/home/talkpoint/domains/talkpoint.nl/public_html/sources/gl
obal.php(211) : eval()\'d code'
 Line     '979'
 Function     '_fatal_exit'
 Args    
 object

 File     '/home/talkpoint/domains/talkpoint.nl/public_html/sources/fa
ilure.php'
 Line     '237'
 Function     'fatal_exit'
 Args    
 object

 File     '/home/talkpoint/domains/talkpoint.nl/public_html/sources/gl
obal.php(211) : eval()\'d code'
 Line     '939'
 Function     '_generic_exit'
 Args    
 object

 'WARN_SCREEN'

 File     '/home/talkpoint/domains/talkpoint.nl/public_html/sources/oc
f_topicview.php'
 Line     '33'
 Function     'warn_exit'
 Args    
 object

 File     '/home/talkpoint/domains/talkpoint.nl/public_html/forum/page
s/modules/topicview.php'
 Line     '89'
 Function     'find_post_id_url'
 Args    
 60

 File     '/home/talkpoint/domains/talkpoint.nl/public_html/sources/zo
nes.php'
 Line     '424'
 Function     'run'
 Class     'Module_topicview'
 Object     Module_topicview::__set_state(array( ))
 Type     '->'
 Args    

 File     '/home/talkpoint/domains/talkpoint.nl/public_html/sources/si
te.php'
 Line     '1,016'
 Function     'load_module_page'
 Args    
 'forum/pages/modules/topicview.php'

 'topicview'

 File     '/home/talkpoint/domains/talkpoint.nl/public_html/sources/si
te.php'
 Line     '785'
 Function     'request_page'
 Args    
 'topicview'

 true

 File     '/home/talkpoint/domains/talkpoint.nl/public_html/forum/inde
x.php'
 Line     '51'
 Function     'do_site'


Avatar
Ah, thanks. This is an old issue, it's just that notifications make you more likely to delete PTs. Please ignore or empty block cache, until next release.

Avatar
Thanks Chris.

Avatar
Please keep replies on these upgrade topics to issues directly relating the upgrade. There's been a recent tendency for users to report every bug in an upgrade announcement topic, which makes these topics into a real tangle.

1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: