HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Sneak Preview of Dark Marshall

Login / Search

 [ Join | More ]
 Add topic 
Posted
Item has a rating of 5 (Liked by FletchLiked by JeanLiked by BobSLiked by Robbie GoacherLiked by Chris GrahamLiked by kennoLiked by sholzyLiked by Brian Hay)  
Rating:
#82992 (In Topic #17279)
Avatar

Community saint

A Modifcation of the Default Theme

 Hi all,

Since I was home probably less than a week the whole month of March I didn't have a lt of time to do stuff with ocPortal lately but the last couple days I decided to play around with modifying the default theme. I am not finished it yet (there are so many dang button images to do) but I am outta town again tomorrow for the long weekend so I won't finish this till next week sometime but I thought I would provide some teasers to peak interests.

I started with the default theme and made it dar then started changing CSS and images manually. I wanted to get a feel for how the default theme works and all its CSS options. Some of which are dang confusing I must say! lol

Anyway I am over half way done at least (I think lol) so here are some of the images (including a gallery shot of some of the finished buttons which I am not sure where some of them even show up???? lol).

This will be released freely when finished. Some images used in buttons etc are free icons from the web others I made or modified.

I have not settled on a name for the theme yet but I think it may be Dark Marshall but we shall see.

on another note: @Chris if you read this where can I find the CSS and images for the WYSIWYG editor?

It may not be a great theme for people with colour blindness but for the others I hope you like!

Front Page ButtonGallery Forum1Forum2


Last edit: by Duck
Back to the top
 
Posted
Rating:
#82993
Avatar

Community saint

Chris I dunno if I discovered a bug or what but when trying to add attachments to the previous post I tried adding all 4 at first and only one showed up when publishing. I had to add each image 1 at a time then save and edit the post to add the others. Also note that when Adding more than 1 attachment every Attachment box (other than the first one) had 2 Upload slots per attachment box. I am using a very outdated FF though so it could be an issue.
Back to the top
 
Posted
Rating:
#82994
Avatar

Community saint

Nice looking theme, Duck.

Bob
Back to the top
 
Posted
Rating:
#82998
Avatar

Community saint

Good job Duck! Good Job!

Legends of Nor'Ova: A site powered by ocPortal; home of the Legends of Nor'Ova tabletop RPG wiki and community.

Like ocPortal? Want to thank Chris and gang somehow? Then help out in the chat room! It really needs your help! Just open it in a tab everytime you open your web browser, and when you hear a "ding", check it out!

"Those who want help should first be willing to give help."
Back to the top
 
Posted
Rating:
#83002
Avatar

Community saint

Like!

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#83003
Avatar

Community saint

:thumbs:


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#83006
Avatar

Community saint

Very good work, Duck!:thumbs:

Love the rusted metal plates look.

Jean
Back to the top
 
Posted
Rating:
#83011
Avatar

Community saint

Thanks All. I thought it would be a good example of what can be done to the default theme (that people like complaining about) with a little work

@Jean I can take credit for the plate designs themselves that was a background I found on the web I thought suited my colour scheme. I'll posts the address later. Lots of good free backgrounds there.
Back to the top
 
Posted
Rating:
#83036
Avatar

Chris I dunno if I discovered a bug or what but when trying to add attachments to the previous post I tried adding all 4 at first and only one showed up when publishing. I had to add each image 1 at a time then save and edit the post to add the others. Also note that when Adding more than 1 attachment every Attachment box (other than the first one) had 2 Upload slots per attachment box. I am using a very outdated FF though so it could be an issue.

There are so many posts recently, I have to heavily skim-read so good thing I saw the word 'Chris' :lol:.

Of course, you might be talking about some other Chris, maybe Christopher Robin from the Winnie the Pooh books, or Saint Christopher, or maybe the great English actor named Christopher Biggins. But I think you meant me :lol:.

Anyway, I could reproduce the problem on Firefox 3.6, but it is over 2 years old and the latest is 11. I appreciate some people have not upgraded yet, but it is EOL'd at the end of this month so I definitely advise upgrading. I'll see if there's a simple fix :). I did find and fix another small bug whilst testing though, and that affected everyone (not showing multiple upload progress dialogs simultaneously correctly).


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#83037
Avatar

Good, fixed :).


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Item has a rating of 5 (Liked by Chris GrahamLiked by Tisnart)  
Rating:
#83594
Avatar

Community saint

Theme is almost ready for release. There is lots more I'd like to do to it but I've put sooo much time into it already I will release it as is and maybe improve it later and make a version2 who knows?
Last thing I want to do before release is make a proper PSD as well as a blank of the Logo so Users can edit the Logo easily. Maybe a few more minor CSS tweaks too.
Back to the top
 
Posted
Rating:
#84200
Avatar

Well-settled

I really like this theme.
Very nice work Duck, your amazing :)

Making games is fun…having people play them is the reward!
Back to the top
 
Posted
Rating:
#84323
Avatar

Well-settled

Hey Duck,
I just added your theme to a new site I am doing and I really like what I'm seeing so far.
(Now I'm having problems with the forum but I don't think that's anything to do with the theme)

Making games is fun…having people play them is the reward!
Back to the top
 
Posted
Rating:
#84339
Avatar

Community saint

I also use this theme now for a new site i build up. Theme is working under 8 RC7 without problems.
I changed some pieces, like the background who is now fixed with a 100% width. This mean the middle screen is alway's the middle point on screen. Also I use a header to 300 px hight.

I will thanks Duck for the very nice theme and color scheme.


Harry.


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#84352
Avatar

Well-settled

Harry-S said

I also use this theme now for a new site i build up. Theme is working under 8 RC7 without problems.
I changed some pieces, like the background who is now fixed with a 100% width. This mean the middle screen is alway's the middle point on screen. Also I use a header to 300 px hight.

I will thanks Duck for the very nice theme and color scheme.


Harry.

Harry, (or anybody)
could you tell me how to the header to 300 px height ?
Thanx
Gerald


Making games is fun…having people play them is the reward!
Back to the top
 
Posted
Rating:
#84356
Avatar

Community saint

Hi gerald,

you need to make changes the in the global .css  see this picture.



http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#84360
Avatar

Well-settled

Thank you harry :)
I did that once already and ended up with a huge error after I saved it.

PHP NOTICE [8] Undefined offset: 2 in adminzone/pages/modules/admin_themes.php on line 984 (version: 7.1.6, PHP version: 5.3.8, URL: /adminzone/index.php?page=admin_themes&type=edit_css&theme=D
arkMarshall-copy&file=global.css)

I just tried it again and got the same error…ahhhhhh!
I screwed something up

Making games is fun…having people play them is the reward!
Back to the top
 
Posted
Rating:
#84364
Avatar

Community saint

I see the fault has to do something with the global.css of the theme from Duck.  I have no clou how to make this working at the moment. I use the same global.css only under version 8 RC7


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#84424
Avatar

Tisnart said

Thank you harry :)
I did that once already and ended up with a huge error after I saved it.

PHP NOTICE [8] Undefined offset: 2 in adminzone/pages/modules/admin_themes.php on line 984 (version: 7.1.6, PHP version: 5.3.8, URL: /adminzone/index.php?page=admin_themes&type=edit_css&theme=D
arkMarshall-copy&file=global.css)

I just tried it again and got the same error…ahhhhhh!
I screwed something up

This error should not be possible :S. I have really checked over the code very carefully, across a few versions. If you'd like me to take a look, I'll need admin zone access. I'm more than a bit curious to be honest.

EDIT: However first try uploading the adminzone/pages/modules/admin_themes.php file from the 7.1.6 manual installer package.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#84459
Avatar

Well-settled

Hey Chris,
I did what you said and uploaded the admin_themes.php file and I got this error message as soon as I tried to edit the global css

error message

An error occurred when loading this screen onto the web browser. You are being notified of this as you are staff. If you believe this is a bug in the website software, please contact ocProducts with full details. More details are available in your browser's error console. The error was:

5: d.getElementById(id) is null
http://tisnartgames.com/data/editarea/edit_area_full.js

I will send you the admin zone access.


Making games is fun…having people play them is the reward!
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Expand