HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


[RESOLVED] - Background images - how to?

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#67117 (In Topic #14324)
Avatar

Community saint

I am trying out an idea - trying to 'bleed' the banner header into the top of the actual page on display. There has been a limited amount of success; the brick wall I have hit is the ability for me to differentiate between displays for pages with a 'left_panel' and pages that are designated 'wide'. The attachment more or less says it all …



Any smart coders (Jean, mythus, Eric, Brian - ermmmm Staff?) out there that can help out with this one?

TIA


Last edit: by Fletch

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#67119
Avatar

Community saint

Just a guess here Fletch but is the problem that your background image is floating left and not wide enough without the left panel? Maybe try floating it rite and then see if the white space appears on the left in wide view. If it does maybe make your image wider, float it rite and hide the overflow.
Back to the top
 
Posted
Rating:
#67121
Avatar

Community saint

Brian Hay said

Just a guess here Fletch but is the problem that your background image is floating left and not wide enough without the left panel?
772px is not wide enough without the left_panel, and it is aligned left by default.

Brian Hay said

 Maybe try floating it rite and then see if the white space appears on the left in wide view.
Floating it right doesn't help move it across the page to the right.

Brian Hay said

 If it does maybe make your image wider, float it rite and hide the overflow.
Making the image wider (980px - width of the page) displays it fine on the 'wide' pages (Forum, Admin, CMS, etc.), but pushes it off the page to the right for all the others, because the left of the image butts up against the left_panel.

So far it is …

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#67125
Avatar

Community saint

OK, guys - cracked it!

It was staring me in the face:
  • copied the 'user' theme that I was using for all pages
  • exported/imported to a new theme
  • edited the CSS for .global_middle, .fake_middle_continuation in the new theme, replacing the 772px graphic with the one of 980px, the width of the page

Result: all working seamlessly. Can't even see the join!!

 :lol:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#67138
Avatar

Community saint

Glad you nailed it Fletch!

I was looking at your problem last night, and could not understand what you meant by "Viewport" wide and not wide. Maybe it's my French or I'm missing something important I did not know existed!:$
Back to the top
 
Posted
Rating:
#67142
Avatar

Community saint

Jean said

Maybe it's my French or I'm missing something …
You have the jump on me there, Jean. My French is non-existant!

I actually meant 'window' when talking about the display. Had several browser windows open at the same time … my excuse!

The problem is only partially resolved. I am still getting the problem display when viewing IOTDs, and cannot find where the 'wide=1' bit is called (except that it is referenced in the initial installation - install.php), and I really don't want to mess about with that element in case I zapppp! something else!





Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#67144
Avatar

Community saint

Fletch said

Jean said

Maybe it's my French or I'm missing something …
You have the jump on me there, Jean. My French is non-existant!

I actually meant 'window' when talking about the display. Had several browser windows open at the same time … my excuse!

The problem is only partially resolved. I am still getting the problem display when viewing IOTDs, and cannot find where the 'wide=1' bit is called (except that it is referenced in the initial installation - install.php), and I really don't want to mess about with that element in case I zapppp! something else!






LOL,Fletch!
This is exactly the problem I facing now, as I'm trying to finish my first theme with version 6. I'm defeated by this one screen. Everywhere else my "global_middle_ph" behaves exactly as I set it up, except here it is "wide" and I cannot find the source for it.

Let's see if we can figure it out!
Back to the top
 
Posted
Rating:
#67145
Avatar

in v6 there's a way to disable the wide feature, I think I showed how in the recent designer themes tutorial we did


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#67146
Avatar

Community saint

Chris Graham said

in v6 there's a way to disable the wide feature, I think I showed how in the recent designer themes tutorial we did
Thanks Chris!:thumbs:

Indeed you did:

Chris said

If you have incorporated panels and have made the assumption that they will never be blank/hidden, then you must put supports_wide=0 into your themes/<theme>/theme.ini file.
I've been following this tutorial set with great interest and was able to accomplish much of my new theme by listening to the videos plus my trials and errors, but I missed that important feature.

IT WORKS!

I'l be posting my new theme and comments soon!

Thanks Again!:)
Jean
Back to the top
 
Posted
Rating:
#67148
Avatar

Community saint

Jean said


IT WORKS!


I can confirm that. Indeed, I will repeat it:

IT WORKS!



Crackin' Cheese, Gromit!


Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: