HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Max file size upload?

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#83067 (In Topic #17291)

Non-joined user

I do not know how to increase max_upload

I can't upload the brave new world theme it says it is too large. It takes me to the admin page where I can change the size but not for the overall site.  I need to change the max_upload parameter? but do not know where that is...any help??
Back to the top
 
Posted
Item has a rating of 5 (Liked by Jean)  
Rating:
#83069
Avatar

Community saint

You can try changing this in your site's .htaccess file. Look for this block of code and change the max, as needed:

Code

<IfModule mod_php5.c>
# ocPortal needs uploads; many hosts leave these low
php_value post_max_size "65M"
php_value upload_max_filesize "65M"

However, you will not be able to increase it beyond the maximum size your host allows.

If this doesn't work, you can try changing the maximum in the php.ini file in your home directory. Look for this:

Code

; Maximum allowed size for uploaded files.
upload_max_filesize = 64M

Again, you will not be able to exceed your hosts maximum settings. You would have to check with them if neither of these works.

Bob
Back to the top
 
Posted
Item has a rating of 5 (Liked by Jean)  
Rating:
#83070
Avatar

Community saint

Bob's advice is sound and you should follow it. But just in case, I shall amplify a bit more …

Admin Zone Tools PHP info

>> PHP Credits

>> Configuration

>> PHP Core

Scroll down and check the following …
post_max_size            128M   128M
upload_max_filesize    128M   128M

Those two values are the sizes set by my web hosts. If your values are set too low, you will suffer from the issue you are having at the moment.

To change this it would be best to talk to your web host who will advise how best to go about it.

The easiest way to do this is to access the file via your cPanel. It is probably grouped under Software/Services, and is probably called 'php.ini (QuickConfig)'. Set those two values at a reasonable level, but not too high or your hosts will go all pear-shaped about it.

Save the changes, go back to Admin, refresh, and you should be good to go!

Shout if it all goes TU.

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: