HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Lost Top Menu To A Side Menu After Upgrade to 9.0.1

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#90985 (In Topic #18351)
Avatar

Fan in action

In Menu Block - Top Option doesn't change menu positioning

I had trouble with the Upgrader.php accepting my pw earlier. Got that fixed so I thought best to do an upgrade. Once I completed upgrade to 9.0.1 I lost my 'Top Menu'. I choose the option in the drop down but it doesn't seem to have any affect. 
Back to the top
 
Posted
Rating:
#90989
Avatar

Community saint

Not sure whether you are referring to the 'menu' or the 'top panel' Ernie, as this has cropped up recently in relation to a version 9.x.x installation.

Take a look at View topic: [SOLVED!] Forum Bars in a non-wide forum - ocPortal.com to see if that thread answers your issue

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#90990
Avatar

Fan in action

I created menus & chose it as a top menu rather than embossed, drop down, etc.

None of my menus are positioned as top menus, but rather off to the left in a column.

Plus my footer went all wonkie as well! :)
Back to the top
 
Posted
Item has a rating of 5 (Liked by Chris GrahamLiked by Jean)  
Rating:
#91028
Avatar

Well-settled

I recently added top menu's to my site, and I had to edit several of the templates.  v9 hides top menu's on most pages if the Forums and other social functions are installed.  The main panel_top (going off memory) has code to hide itself unless you are on the Forums page and a few others.  And the Redirects from most pages other than Forum go to this main panel_top.

I had to go in an remove the code to "hide" the panel_top.  I also created a different panel_top for my non-Forums page (leaving the member bar that  is default in the current panel_top).  After doing that and changing a few Redirect, I was able to get it to work as expected.

So the long story is, check your panel_top.  :)
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: