HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Following tutorial appears to have broken my site

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#101447 (In Topic #19899)
Avatar

Fan in training

Hi,

I have just followed this tutorial. my site is now looking strange with menu's being badly messed up. Could someone take a look and see if they can spot a mistake I may have made? or if their is a way i can fix it? i was trying to make the site transparent so that the background image can be see fully. my website address is www.xg-hq.com/site/index.php 
Back to the top
 
Posted
Rating:
#101448
Avatar

I'm getting "502 Bad Gateway" when I try and access your domain actually.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#101450
Avatar

Fan in training

Chris Graham said

I'm getting "502 Bad Gateway" when I try and access your domain actually.
yeah sorry about that, my web server host was performing a server hardware upgrade, its back online now if you would like to take a look?
Back to the top
 
Posted
Rating:
#101451
Avatar

In 3 places you've started comments with /* but not ended them with */. Hence, large portions of code are disabled due to the onrunning comments.



To determine that, I went to:
http://xg-hq.com/site/index.php?keep_no_minify=1
(so the CSS would not be minified)

Found the compiled (but non-minified) global.css's URL, and validated it: The W3C CSS Validation Service


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#101453
Avatar

Fan in training

ah excellent, i'll get on to that and get it fixed. i'm used to working with game servers and when commenting things out its usually a full line with '//' and not needing to put any thing after.

thanks for the help i will be for ever grateful :)
Back to the top
 
Posted
Rating:
#101454
Avatar

Fan in training

Chris Graham said

In 3 places you've started comments with /* but not ended them with */. Hence, large portions of code are disabled due to the onrunning comments.



To determine that, I went to:
http://xg-hq.com/site/index.php?keep_no_minify=1
(so the CSS would not be minified)

Found the compiled (but non-minified) global.css's URL, and validated it: The W3C CSS Validation Service
I have carried out the above, however something is still not right, some changes have occured for what i wanted to achieve but its still left the munu's looking very bad. Plus when I'm in admin mode viewing the site all the left panels take over the whole page, making the central and right panels un-viewable. i could view these until I made the above changes.
Back to the top
 
Posted
Rating:
#101458
Avatar

Fan in training

I have now fixed this, i started the theme from scratch followed the tutorial again and it worked perfect…..
Now to find a tutorial to change the font colors or the colors of box side panels titles to match the center panel titles
Back to the top
 
Posted
Rating:
#101462
Avatar

Community saint

Have a look for items like .global_side_panel .box, .box.nested in your global.css and marry them up.

Use the ocPortal built-in page rendering tool (find it in the footer), or your browser's developer tool (like Firebug in Firefox) to track down each element, and that will make life a lot easier for you.

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#101465
Avatar

Fan in training

its the actual webform for creating a new account. After going to www.xg-hq.com then clicking on 'login' then 'create account'. That takes you to a page to agree to t&c's page then after agreeing it takes you to the next page which has the webform for creating account. The webform is black and so is the text with the questions.

I've tried changing as many of the text colors in the global.css but still having no luck.

Thanks very much for providing the help, but i appear to really be struggling and this is the last thing to fix to have the theme as I need it.
Back to the top
 
Posted
Rating:
#101469
Avatar

Community saint

In your custom_theme, look in forms.css for the following, and apply the changes where I have indicated …

.form_table .required {
   background-color: {$GET,required_background} !important;
   {$BETA_CSS_PROPERTY,background-image: linear-gradient(to bottom\, {$GET,required_2_background}\, {$GET,required_background}) !important;}
}

>>>change to<<<

.form_table .required {
/*   background-color: {$GET,required_background} !important; */
   background-color: #FFFFFF !important;
/*   {$BETA_CSS_PROPERTY,background-image: linear-gradient(to bottom\, {$GET,required_2_background}\, {$GET,required_background}) !important;} */
}

AND

.form_table_field_name, .form_table_field_input, .form_table_huge_field,
th.form_table_field_name, /* Extra specificity to take precedence over th.de_th */
.form_table_field_spacer>th, .form_table_field_spacer>td, .form_table_description_above_cell, .form_table_description_under_cell
{
   border: 1px dotted {$GET,pale_border};
   color: {$GET,slightly_seeded_text} !important;
   padding: 0.5em;
   background-color: {$GET,area_background} !important; /* !important is so has priority over .de_th */
   {$BETA_CSS_PROPERTY,background-image: linear-gradient(to bottom\, {$GET,area_background}\, {$GET,area_2_background});}
}

>>>change to<<<

.form_table_field_name, .form_table_field_input, .form_table_huge_field,
th.form_table_field_name, /* Extra specificity to take precedence over th.de_th */
.form_table_field_spacer>th, .form_table_field_spacer>td, .form_table_description_above_cell, .form_table_description_under_cell
{
   border: 1px dotted {$GET,pale_border};
   color: {$GET,slightly_seeded_text} !important;
   padding: 0.5em;
/*   background-color: {$GET,area_background} !important; */ /* !important is so has priority over .de_th */
   background-color: #FFFFFF !important;
/*   {$BETA_CSS_PROPERTY,background-image: linear-gradient(to bottom\, {$GET,area_background}\, {$GET,area_2_background});} */
}

Does that help?

 :thumbs:




…also (same CSS file) …
.required_field_warning {
   border: 1px solid {$GET,standard_border};
   overflow: hidden;
   padding: 0.5em;
   background-color: {$GET,required_background};
   font-weight: bold;
   font-size: 0.85em;
   margin: 28px auto;
   {+START,IF,{$NOT,{$MOBILE}}}
      width: 11em;
   {+END}
   {$BETA_CSS_PROPERTY,border-radius: 5px;}
}

>>>change to<<<

.required_field_warning {
   border: 1px solid {$GET,standard_border};
   overflow: hidden;
   padding: 0.5em;
/*   background-color: {$GET,required_background}; */
        background-color: #FFFFFF;
   font-weight: bold;
   font-size: 0.85em;
   margin: 28px auto;
   {+START,IF,{$NOT,{$MOBILE}}}
      width: 11em;
   {+END}
   {$BETA_CSS_PROPERTY,border-radius: 5px;}
}

 :thumbs:


Last edit: by Fletch

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#101470
Avatar

Fan in training

thanks very much, that worked perfectly. Look's like I will get the site open for the new year :)

I am most grateful for your help. Hope you have a great xmas.
Back to the top
 
Posted
Item has a rating of 5 (Liked by Jean)  
Rating:
#101471
Avatar

Community saint

Call me Santa …  :christmas:  … but I'm glad it worked for you.

Merry Christmas!

cheers-single

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: