HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Insert functions are not working

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#24580 (In Topic #5845)
Avatar

Fan in action

 I get no response when I click on the insert special character, insert image and insert table buttons.  The insert ruler function works immediately.  Nothing happens although there is sometimes a message that it is transferring data for ocportal and my internet connection shows some minimal activity.  No egg-timer appears to indicate it is transferring so I have no idea what is happening, if anything.  How long should I wait? I am on dial-up at about 35Kb/sec which is slow but usually I don't have to wait long for something to appear.
Back to the top
 
Posted
Rating:
#24582
Avatar

The first thing to check is whether your web browser is reporting any Javascript errors. Also, does this problem happen on all ocPortal sites including this one? What web browser are you using?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#24585
Avatar

Fan in action

There is sometimes a message - javascript;void(0) I'm using Mozilla Firefox. Java & Javascript are enabled. Yes it's happening on this site also.All the table function buttons are disabled (not highlighted). When I used IE6 I got this error message:-EXCEPTION: couldn't get doc in initFrame - delaying and returning. Now most of the buttons are disabled when using IE6


Last edit: by adventure4th
Back to the top
 
Posted
Rating:
#24589
Avatar

Well-settled

I'm also having problems with links.

I was pointed in the direction of comcode help and if I manually type it in then it works and creates a link. But if I highlight text then click the link image in WYSIWYG it doesn't seem to work properly.

Likewise have just noticed it I disable WYSIWYG and click the "add link" button, it gives me a prompt for the link, then the name, then it vanishes and absolutely nothing happens.

I'll try it on this site.

Biggly

Mmm, looks like that may be working, except it's bright blue to me, suggesting not a link I've visted recently. I'll preview.. That's interesting, it does look like it's a working link on this site. So why not on mine?

I'll see what happens if I disable WYSIWYG.. and try another link..  No, that did the same as my site, the screen suddely jumps to the top but there is nothing on the page?

Getting a little error in the bottom left corner, line 328, char 4, Error: Cant move focus to the control because it is invisible, not enabled or of a type that does not accept the focus, code 0, followed by the url.

I do have IE security set fairly high but this sounds more like the site than my browser?


D





Back to the top
 
Posted
Rating:
#24590
Avatar

Well-settled

Remind me, is there a permission somewhere for links, for it there is it's quite likely I set it for 'no', to reduce spam?


D
Back to the top
 
Posted
Rating:
#24592
Avatar

adventure4th, unfortunately I can't reproduce your problem. It may well be a connection issue, as the WYSIWYG component does need to transfer many files dynamically.

dateofbirth, I'm not sure what could be happening on your site wrt WYSIWYG.
However I can reproduce your IE problem. There's a bug in IE that occurs when you immediately close the WYSIWYG editor and then try to manipulate the post using Javascript – we'd worked around that bug for attachments, but not realised we'd need to do for buttons also – this will be fixed in the next patch release.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#24624
Avatar

Fan in action

Do you know how many files and what the total size is in Kb?  There is activity happening on the internet connection but I don't know what it is.  I thought it must just be the normal communication between connections but if it is actually downloading then I will wait for it to download.  Does it have to download each time or only once?  If I know how big the file is then I can watch the connection which will give me some idea of how long it takes.  Unfortunately I am on a rural farm up north in NZ where dialup is slow and wireless broadband is not possible.
Back to the top
 
Posted
Rating:
#24640
Avatar

Our capacity to help here is somewhat limited as we didn't create the actual WYSIWYG editor component – it's a very slightly modified copy of AreaEdit.

Taking the character map as an example, there are files in data/areaedit/plugins/CharacterMap. Quite possibly it is loading up popups/select_character.html dynamically (16kb).


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#24654
Avatar

Community saint

Chris Graham said

Our capacity to help here is somewhat limited as we didn't create the actual WYSIWYG editor component – it's a very slightly modified copy of AreaEdit.

Taking the character map as an example, there are files in data/areaedit/plugins/CharacterMap. Quite possibly it is loading up popups/select_character.html dynamically (16kb).

That almost looks like IPB's rich text editor more then yours.

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#24698
Avatar

Fan in action

Can't be the file size then.  I left it on for over 2 hours without any result.
Back to the top
 
Posted
Rating:
#53107
Avatar

Fan in training

I am getting the same "EXCEPTION: couldn't get doc in initFrame - delaying and returning." result the WYSIWYG worked perfectly untill today it just gave me that popup. maybe its cause i cleared my cache earlier but i don't know.
Back to the top
 
Posted
Rating:
#53125
Avatar

Please try this data/areaedit/htmlarea.js file. It won't fix the problem, but it may give a better error message.

Attachment
» Download: htmlarea.js.zip (26 Kb, 123 downloads so far)


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: