HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Permissions question/members posting videos in forum

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#93202 (In Topic #18645)
Avatar

Community saint

Hi all,

I am still working out the kinks of moving to a new server. I think some permissions have defaulted, but can't for the life of me find out how to fix the problem.

Up until the move to the new server, all members could upload videos into their posts in the OCP forum. Now, administrators are the only ones who can. In addition, administrators can not edit a members post to include the video; however, when editing, the correct code is present in the "source view".

I thought this was in admin zone > Security > privileges, but that does not seem to be the location.

Any help is greatly appreciated.

Forgot...this also seems to affect the ability of members to upload avatars. The avatar is in the file uploads/ocf_avatars , but it does not show on the site. It is also in the database members table.

My version is 8.1.3


Last edit: by psydoc
Back to the top
 
Posted
Rating:
#93203
Avatar

Community saint

psydoc said

In addition, administrators can not edit a members post to include the video; however, when editing, the correct code is present in the "source view".
Is the video displayed via a comcode tag? If so, have you checked the permission of the comcode to ensure that it is not set as a "Dangerous tag"?
this also seems to affect the ability of members to upload avatars. The avatar is in the file uploads/ocf_avatars , but it does not show on the site.
Have you checked that members have permission for Use off-site/uploaded avatars (in Admin Zone Security Choose Privileges: Forums)?

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#93208
Avatar

Forgot…this also seems to affect the ability of members to upload avatars. The avatar is in the file uploads/ocf_avatars , but it does not show on the site. It is also in the database members table.

Also check you didn't uninstall the ocf_member_avatars addon.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#93220
Avatar

Community saint

temp1024 said

psydoc said

In addition, administrators can not edit a members post to include the video; however, when editing, the correct code is present in the "source view".
Is the video displayed via a comcode tag? If so, have you checked the permission of the comcode to ensure that it is not set as a "Dangerous tag"?
this also seems to affect the ability of members to upload avatars. The avatar is in the file uploads/ocf_avatars , but it does not show on the site.
Have you checked that members have permission for Use off-site/uploaded avatars (in Admin Zone » Security » Choose » Privileges: Forums)?
Hi temp1024. I checked the use off-site/uploads, and members are allowed.

I didn't have any of the boxes checked under "Use dangerous Comcode" or "Use potentially-troublesome Comcode"; however, changing that made no difference. 

I'm still scratching my head on this one.
Back to the top
 
Posted
Rating:
#93221
Avatar

Community saint

Chris Graham said

Forgot…this also seems to affect the ability of members to upload avatars. The avatar is in the file uploads/ocf_avatars , but it does not show on the site. It is also in the database members table.

Also check you didn't uninstall the ocf_member_avatars addon.
The ocf_member_avatars addon indicates it is installed.  :(

Back to the top
 
Posted
Rating:
#93222
Avatar

Community saint

The code displays if posted by an admin; however, if posted by a regular member, the code is there, but no display.

Back to the top
 
Posted
Rating:
#93227
Avatar

If members are being asked to directly input Youtube iframe HTML, that's definitely not going to work without putting on some very dangerous privileges (arbitrary HTML posting access is extremely dangerous). You need them to use a Custom Comcode tag to input the youtube video, I think there is one bundled for this.

Regarding avatars, by not showing, do you mean it shows an empty space, or a broken image, or some other image? If it is a broken image, I'd try opening the image URL directly into a new tab and see if it is showing an error.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#93228
Avatar

Community saint

Hi Chris, I use the semihtml when posting a video, but it doesn't work as an attachment, either. I will look for the custom comcode tag. I think I looked under the comcode help in the WYSIWYG, and didn't see anything, but I will look again.

The avatar does not display (blank space), even as a broken link to an image. If I post it for a member, using admin privileges, it posts.
Back to the top
 
Posted
Rating:
#93229
Avatar

The avatar does not display (blank space)

Is there an <img> tag in the HTML?

but it doesn't work as an attachment

How could you add a youtube video as an attachment though?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#93230
Avatar

Community saint

This is what you see…
Back to the top
 
Posted
Rating:
#93231
Avatar

Community saint

Chris Graham said

The avatar does not display (blank space)

Is there an <img> tag in the HTML?

but it doesn't work as an attachment

How could you add a youtube video as an attachment though?
You can't. At least, not that I know of, that would be when uploading an FLV, MP4, SWF, etc.  :)

Back to the top
 
Posted
Rating:
#93233
Avatar

Community saint

I don't understand your question regarding the <img> tag, Chris.
Back to the top
 
Posted
Rating:
#93234
Avatar

psydoc said

Chris Graham said

The avatar does not display (blank space)

Is there an <img> tag in the HTML?

but it doesn't work as an attachment

How could you add a youtube video as an attachment though?
You can't. At least, not that I know of, that would be when uploading an FLV, MP4, SWF, etc.  :)



Exactly, lol. I suspect if you click the Comcode button in the editor, it'll open the overlay of Comcode tags, and Youtube will be in it.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#93236
Avatar

Community saint

I just check the comcode overlay. There is no Youtube tag.  :(  Is that an addon I could install?
Back to the top
 
Posted
Rating:
#93237
Avatar

I think it comes with the galleries addon, as it shares a template with that.

But it's easy to make, I know we did a video tutorial on adding it, I think I remember at least one other one around.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#93238
Avatar

Community saint

I have been searching around, I will see if I can find something.

Thanks, Chris.
Back to the top
 
Posted
Rating:
#93239
Avatar

Community saint

I'll have to continue later. I have to go to a funeral.
Back to the top
 
Posted
Rating:
#93240
Avatar

ocportal youtube custom comcode - Google Search

Allen's tutorial is the top 2.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#93248
Avatar

Community saint

YouTube: I built my own custom-comcode tag, based on Allen's tute. This is what I did …

Code

<p align="center"><object width="425" height="344"><param name="movie" value="http://www.youtube.com/v/{content}&amp;hl=en_GB&amp;rel=0&amp;color1=0x2b405b&amp;color2=0x6b8ab6&amp;border=1"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/{content}&amp;hl=en_GB&amp;rel=0&amp;color1=0x2b405b&amp;color2=0x6b8ab6&amp;border=1" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"></embed></object></p>
… but please don't be critical about the HTML, as I did this many versions ago. It still works!

I then had to explain to my users how to go about using the tag …

Code

[youtube](your video ID here - no spaces)[/youtube]

This link is an example of how I encouraged my silver-surfers to use the comcode tag. And they have!

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#93256
Avatar

Community saint

And here is my YouTube custom comcode tag: View topic: FreeOurMoney - advocating monetary reform - ocPortal .

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Expand