HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


how to add rss feed

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#78155 (In Topic #16028)
Avatar

Fan in training

How to add an RSS feed

How do I add a RSS feed to my site?  when I choose the rss feed block thing to show up, it gives me the Ocportal feed.  I want feeds from google news about eating disorder recovery.  This would be helpful, also, how do make a catolog show up on the site after creating it? I'm not sure how.
Back to the top
 
Posted
Rating:
#78156
Avatar

Community saint

When you edit the page click main rss feed block (see image 1) Then in the window that pops up add the url to the google feed in the first param. See image 2 Hmm I cant add attachments sorry
Back to the top
 
Posted
Rating:
#78157
Avatar

Fan in training

I am not able to see where that is located, i'm visually impaired and use jaws for a screen reader.
Back to the top
 
Posted
Rating:
#78160
Avatar

Fan in training

and, i don't want it in the page, i want it in the block thing, so it stays on the site even when people go to a different page. I'm not sure if I'm making sence or not.
Back to the top
 
Posted
Rating:
#78161
Avatar

Community saint

I have never worked with a screen reader so I am not sure how to guide you correctly but when add the block to a page there is a pop-up window that allows you to add a url as a parameter to the block.
Back to the top
 
Posted
Rating:
#78162
Avatar

Fan in training

Is this how it's supposed to look?

Eating Disorder Recovery Network
Back to the top
 
Posted
Rating:
#78163
Avatar

Fan in training

Also, I added a new catolog to my site, but the only ones that show up are on the pages hedding are the links catolog and the faq.  How do I make the catolog I created show up as well?
Back to the top
 
Posted
Rating:
#78164
Avatar

Community saint

There appears to be something wrong with the display of that page as I can see a bunch of characters half hidden off screen to the right. As for new catalogue entries I am not sure but I would guess either permissions may be at play or you'll need to add them to a menu manually. I think there is a catalogues menu but I haven't played with the menus enough myself to be the best guide. I am sure one of the other more experienced members here can point you in the right direction for that one.
Back to the top
 
Posted
Rating:
#78165
Avatar

Community saint

Also note that I couldn't view much on the link provided (especially not an RSS feed) so I figured only members can see so I tried to join and the activation email went to my spam box (you may want to look into that) and now it further requires validation by an admin. Anyway I just thought you should know that if this was a site I was curious in I likely would leave and not come back in frustration and so might many other users. Something to consider. I do realize the nature of your site you may want some privacy for your members but you should realize that it is a good idea to make some info easy accessible to the public to gain reader interest and make it easy for them to join. Later you can manually add them to groups with access to the privy areas if you want. Just an FYI
Back to the top
 
Posted
Rating:
#78166
Avatar

Community saint

wintergirl said

Is this how it's supposed to look?

Eating Disorder Recovery Network
I don't know how much help my attached images are going to be, but I'll add them just in case you being 'visually impaired' means you can see something.

1. I don't see an RSS feed in either 'left' or 'right' panel, unless you are referring to the block titled Newest 10 Frequently Asked Questions.
2. If that is the block you are referring to, you've coded it incorrectly as the display in attachment 1 shows:


Attachment 2 shows what it could look like if you changed the widths for the 'colgroup':


How do I make the catolog I created show up as well?
One of the 'gotchas' about creating catalogs is to forget to add fields. I've done that in the past and wondered why my catalog doesn't show. Can you check that you've added the relevant fields?

If you can't see the attached images (Duck has also referred to the display), please say so and I (WE) will try and get our heads around how to explain things without the aid of images!

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#78168
Avatar

Fan in training

what characters?
Back to the top
 
Posted
Rating:
#78172
Avatar

Community saint

Actually Fletch has shown in his images what I was talking about by widening the column. Basically the Question answer thing on the right is not displaying correctly. By the way you can click on the images that Fletch has attached and they will zoom larger so you can see them better if it helps?
Back to the top
 
Posted
Rating:
#78174
Avatar

Fan in training

no, i am unable to see. I'm not able to see anything.  and, I seen that you joined Eating Disorder Recovery Network Welcome!
Back to the top
 
Posted
Rating:
#78186
Avatar

Community saint

wintergirl said

no, i am unable to see. I'm not able to see anything.
I guess NOW is the time to stop paying lip-service to 'usability' and start trying to cope with what may appear to be an easy fix for the sighted!

Currently, the box (the <div>) you've inserted into the right panel that is titled 'Newest 10 Frequently Asked Questions' is taking its CSS properties from 'wide_table_wrap'. The table that fills that box is being taken from the CSS 'wide_table solidborder spaced_table', which in turn delivers a 'colgroup' style of (1st column)-"width: 150px" and (2nd column)-"width: 100%". This is rendering your first column as 150px wide leaving the text (of the 'answer') to fill the rest of column 2, which by now is rendering about 2px wide.

Playing around with your display in Firebug I've established that removing 'wide_table' from the table properties causes the box to render correctly in your side panel.

However, I don't know how you came to decide on the choice of display, but you should re-think the type of 'box' you want to use to show this information in the side panel.

I hope that pretty pathetic explanation has gone a small way towards suggesting a solution. Shout if you still aren't getting the result you need, and I am sure somebody will be able to come up with the right answer.

Keep on truckin'!!

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#78188
Avatar

Fan in training

"I guess NOW is the time to stop paying lip-service to 'usability' and start trying to cope with what may appear to be an easy fix for the sighted!
"

What did you mean by that?

and, if i send you a pt with my info, can you fix it for me? I don't know how to edit templets or tables.
Back to the top
 
Posted
Rating:
#78193
Avatar

Community saint

wintergirl said

"I guess NOW is the time to stop paying lip-service to 'usability' and start trying to cope with what may appear to be an easy fix for the sighted!
"

What did you mean by that?

Nothing derogatory, I can assure you! EVERYBODY talks glibly about 'web standards' and usability' (and that includes me), but in reality we 'sighted' people find it pretty hard to understand the problems that 'visually impaired' people have. So, for me, it is a huge learning curve trying to understand and 'help'!

and, if i send you a pt with my info, can you fix it for me? I don't know how to edit templets or tables.
Of course.

I'll try, but I don't guarantee success. But let's go for it. Could be my last good deed for 2011 …

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#78197
Avatar

Fan in training

sent you a pt. hope you can fix it.
Back to the top
 
Posted
Rating:
#78201
Avatar

Community saint

Fixed.

The CSS properties for .wide_table are 'width:100%' - and - 'table-layout:fixed'. I commented out the 'table-layout' and added an explanatory note against it in case you ever need to restore it some time in the future.

I've never used a 'reader' of any description, so I am pretty clueless about how they work, but I suspect your reader wasn't doing you any favours. The display was plain 'wrong' with a wide column for the sub-headings Question and Answer, and the rest of the text was pushed into the narrow column against each. But, of course, that didn't deter the reader which was able to read it back to you without any problem!

Perhaps some staff intervention is necessary for the template BLOCK_MAIN_RECENT_CC_ENTRIES which can apparently be used in a side panel, but which sticks to the 'table-layout:fixed' mantra.

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#78202
Avatar

Community saint

while it certainly is better now I highly recommend moving that block to centre panel instead of right. It is still far too condensed on the right.
Back to the top
 
Posted
Rating:
#78207
Avatar

Community saint

I second Duck's suggestion, and move that most recent faq's to the center of the page.  It will look and read a lot better.

Paul
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: