HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Unable to edit a user avatar by uploading an image

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#107289 (In Topic #20905)
Avatar

Well-settled

I tried to change my user avatar for my user profile but the upload does't see to work. I tried altering the size of the image but nothing helped. I was able to use a image URL to change the avatar but as far as uploading from a local source it doesn't work. Has anyone ever dealt with this before and if so can you point me in the right direction to fix it?

Thanks in advance,
The LocalMC
www.localmc.com
Back to the top
 
Posted
Rating:
#107290
Avatar

Well-settled

In fact, now that I've changed the avatar using an image URL I am unable to log into my account. The site keeps refreshing as if it's trying to log me in but nothing happens. I'm a little worried about this bug.
Back to the top
 
Posted
Rating:
#107291
Avatar

Well-settled

I should mention that this is an account created using the Facebook add-on and not a standard OCF user account. In the past I've never run into this. In fact I've usually changed the avatars because the Facebook avatar translates over with a very small image. So, before, I just chafed it to a larger version but now it has locked me our of my account.
Back to the top
 
Posted
Rating:
#107293
Avatar

Well-settled

Upon further investigation I think my issue goes a lot deeper than just a change in an avatar. I've sent Chris Graham a private message regarding this problem.
Back to the top
 
Posted
Rating:
#107304
Avatar

The avatar editing is a problem I accidentally introduced in my last fix, sorry about that.

Facebook looping must be something separate. I'm logged into a Facebook account and it's fine, and it shouldn't actually be possible for it to refresh forever because of how the Facebook addon is encoded.
It should first append refreshed_once=1
then append keep_refreshed_once=1
Then if it's still not logging in, it should stop trying.

Is it still happening now?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#107305
Avatar

Well-settled

No. Its not happening anymore. Thanks for your help. That was a weird one but everything seems to be working fine now.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: