HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Changing Upload Size

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#72038 (In Topic #15129)
Avatar

Well-settled

Hi, I have the latest version of OCportal.

I'm currently experiencing with making the maximum size of uploading bigger than 2 MBs.

Even for me, administrator, can't be allowed MORE THAN 2 MBs.

I've tried changing it by using the link, I've set it to a ridiculous amount and still, it doesn't change at all.
Back to the top
 
Posted
Rating:
#72040
Avatar

Community saint

That limit is likely set server wide by your host, it is quite common.
Back to the top
 
Posted
Rating:
#72081
Avatar

Well-settled

Hi, I have over 50 GBs of space, plenty of space, my webhosting have no way to change the limit on OCportal, I still don't understand why it doesn't change to LOWER or HIGHER when I try to change it either way.
Back to the top
 
Posted
Rating:
#72084
Avatar

Community saint

Have you chcecked what your server is set to allow using 'PHP tools' in Admin?



If they are set to 2M, then change the limit using the recommended.htaccess that comes with the original ocPortal bundle.

Let's hope that sorts your problem!

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#72090
Avatar

Community saint

Hi Voarsh,

Actually the amount of storage you have and your max_upload_filesize are two separate things and your host does have control over limiting them for sure.

Being limited to 50gigs of space is a good sign. It tells me your host is probably one of the better ones that advertises something real (no such thing as unlimited) and keeps an eye on how much space/resources each person uses so no one hogs up more than their fair share. And 50gigs is a LOT of space. It will probably take you a really long time to use that up.

The max_upload_filesize is the limit set on what the size of any one file being uploaded can be. The screen shot Fletch posted shows your php info. On the left is what the values are you/ocPortal has set. The right shows what the value is set at server wide….what your host has it set at for everyone.

You can find what Fletch showed you in the screenshot on your own site by going to admin zone>tools>php info. If your host has the master value set to 2mb, which is very possible, that is a common number, you will have a hard time working around it if you can at all.

Fletch's suggestion is a good one and may help. That will also help you with other things at the same time, like if you want to use short url's. I will add some instructions to that.

ocPortal Tutorial: Advanced configuration - ocPortal

Go to where you installed ocPortal, ether through cPanel if that is what you use or your ftp client. Check the option to show hidden files on your way there. Find the one called .htaccess and delete it. Then find the one called recommended.htaccess and rename it .htaccess (don't forget the dot) Hopefully that works for you.

If need any more help/instructions we are here. Good luck :)
Back to the top
 
Posted
Rating:
#72107
Avatar

Well-settled

Hi, thanks! I'm not sure where I can access that PHP INFO display let alone the file…..


I have a VPS (Virtual Private Server)
Back to the top
 
Posted
Rating:
#72112
Avatar

Community saint

No prob, we are happy to help when we can.

To find PHP INFO go to your admin zone, hover over the tools link and you should see it in the dropdown.

If you don't see it there then you don't have it installed. Go over to addons and go down the list and you should see it, install it if it is not installed.

The files mentioned to be edited you will not find in your admin zone. You have to go to the home directory of where ocPortal is installed….where you extracted ocPortal to when you installed it.

Is it cPanel that you use? In cPanel click on file manager. In the popup choose web root and also check the option to show hidden files and you will find them there.
Back to the top
 
Posted
Rating:
#72113
Avatar

Well-settled

Hi, sorry people, I have managed to change the the amount to upload to 8 MB, I tried uploading a 2.45 MB file and OCportal says the file you tried to upload was to big.


Strange this is what the page says:

The maximum upload size is 8.00 MB. You have access to change upload limits.
Back to the top
 
Posted
Rating:
#72115
Avatar

Community saint

I am guessing then that your host has the master value set to 2mb.

Changing it on your end will not override that setting. You may be stuck with it unless someone knows a more advanced work around they can share with you or your host changes it for you.
Back to the top
 
Posted
Rating:
#72116
Avatar

Well-settled

I have access on changing the PHP configurations.

I have set it to 32 MB, but my settings on OCportal add it up to 8 MB (the number of kilobytes) and I still get the problem.
Back to the top
 
Posted
Rating:
#72117
Avatar

Community saint

Voarsh said

I have access on changing the PHP configurations.

I have set it to 32 MB, but my settings on OCportal add it up to 8 MB (the number of kilobytes) and I still get the problem.

Hi Voarsh!

See if this can help, or explore other answers from that topic?
http://ocportal.com/forum/topicview/findpost/71820.htm

Jean
Back to the top
 
Posted
Rating:
#72118
Avatar

Community saint

If your host has it set to 2mb you may not be able to change it yourself. Even if you are able to change your local setting that still will not change the master settings that only your host has control of. What your host has set is the one that really counts and will override whatever you set

Did you have a look and see what the master value is in your PHP INFO?
Back to the top
 
Posted
Rating:
#72119
Avatar

Well-settled


Local Value                             Master Value
upload_max_filesize   50M           50M


Back to the top
 
Posted
Rating:
#72123
Avatar

Community saint

Well that is good news. You should be able to find and answer in the link Jean gave you,

Also since you changed your setting in ocPortal and it never worked try running the website cleanup tools in the admin zone and that may make the changes you made take effect.
Back to the top
 
Posted
Rating:
#72126
Avatar

Well-settled

Thank you for your help. I will contact my web hosting too.
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: