HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


XML Parsing Error: mismatched tag. Expected: </body>

Login / Search

 [ Join | More ]
 Add topic 
Posted
Item has a rating of 5 (Liked by Guest)  
Rating:
#95042 (In Topic #18925)
Avatar

Well-settled

How can I fix this problem:

XML Parsing Error: mismatched tag. Expected: </body>.
Location: http://buyproforms.com/index.php?page=start&keep_mobile=1&keep_devtest=1&redirected=1
Line Number 118, Column 4:    </div>
----------^

I moved my website (Still with the same host, just changed domain names) from "mydomain.com/Proforms"
to "buyproforms.com" by moving all files and folders. I have a Welcome page and a Site page.
reset the configuration with "config_editor"
Everything from site and others zones work correctly, but the welcome screen is the only one that gives me the error shown above.

I've looked everywhere and tried everything but nothing works.
Back to the top
 
Posted
Rating:
#95044
Avatar

Community saint

That error message implies that you are closing one too many  divs.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#95047
Avatar

Well-settled

I know that, but I cannot find out how to remove the "</div>"

How do I do that, would you know?

But I also just found out that I do not seem to have any problems with IE, I reinstalled Firefox but still have the problem.


Thanks if answering,

Robert
Back to the top
 
Posted
Item has a rating of 5 (Liked by Jean)  
Rating:
#95049
Avatar

Well-settled

GOT it fixed.

I knew that is was pointing to the index.php file, but every time that I looked for the cause of the error "</div>" it was not there.

This time I copied the code form the web browser and Deleted the code in the index file and pasted the one that I got from the web (With the error) and went to the error and deleted it from the file and saved the file and replaced the one on the server. Now it working correctly.


Robert
Back to the top
 
Posted
Rating:
#95058
Avatar

Well-settled

The joy of it being fixed was short lived.

 

By fixing the problem the way I did, caused ocPortal to no longer log you out, you think you have logged out but when you go back to the site you find that you are still logged in. Had to put back the “index.php file. I firmly now believe that the problem is not in the “index.php” but that ocPortal create the Welcome screen by a compilation of the index file CSS file and java, and maybe others. In one of thouse files is my “</div?” problem. Now iI have the task to find it.

 

 

Robert

Back to the top
 
Posted
Item has a rating of 1  
Rating:
#95059
Avatar

Community saint

index.php is the sites main entry point, so I'm surprised that it didn't break the instant you made the change.

The welcome page should be editable from Content >> Pages (Comcode pages) .

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#95060

Non-joined user

I looked at every "welcome" page in Content>>Pages(Comcode pages), could not find the error in anyone of them.

Will let let you know when I find it.


Robert
Back to the top
 
Posted
Rating:
#95061
Avatar

I'm surprised you're seeing these kinds of errors.

In version 8 and earlier we put in an XHTML mime-type in "development mode". Development mode was basically only enabled if there was a .git directory. This would cause strict errors like this if there was any validation problem.

In version 9, we formally switched to HTML5 rendering which does not have strict errors.

HOWEVER, Google Pagespeed did have an issue which we worked around in a patch release a while back. It would override the mime-type we specified with the one that was referenced in the HTML as the document validation mime-type. Make sure you have this in your HTML_HEAD template:

Code

<meta http-equiv="Content-Type" content="text/html; charset={CHARSET}" />
and NOT

Code

<meta http-equiv="Content-Type" content="application/xhtml+xml; charset={CHARSET}" />

Maybe you have Google Pagespeed installed on your server plus overrode HTML_HEAD.tpl in your theme before we made the workaround.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#97798
Avatar

Fan in training

I just joined the forum today after searching for a similar issue and seeing this thread.

I too had just switched from one host to another (I don't use ocPortal) and had moved a wordpress website.

When attempting to login to the admin backend, I got an XML error similar to yours (mine was a missing end-HEAD tag).  Thing is, when I accessed the site using Internet Explorer, I got a different error - not an XML parsing error, but rather, a downloaded page(!) that looked to be the standard "parked website" page that hosting companies normally display until you upload your website.  But, this page came from the PREVIOUS hosting company!

I've still got support tickets open to find out why this may be happening, but thought I'd post here in case there is a similar cause.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: