HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Weather block quit working after upgrading to V8.0.1

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#85505 (In Topic #17570)

Honoured member

I just upgraded to v8.0.1 from 7??.  I was using a weather block on my front page, and now it just says:

Code

This information has not loaded yet. It will be generated in the background, please
come back later.

I went in to the editor and regenterated the code, and it works during preview, but when I add the block to my page and hit saves it still says the same thing.
Back to the top
 
Posted
Rating:
#85540
Avatar

Fix attached:

Attachment
sources/hooks/systems/cron/block_caching.php
» Download: block_caching.php (4 Kb, 108 downloads so far)


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#88567
Avatar

Fan in action

Upgrade to 8.1.2 bug fixes. Lost Weather Block. Downloaded the block_caching.php which made no difference. All I get is the same message as Chipster above.
Back to the top
 
Posted
Item has a rating of 5 (Liked by Chris Graham)  
Rating:
#88577

Honoured member

Hi Ernie, Try setting the cache value to 0 or 1 and then use upgrader.php to clear your cache.  Otherwise it will update the next time cron.php runs.

Code

[block="12772901" unit="f" cache="0" title="Current Weather"]side_weather[/block]

is the code I use and it updates my weather block each time the front page is hit.
Back to the top
 
Posted
Rating:
#88584
Avatar

Fan in action

Thanks Chipster! Set 'No Cache" & my weather is up. Every day is for learning.
Back to the top
 
Posted
Rating:
#88592

Honoured member

Just glad I was able to help.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: