HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


v9 galleries question....

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#90295 (In Topic #18257)
Avatar

Community saint

Back in v7, I made a block for my main page that displayed a few random images from randomly selected galleries.   It views fine in v9, but the link associated with the image no longer works, so if you click on the image, rather than getting the image in v9, you get a 404 error.

This is the href link generated:

http://www.air-rc.com/galleries/pg/start/image/221/index.php?wide=1

Just wondering if something in v9 changed that changed the link as it was created, or if something changed so this format no long works.

Of note, I noticed that pg comes after galleries for some reason, seems on most other pages pg comes first.  I reversed them manually in my browser but it still doesn't work.


Paul
Back to the top
 
Posted
Rating:
#90296
Avatar

Community saint

I did a clean install of v9, with a gallery on the main page. I only uploaded one image as a test, but the link worked perfectly. I have since removed the install as I want to use it live on another site, so I can't give you a reference. Did you do an upgrade, or fresh install?
Back to the top
 
Posted
Rating:
#90297
Avatar

Community saint

Which image is giving you problems? I am going through all the images on your site (very cool, btw) and I am able to view them all, so far.
Back to the top
 
Posted
Rating:
#90298
Avatar

Community saint

I gather snakecrew is not a GWB fan.  :lol:
Back to the top
 
Posted
Rating:
#90299
Avatar

Community saint

I take it back, snake crew's slideshow broke at image 5
Back to the top
 
Posted
Rating:
#90300
Avatar

Community saint

It was an upgrade.   Which block did you use on the main page that showed images and let you click right to them?  

Hmm, why are there no thumbnails for his other images?   Interesting.

Paul
Back to the top
 
Posted
Rating:
#90301
Avatar

Community saint

Interesting as well, I had a modification where users could select slider or grid view, none of that works anymore.    Man, I got a lot of reverse engineering to do to get it back to where I want it.

Paul
Back to the top
 
Posted
Rating:
#90304
Avatar

Community saint

Ok, in v7 I had made a 'mgalleries' zone, so that galleries were a zone not a menu item.   I created that and did a redirect from mgallery:start to welcome:galleries and the old code works again.    There are some other modifications I had that aren't working, but I'll worry about that later, important part was getting that front page link working.

Paul
Back to the top
 
Posted
Rating:
#90322
Avatar

Arbo said

Ok, in v7 I had made a 'mgalleries' zone, so that galleries were a zone not a menu item.   I created that and did a redirect from mgallery:start to welcome:galleries and the old code works again.    There are some other modifications I had that aren't working, but I'll worry about that later, important part was getting that front page link working.

Was just going to say you must have done something weird like that  :lol:


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#90324
Avatar

Community saint

Yeah, I guess I'll have to keep doing it until 'galleries' is a zone of it's own.   ;)


Paul
Back to the top
 
Posted
Rating:
#90325
Avatar

psydoc said

I take it back, snake crew's slideshow broke at image 5

Let me know if there is a bug for me to be pointed to. Not aware of this 'snake crew', but I ran a quick slideshow test on Air-RC and it seemed to run past 5 (Google Chrome).


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#90328
Avatar

Community saint

I was going to give a link, but once you click on a members gallery, you get a 'the requested page (galleries) is missing.   Ugh.   I think it is a redirect issue.

Paul
Back to the top
 
Posted
Rating:
#90331
Avatar

Community saint

Ok, I fixed all this by moving the galleries.php from site/modules to mgalleries/modules.

Should have thought of that to start with.

Here is the user snakecrews gallery, in slideshow, you'll see that by the 5th image, there are no more images, just the little ? in place of image.

View slideshow: snakecrew's Gallery - Air-RC

Paul
Back to the top
 
Posted
Rating:
#90332
Avatar

Community saint

correcting, it's from image 5 to about 25 that are gone… must be something on my server end…

Paul
Back to the top
 
Posted
Rating:
#90334
Avatar

Ah, those are bone-fide broken images, pointing to bing.com.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#90352
Avatar

Community saint

Chris Graham said

psydoc said

I take it back, snake crew's slideshow broke at image 5

Let me know if there is a bug for me to be pointed to. Not aware of this 'snake crew', but I ran a quick slideshow test on Air-RC and it seemed to run past 5 (Google Chrome).
I was using FireFox. The only error was in the error console.
Timestamp: 8/29/2012 12:01:11 PM
Warning: Error in parsing value for 'background-image'.  Declaration dropped.
Source File: http://www.air-rc.com/themes/Air_RC/templates_cached/EN/ocf.css?1346246966
Line: 4

Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: