HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


v8.1 Classifieds Error

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#87004 (In Topic #17755)
Avatar

Community saint

I got the following error and stack trace while testing classifieds system.  I added several of the default price options to hosted sites catalogue to see how the classifieds work. Added one entry as admin (was expecting to see some options for how long to run the add but didn't) so I went to my profile and chose the My classifeds options which shows my 1 entry to expire in a week and clicked upgrade advert. I got the following error despite the fact that customers.ini exists in lang_custom/EN

Expand:

Back to the top
 
Posted
Rating:
#87016
Avatar

This one's left me baffled. I've stepped through the code very carefully, and it seems the only way this could happen is if the file doesn't exist, or permissions stop it being checked for existence. Seeing as you have seen things that require it to exist (other parts of the classifieds system) that doesn't make sense.
I suppose that leaves 3 possibilities:
  • Random chaos
  • Different instances of PHP having different caches of the filesystem state (so try resetting the web server)
  • The file was there but isn't now


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#87021
Avatar

Community saint

Whoops might be my bad here I don't know? I refreashed my explorer screens Cleared everything in website cleanup tools and restarted server and same errror this time I noticed the fact that it is customers.ini file and maybe I was looking at classifieds.ini as being there before I can't remember now but one thing I am sure now is that I don't have customers.ini but do have classifieds.ini


Also 2 other errors showed up on the way to recreating (that were there the first time I just clicked thru too quick to pay attention)

1First clicking myprofile from site start did a modal popup something about undefined index I believe but I lost the window before I could copy all details. I did land on profile page though.

 2When first clicking My Classifieds I get an error top of the screen (though it listed my entry fine):

Code

A parameter, RESULTS_BROWSER, is referenced in the template, CLASSIFIED_ADVERTS_SCREEN, but not passed
This tpl file exists in custom templates of default  theme.

Anyway same error on the customers thing when upgrading adverts but as I say the file truly doesn't exists and may not have from the begining cause i checked my downloaded copy of the tar of the addon and there is no such file inside that.

Should there be a customers.ini or should I be changing the include reference to classifieds.ini?
Back to the top
 
Posted
Rating:
#87022
Avatar

Community saint

Here is photos of the other 2 errors for your reference:

Back to the top
 
Posted
Rating:
#87023
Avatar

Noticed the classifieds error earlier:
0000595: Error about results browser on classifieds list - ocPortal feature tracker

customers.ini sounds like it is due to the ecommerce hook I sent you previously (the ocportal.com one). That references this. I got confused about the similar names too!

Will look at the Firefox JS error now.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Important!
Posted
Rating:
#87025
Avatar

Automated fix message

Duck said

Here is photos of the other 2 errors for your reference:

This issue has been filed on the tracker as issue #596, with a fix.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Important!
 
Posted
Rating:
#87026
Avatar

Community saint

Thanks the 2 hotfixes fixed the first issues and I pulled out the supports_credit hook and it solved the customers.ini error. All is well now. I had placed that file in the appropriate folder so as I studied the ecommerce system in ocportal 8 I had all files where they were supposed to be for reference.
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: