HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


v.6.0.2 forum posting errors on previews

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#68269 (In Topic #14513)
Avatar

Community saint

causing loss of data and having to repost

I’m having lots of activities on my Virtual Classroom site; something like nearly 1000 posts in two weeks since the opening of my new course. A new method of applying the 'point system' is really motivating students and a testament to ocPortal’s potentials in the classroom.

However, I’m concerned with supposed “posting errors” seemingly increasing as well according to complaints from the members. It is probably due to a setup limiting some functions and I’m at a loss to pinpoint it at the moment. I'm Also worried that this is the tip of many more unreported such incidents.

I did enabled system email reporting of all activities to monitor this new group for a few weeks, and only one error was forwarded to me, which I do not think is related to the incidents quoted below, leaving me perplexed:

”email” said

 ERROR: A link was posted here (img) but it appears to be a broken link.
Here are some of the comments from my students:

….I was replying to a post and when I hit Add topic to send the reply, all my post was gone and this screen showed up. Hitting on the Back button would not bring back what I intended to post so, I would need to repost again. Is it possible for a Draft system to be implemented to prevent a post to be lost when an error happens? I'm just asking, if not, it's ok. Here I included an attachment of the error screen I got:


….I had the same problem after load my third attachment and hit preview. One time I hit the back button it help but the second time not. I had to start from scratch again.

….Yea i have gotten this problem several times cant do nothing about it i gues the draft option would be really really nice !



The preview button has always acted as a “draft system” for me, capturing whatever error and enabling editing before adding a post. I did not experience any of this on the many posts I’ve published during the same period.

The site is using ocPortal v.6.0.2 and I intended to upgrade this weekend.

Jean
A State of Mind - Web 2.0
 
Back to the top
 
Posted
Rating:
#68275
Avatar

 ERROR: A link was posted here (img) but it appears to be a broken link.

That can just happen if someone puts a Comcode 'img' tag (or image via WYSIWYG) and it points to a broken URL.



In theory ocPortal should have the following protections:
  • anything you type gets auto-saved for recovery when you return
  • back button should keep content
  • Comcode repair assistant should kick in

So I'll run some tests to see why these aren't always working.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#68276
Avatar

auto-save – only kicks in after 20 seconds

Back button – working on this, it's always a pain as browsers all have different restoration bugs and back behaviours, especially when WYSIWYG is involved

Comcode repair – doesn't work with WYSIWYG on it seems, fixed I think
Attachment
sources/comcode_renderer.php
» Download: comcode_renderer.php (93 Kb, 77 downloads so far)



Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#68280
Avatar

v6's WYSIWYG field not autosaving. This fixes, but only works on 6.0.3.

Attachment
» Download: JAVASCRIPT_POSTING.tpl (16 Kb, 78 downloads so far)
Attachment
» Download: JAVASCRIPT_EDITING.tpl (17 Kb, 88 downloads so far)


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#68281
Avatar

Great, this makes back button work on all browsers even with WYSIWYG. Supersedes last file. 6.0.3 only.

Attachment
» Download: JAVASCRIPT_EDITING.tpl (17 Kb, 77 downloads so far)


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#68286
Avatar

Community saint

Thanks for all your great work, Chris!

In a way I'm glad it lead to even more stability across browsers.

I will upgrade to 03 this weekend.

Cheers!
Jean
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: