HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Using the zone editor--changes won't save

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#76434 (In Topic #15770)
Avatar

Fan in action

Grrrr…just as I thought I was fully getting the hang of things, the zone editor has jumped up to bite me in the rear.

I've been trying to make changes to my main menu, but none of them seem to want to "stick".

This is a current image of my main page:

Notice that my iotd block is not allowing for a space at the top. I need to get a space in there, as well deleting one block and adding in a few others.

My view of the zone editor:
I need to move the main_iotd block down a line and I want to delete main_cc_embed block. Simple enough. I make sure to space it down and delete the block main_cc_embed–which are both pretty straightforward procedures.
I add in my desired blocks:
…and after hitting save, absolutely nothing has changed:
Any thoughts as to what might be going on?
Back to the top
 
Posted
Rating:
#76436
Avatar

There have been some nasty bugs in the zone editor. I think the fixes are all in the latest version, but if in doubt maybe just use the normal Comcode page editor? (CMS \ Pages (Comcode Pages))


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#76437
Avatar

Community saint

Admin Zone Tools Website cleanup tools

Clear:
  • Block cache
  • Template cache

If that doesn't work, go back and clear a couple of 'Language' caches.

And if that doesn't work, FORCE yourself to disable the WYSIWYG editor and try something like:

Code

[block]main_quotes[/quote]

{| 60%:37% wide floats
| [block]main_news[/block]
| [block]main_iotd[/block]
}

[block]A.N.Other_block[/block]

I haven't tested any of this, so apologies in advance if 'fings don't go as planned … !!

 :$




Oooooops! Chris got in first …

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#76444
Avatar

Community saint

And I'll add to clear browser cache. Only when clearing all these caches can you be sure you are getting the latest version of the page?

Are the changes "sticking" in the Zone Editor?

Bob
Back to the top
 
Posted
Rating:
#76462
Avatar

Fan in action

Chris Graham said

There have been some nasty bugs in the zone editor. I think the fixes are all in the latest version, but if in doubt maybe just use the normal Comcode page editor? (CMS \ Pages (Comcode Pages))

Worked like a charm. Thx.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: