HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Upload limit and File types

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#75947 (In Topic #15694)
Avatar

Fan in action

Hi,

Could someone explain me how to set the limits for Uploads to 50MB?

I also was try to add .apk files to the allowed file types but I still could not upload those .apk files.

Thanks for any info.
Back to the top
 
Posted
Rating:
#75951
Avatar

Community saint

quax said

  • Could someone explain me how to set the limits for Uploads to 50MB?
  • I also was try to add .apk files to the allowed file types but I still could not upload those .apk files.
1. - First check that your host hasn't set the limits lower than 50MB - (Adminzone >> Tools >> PHP info - check PHP core configuration for post_max_size and upload_max_filesize). Then use the recommended.htaccess file included with the basic installation to raise your limits if the hosts permit it.

2. No idea if the developers have included the Android Application Package extension as a recognised one. Perhaps they will answer this one for you.

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#75954
Avatar

Community saint

quax said

I also was try to add .apk files to the allowed file types but I still could not upload those .apk files.
Add "apk" to the "Valid file types" section of Admin Zone Setup Configuration Security options.

Then make sure you flush your browser cache and you should be able to download it just fine.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#75955
Avatar

Fan in action

Fletch said

1. - First check that your host hasn't set the limits lower than 50MB - (Adminzone >> Tools >> PHP info - check PHP core configuration for post_max_size and upload_max_filesize). Then use the recommended.htaccess file included with the basic installation to raise your limits if the hosts permit it.:thumbs:
That limit is set to 8M(for Post) and 16 M (for Upload).

I used Softaculous for to install the script of PCPortal That means I need to download the package from here and replase the .htaccess file? And where that file is locate on thge sever?

Thanks a lot for the help and further info.
Back to the top
 
Posted
Rating:
#75956
Avatar

Fan in action

temp1024 said

Add "apk" to the "Valid file types" section of Admin Zone Setup Configuration Security options.

Then make sure you flush your browser cache and you should be able to download it just fine.

Thanks a lot. Had forget to flush the browser cache, works now fine.
Back to the top
 
Posted
Rating:
#75957
Avatar

Community saint

The recommended.htaccess should already be in you ocPortal root directory.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#75958
Avatar

Fan in action

temp1024 said

The recommended.htaccess should already be in you ocPortal root directory.
No, there isn't! There's a index.php file.
Back to the top
 
Posted
Rating:
#75959
Avatar

Fan in action

OK, there the following 2 .htaccess files:
  1. plain.htaccess
  2. recommended.htaccess
How to set the limits and how to use hem?

Thanks for your help.
Back to the top
 
Posted
Rating:
#75961
Avatar

Community saint

1. Rename .htaccess to say old.htaccess (just in case you need to go back to it)
2. Rename recommended.htaccess to .htaccess
3. Now in .htaccess change php_value upload_max_filesize "16M" to whatever limit you need.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#75963
Avatar

Fan in action

temp1024 said

1. Rename .htaccess to say old.htaccess (just in case you need to go back to it
2. Rename recommended.htaccess to .htaccess
3. Now in .htaccess change php_value upload_max_filesize "16M" to whatever limit you need.)
Hm…..?! There isn't any .htaccess on root of the OCPortal folder. There only the 2 files mention above!

I'm a bit with caution and don't know how to that now.

Thanks for help.
Back to the top
 
Posted
Rating:
#75965
Avatar

Fan in action

One more question: in recommended.htaccess is an entry:
# Set ocPortal to handle 404 errors. Assume ocPortal is in the root
ErrorDocument 404 /index.php?page=404

Till now the OcPortal is in it's default folder /ocportal should I use # in front for to disable?

The file recommended.htaccess which I have could be downloaded here:recommended.htaccess | localhostr.com - share … anything

Thanks for advice.
Back to the top
 
Posted
Rating:
#75967
Avatar

Fan in action

Oops!! Maybe there isn't any .htaccess! I checked the PHP Info again and it looks like that the server is an CGI server. Look at the picture:

PHP Info

I have no access to the php.ini file, nor to the folders /usr/lib……

How to handle that?

Thanks.
Back to the top
 
Posted
Rating:
#75968
Avatar

Community saint

quax said

Oops!! Maybe there isn't any .htaccess! I checked the PHP Info again and it looks like that the server is an CGI server.
Standard. Nothing to get twitched about.

I think you have to talk to your web hosts and enquire whether they can raise the limits - OR - tell you how to access your PHP.ini file so that you can do it yourself.

If they decline to raise the limit because this is a limit they arbitrarily set for all their shared-hosting customers, SERIOUSLY consider changing to a host that is more accommodating!

Good luck.

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#75983
Avatar

Community saint

quax said

Hm…..?! There isn't any .htaccess on root of the OCPortal folder. There only the 2 files mention above!
Your probably just have display of hidden dot files turned off.

If you are using File Manager in cPanel, then after clicking on File Manager make sure you tick "Show Hidden Files (dotfiles)".

If you are using an FTP program, you should find something similar to "Do not show dot files" in the configuration options. Just make sure it is un-ticked.

I'm a bit with caution and don't know how to that now.
I assume you are referring to step 3. Simplest way is to just use the Code Editor in cPanels File Manager and change 16M to 50M (or whatever) on the php_value upload_max_filesize line.
One more question: in recommended.htaccess is an entry:

    # Set ocPortal to handle 404 errors. Assume ocPortal is in the root
    ErrorDocument 404 /index.php?page=404


Till now the OcPortal is in it's default folder /ocportal should I use # in front for to disable?
Don't disable it, just change the line to

Code

ErrorDocument 404 /ocportal/index.php?page=404

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#75984
Avatar

Fan in action

Thanks for that. I'll contact my hosting company and ask for to up the limits.
Thanks for all the help.
Back to the top
 
Posted
Rating:
#75989
Avatar

Fan in action

I was getting an reply to the Ticket I opened with my Hoster:
Yes, you can create a custom php.ini file in your account and write the php values in it and copy the file where you are getting the error.

As I didn't have the knowledge and also not the php.ini file for OcPortal, could someone help me with that?

I need to have the limits set to min. 32M better to 50M and the memory to 128M which original at the server at 32M.

Thanks a lot
Back to the top
 
Posted
Rating:
#75991
Avatar

Fan in action

Ok, Problem solved now.

My hoster was updating the php.ini file while increase the settings.

All done.

Thanks a lot for all the help and infos.
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: