HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Unable to stay logged in?

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#98314 (In Topic #19411)
Avatar

Honoured member

I recently decided to move my test site to Arvixe hosting, as I like their offerings as well as their price structure.

Since I've deployed OCP at least a half dozen times now, I'm pretty comfortable with the install and configuration process.  That being said, I ran the 9.0.7 installer and set things up the way I have many times in the past, the problem is:  Now I am prompted after almost each mouse click, to re-enter my user name and password??

I've checked the cookie settings on the browser (Firefox) and even tried using IE10, but ran into the same problem?  I suspect it's a configuration setting somewhere but I haven't a clue where to start (I've checked the security settings in the config menu, but they all match my other sites which work fine)???

This one has me baffled?  The only thing I recall that went differently this time was that the OCP installer came up with a notification that the hosting server was "SU..." something or other, and that because of the increased security of the server configuration, certain application settings weren't required.

It's terribly frustrating though, as each mouse click seems to log me off and I get the "“Guest” does not have access to the zone adminzone." displayed at the top of the screen.  Even trying to make configuration changes takes so many logins, it's getting ridiculous!

It's probably a simple fix, so I'm throwing it out to the group in hopes that someone will say, "Oh yes, you just need to..." and that will fix everything!  Thanks again!

Cheers,

Mark
Back to the top
 
Posted
Rating:
#98315
Avatar

What are your cookie settings, what is your base URL, and have you tested on a private browsing session (i.e. so you don't have existing cookies to potential set and interfering)?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#98316
Avatar

Honoured member

Base URL is:  www.superiorpyro.com

I've not tested using a private browsing session, but I will do that now.  I don't suspect this issue is tied to to the browser however, as I am now receiving this message:

Back to the top
 
Posted
Rating:
#98317
Avatar

The ocPortal cookie settings...


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#98320
Avatar

Honoured member

Not sure if this is the info you're looking for?



If you would like, I can set up an admin account for you to have a look?

Thx Chris :)
Back to the top
 
Posted
Rating:
#98321
Avatar

Honoured member

Just received this message as well:

Back to the top
 
Posted
Rating:
#98322
Avatar

Hmm, yeah, I can't see anything wrong. Please do open a ticket:
Add a new support ticket - ocPortal.com


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#98325
Avatar

Honoured member

Ticket has been opened.  Thanks again, Chris.
Back to the top
 
Posted
Rating:
#98333
Avatar

Community saint

I had similar thing happen last week and traced the problem to my session IP address bouncing back and fourth between my ISP IP address and a CloudFlare IP address.  At times it seemed like every other click in the admin or cms zones (where confirmed sessions are required) I was prompted to log on again and some adminzone options wouldn't even progress past the log on page.  I unchecked the Enforce IP addresses for sessions configuration option in ocPortal Adminzone->Setup->Configuration->Security options and admin logons started working normally again.
Back to the top
 
Posted
Rating:
#98336
Avatar

Thanks Jason. You are indeed correct, Cloudflare seems to be active when not enabled, and I identified the same session issue as you. I have open a discussion with the Arvixe CEO about it, with a suggested remedy. I didn't want to suggest removing that option as it's a lowering of security, but it'd be okay if just temporary.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#98337

Non-joined user

Jason Verhagen said

I had similar thing happen last week and traced the problem to my session IP address bouncing back and fourth between my ISP IP address and a CloudFlare IP address.  At times it seemed like every other click in the admin or cms zones (where confirmed sessions are required) I was prompted to log on again and some adminzone options wouldn't even progress past the log on page.  I unchecked the Enforce IP addresses for sessions configuration option in ocPortal Adminzone->Setup->Configuration->Security options and admin logons started working normally again.


Hello Jason,

Which URL was this on? Did you have cloudflare enabled?
Back to the top
 
Posted
Rating:
#98338
Avatar

Community saint

Arvand said

Jason Verhagen said

I had similar thing happen last week and traced the problem to my session IP address bouncing back and fourth between my ISP IP address and a CloudFlare IP address.  At times it seemed like every other click in the admin or cms zones (where confirmed sessions are required) I was prompted to log on again and some adminzone options wouldn't even progress past the log on page.  I unchecked the Enforce IP addresses for sessions configuration option in ocPortal Adminzone->Setup->Configuration->Security options and admin logons started working normally again.
Hello Jason,

Which URL was this on? Did you have cloudflare enabled?
Two sites with the issue are holleywoodstudio.com and tfo.net and both have CloudFlare enabled. Both hosted on sardine.arvixe.com.
Back to the top
 
Posted
Rating:
#98339
Avatar

Fan in training

If you were to disable cloudflare, would it resolve the issue without having to turn off ocPortal's verification feature?
Back to the top
 
Posted
Rating:
#98340
Avatar

Community saint

Arvand said

If you were to disable cloudflare, would it resolve the issue without having to turn off ocPortal's verification feature?
I've got the ocPortal security setting back to default and turned off CloudFlare for the domains. I cleared the sessions from the ocPortal sessions table in the MySQL database. I also cleared my dns cache, browser cache, browser cookies, and restarted the browser on my local PC and still see CloudFlare IP addresses popping up in the ocPortal sessions table…I'll give it some more time for DNS change to propagate and try again later.
Back to the top
 
Posted
Rating:
#98341
Avatar

Fan in training

Do you have skype? Can you add me @ Arvand.arvixe and ill look into this further?
Back to the top
 
Posted
Rating:
#98342
Avatar

Honoured member

Arvand, the problem is, as Chris pointed out… i dont have cloudflare enabled, as you know, you have to agree to their t&c's and sign up.
Ive done neither of those, yet still have the issue?

Jason, you described the problem exactly!


Last edit: by superiorpyro
Back to the top
 
Posted
Rating:
#98343
Avatar

Community saint

Arvand said

Do you have skype? Can you add me @ Arvand.arvixe and ill look into this further?

I installed skype on my workstation, but I'm limited to instant messaging.  

I restarted my Internet gateway and PC and it looks like my logins are now correctly showing up with my ISP IP address and browsing through the adminzone hasn't caused any unnecessary login prompts with CloudFlare turned off.
Back to the top
 
Posted
Rating:
#98346
Avatar

Community saint

I spoke too soon. Logon problems persist even with CloudFlare off. I also checked another domain that doesn't have ocPortal that never had CloudFlare enabled and noticed it too has hits coming from CloudFlare IP addresses. For me, it looks like 11:13pm Central Time Zone on June 26th when I see CloudFlare IP addresses being used for my logon attempts with holleywoodstudio.com.

I've got a closed ocPortal site also hosted on Arvixe that still has CloudFlare enabled so I did some testing. I added three new symbols to symbols.php to grab the http_x_forwarded_for, remote_addr, and http_cf_connecting_ip $_SERVER variables and display them in the web page footer. What I see is the http_x_forwarded_for variable is always set to a CloudFlare IP address, the http_cf_connecting_ip is always set to my ISP provided IP address, and remote_addr seems to be randomly switching back and fourth between these two addresses.  Each time the remote_addr flip flops, I get a logon prompt.  I checked PHP Info on the sites with CloudFlare disabled and I don't see the http_cf_connecting_ip variable and both the http_x_forwarded_for and remote_addr are set to to my ISP provided domain, so that would seem to indicate that CloudFlare is properly disabled for those domains.

I'm gonna call it a night. I gotta be to work in 4 hours. I'll be back online after 3pm Central Time USA.
Back to the top
 
Posted
Rating:
#98350
Avatar

EDIT: Outdated post. See later post.

Thanks Jason,

This sources/support.php (v9) should be a secure workaround until Arvixe tracks this down:
Attachment
» Download: support.php (76 Kb, 150 downloads so far)


I just put this at the top of the get_ip_address function.

Code

   if (isset($_SERVER['HTTP_CF_CONNECTING_IP']))
   {
      $_SERVER['REMOTE_ADDR']=$_SERVER['HTTP_CF_CONNECTING_IP'];
      unset($_SERVER['HTTP_CF_CONNECTING_IP']);
   }


Last edit: by Chris Graham


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#98352
Avatar

Honoured member

Chris, am I supposed to be doing the same?
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Expand