HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Unable to reach admin start page

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#76142 (In Topic #15720)
Avatar

Community saint

Starting this morning, I get Error 500 - Request timeouts when trying to reach my admin start page. This was working fine yesterday afternoon and no changes have been made to the code. What might cause this to suddenly pop up? I can reach individual URLs within the admin area, just not the start page.

Thanks for any help.

Bob
Back to the top
 
Posted
Rating:
#76144
Avatar

Anything showing up in the ocPortal error log (/adminzone/?page=admin_errorlog) or the error log from Apache (accessible through cpanel)?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#76145
Avatar

Community saint

The only thing that shows up is this rather uninformative error in the cPanel error log:
2011-10-18 20:19:36.511 [INFO] [xxx.xxx.xxx.xxx:55572-0#APVH_xxx.xxxxxxs.com] File not found [/home/xxxxxxxx/public_html/xxxxx/500.shtml]

The only thing that looks add is the port.

Thanks for your help.

Bob


Last edit: by BobS
Back to the top
 
Posted
Rating:
#76148
Avatar

Community saint

Well, the problem magically fixed itself when the Tier 3 support person looked at the issue after about 16 hours of not working. I'll take it as even though I'd love to know why it happened and hope the issue does not resurface.

Bob
Back to the top
 
Posted
Rating:
#76165
Avatar

Community saint

Hmm…the problem is back as of this morning and intermittently all day. My host have checked the database server and repaired/optimized my DB. Even tried increasing the timeout on the server and still no luck.

So strange - things have been working fine and there has been no changes to the code and then this just starts happening. Is it possible the external links on the admin start page might be causing this problem?

Thanks for any help.

Bob
Back to the top
 
Posted
Rating:
#76168
Avatar

Hi,

Taking a look now (still have access from before). Can reproduce.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#76169
Avatar

Fixed. Was caused by the Google Page Rank lookups in the website monitoring block, the Google pagerank server is not responding to yours (don't know why, but wouldn't surprise me if they've changed something or don't like the automated queries anymore). To make sure external requests work on all servers (some web hosts put all kinds of restrictions on), we have some fallbacks and one of the fallbacks triggered a flaw in PHP where PHP would not timeout in the short time requested. That was compounded by the number of sites being monitored.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#76184
Avatar

Community saint

Thanks, Chris. Was really a small problem but it was driving me batty.

Bob
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: