HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


This is still causing me a problem!!!!!

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#29772 (In Topic #6839)
Avatar

Well-settled

 Chris

I have it set give the user the primary group of newuser and in the usergroup of Forum I have the Default group checked but after a new user creates a account on the system its assigning them newuser group but not letting them auto join the usergroup forum.

Thanks
Phil
 


Last edit: by ptaylor2
Back to the top
 
Posted
Rating:
#29774
Avatar

Usergroup edit screen, "Default group" tick box.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#29784
Avatar

Well-settled

Its still not working

 

Chris Graham said

Usergroup edit screen, "Default group" tick box.
 
By default when a new user signs up its assigning them the usergroup newuser and in the usergroup forum I have that also checked as the Default group but its not assigning them to the forum group.  When a new account is created I would like them to be assigned to newuser and to forum so I have to login every day and do it my self.

Thanks
Phil


Last edit: by ptaylor2
Back to the top
 
Posted
Rating:
#29836
Avatar

Hi,

I'd check for myself, except I don't have access to your members of groups pages even when logged in.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#29845
Avatar

Well-settled

Here is a screen shot of the usergroup

 

Chris Graham said

Hi,

I'd check for myself, except I don't have access to your members of groups pages even when logged in.
  Chris

Here is a screen shot of that user group.

Phil


Media


Last edit: by ptaylor2
Back to the top
 
Posted
Rating:
#29882
Avatar

I think you've found a bug. Please try changing line 360 of sources/ocf_members_action.php from:

Code

   } else $secondary_groups=array();
to:

Code

   } else $secondary_groups=ocf_get_all_default_groups();


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#29888
Avatar

Well-settled

That fix did not work

 

Chris Graham said

I think you've found a bug. Please try changing line 360 of sources/ocf_members_action.php from:

Code

   } else $secondary_groups=array();
 to:

Code

   } else $secondary_groups=ocf_get_all_default_groups();
 
Chris

I applied the patch and its still working.

Phil
Back to the top
 
Posted
Rating:
#29889
Avatar

I need to see a screenshot of a member profile view screen, for a member created after any changes to the usergroup settings, after this patch was applied. Please be careful to choose the right screen - I don't want any kind of edit screen, I need a screen like this:
ocPortal - helping you make your website
but of the new member, on your own site.
In addition a screen
ocPortal - helping you make your website
but of your 'default' usergroup on your site, would help.
There's no need to make a video, a simple image screenshot, in PNG GIF or JPEG format will do fine.
I only linked to a video program before because I needed to follow your clicks.
A program like this should make it easy:
IE Screenshot - Save entire webpages as images in one click.
But you can also do it without any special software (press 'Print Screen' then edit-paste into Microsoft paint, then save).

Please take care to carefully make up a case demonstrating the problem, so I'm not left guessing on specifics. I need to have a picture in my head of all pertinent details, and I need it demonstrated to me that there is a real problem, and not a misunderstanding - this i why I need those exact screenshots I've asked for above.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#29893
Avatar

Well-settled

ScreenShot

Chris Graham said

I need to see a screenshot of a member profile view screen, for a member created after any changes to the usergroup settings, after this patch was applied. Please be careful to choose the right screen - I don't want any kind of edit screen, I need a screen like this:
/site/pg/members/view/1774
but of the new member, on your own site.
In addition a screen
/site/pg/groups/view/8
but of your 'default' usergroup on your site, would help.
There's no need to make a video, a simple image screenshot, in PNG GIF or JPEG format will do fine.
I only linked to a video program before because I needed to follow your clicks.
A program like this should make it easy:
http://www.browsertweaks.com/screenshot.html
But you can also do it without any special software (press 'Print Screen' then edit-paste into Microsoft paint, then save).

Please take care to carefully make up a case demonstrating the problem, so I'm not left guessing on specifics. I need to have a picture in my head of all pertinent details, and I need it demonstrated to me that there is a real problem, and not a misunderstanding - this i why I need those exact screenshots I've asked for above.
 

Chris

Right now I am work and I tried uploading the 2.5Mb Screen shot but your Ocportal did not like the bmp file.  The other program you refeing to http://www.browsertweaks.com/screenshot.html that is loaded on my laptop and I do not have it here with me.

Here is a link for the screenshot http://www.cyberchatnet.com/screenshot1.bmp.  BY the time I get home it will be like 12 or 1 am your time.  I also confirmed by reloading the changes you told me to make in the file php file, and they are included in it.  I have not made any changes the forum users group since my last post.

Phil




Last edit: by ptaylor2
Back to the top
 
Posted
Rating:
#29898
Avatar

Ok, I've tracked this down. This is a very specific bug that happens in special circumstances.
To fix it change line 207 of pages/modules/join.php from:

Code

      $custom_fields=ocf_get_all_custom_fields_match($groups,NULL,NULL,NULL,1);
to:

Code

      if ($additional_group==-1)
      {
         $test=$GLOBALS['FORUM_DB']->query_value_null_ok('f_groups','id',array('g_is_presented_at_install'=>1));
         if (!is_null($test)) $additional_group=$test;
      }
      $custom_fields=ocf_get_all_custom_fields_match($groups,NULL,NULL,NULL,1);


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#29901
Avatar

Oh – instead of placing this fixed – just untick "Is presented at joining" on the edit screen for the usergroup. You don't want it to be a usergroup presented at joining (because that makes it the primary group), and this bug only happens if it is.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#29905
Avatar

Well-settled

I am confused

Chris Graham said

Oh - instead of placing this fixed - just untick "Is presented at joining" on the edit screen for the usergroup. You don't want it to be a usergroup presented at joining (because that makes it the primary group), and this bug only happens if it is.
 

Chris

If the maiin usergroup is newuser and if I uncheck Default group from the forum group how is this going to fix the problem.  I would like OcPortal assigned a user the primary group of Newuser and for the secondary group Forum when someone creates a new account?

Thanks
Phil



Back to the top
 
Posted
Rating:
#29910
Avatar

I advised to untick "Is presented at joining", not "Default group". You need to do this for your forum user usergroup.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#29912
Avatar

Well-settled

How do you get the forum usergroup

 

Chris Graham said

I advised to untick "Is presented at joining", not "Default group". You need to do this for your forum user usergroup.
  Chris

How do you get to the forum user group please? Once they this is done, will the users be able to access to all the forums please? In the tree permission editor from the root level the user have to be in the forum group in order to access the forums.

Thanks
Phil


Last edit: by ptaylor2
Back to the top
 
Posted
Rating:
#29916
Avatar

I mean the 'Forum Access' group, the one you showed me in your video.
Once they this is done, will the users be able to access to all the forums please?
For the new users, I believe so.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#29917
Avatar

Well-settled

How I get to this?

 

Chris Graham said

I mean the 'Forum Access' group, the one you showed me in your video.
Once they this is done, will the users be able to access to all the forums please?
 For the new users, I believe so.
 
Chris

How do I edit this please?  You need to do this for your forum user usergroup.
Back to the top
 
Posted
Rating:
#29918
Avatar

Well, you were on the edit screen before when you took the video. Just go to that screen (the Admin Zone 'Security' tab, then 'Usergroups', then 'Edit', then select the right usergroup, then click the button), change the tickbox, scroll to the bottom of the screen and click the button.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#29920
Avatar

Well-settled

Question

 

Chris Graham said

Well, you were on the edit screen before when you took the video. Just go to that screen (the Admin Zone 'Security' tab, then 'Usergroups', then 'Edit', then select the right usergroup, then click the button), change the tickbox, scroll to the bottom of the screen and click the button.
  Chris

After I set this once do I have to do it every time a new signs up? I wanted to have Ocportal to assign them the New member as the primary and Forum Access as the secondary group after the account was created so I do not have to do it every day.

Thanks


Last edit: by ptaylor2
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: