HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Template trouble.

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#24462 (In Topic #5832)

Non-joined user

I edited a block's template but the changes are not showing up on the main page.
The block is main_content.
I made sure I set the theme I am editing to show up in all zones.
I even took every bit of content out of the template and just left content and it still only displayed what it would if I made no changes.
I thought maybe it was a cashe issue so I ran the clean up tools, still the same thing.
Tried another from another site and that did the same thing.
 
Back to the top
 
Posted
Rating:
#24463
Avatar

Two questions:
  • How did you edit the template (via ocPortal, or manually)
  • What cleanup tools did you run? Specifically the block and template caches are involved here.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#24465
Avatar

Community saint

That was me on my lappy sorry I did not log in.
I edited it though the ocPortal.
http://ocpower.info/adminzone/index.php?page=admin_cleanup&type=misc
I checked all the boxes in that one.

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#24468
Avatar

Community saint

O dear I just did some thing stupid to try and fix this.
Basically what I am doing is trying to reset up ocPower using smf but with out deleteing the one that does not have smf and I did an import of the things from the none smf version and it messed up a few of the links. I was trying to import the downloads and cedi.

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#24486
Avatar

Community saint

I am just going to reinstall it and see what that does mainly cuz I have it so messed up I can not add any thing to either site now.

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#24493
Avatar

Well-settled

Ouch.

Hugz!

(((Ami)))


D
Back to the top
 
Posted
Rating:
#24503
Avatar

Ouch indeed :(. Jumping forum drivers is not supported – strange things can happen that are outside our control because the drivers are very much involved with how the site data is interpreted.

I'd have suggested checking that the template really has been saved properly, by checking that themes/yourthemename/templates_custom/BLOCK_MAIN_CONTENT.tpl existed, and that it was as expected.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#24773
Avatar

Community saint

I am having this template problem again. This time with a site that I set up for only skin development so the only changes I am making are template changes.
I was editing Main_forum_topics and refreshed the page and none of the changes I made showed up so I did the changes again.
Still did not show up.
So I emptied the template again and it still did not show the changes, would have thought it would have showed a blank spot on the screen where that block shoul be but it showed the original box.
So I went into ftp and Looked to see if I opened it in php desinger if the changes I made would show up and opening it in there did infact show an empty file.
So I was wondering what would happen if I deleted the template from ftp/server and then refreshing the page and out of my amazement the block was still there. So I double checked to see if the template was any where else on the ftp so I deleted it from every where and the block still showed up.
So now I am at a huge loose as to what is going on and why this keeps happening to me.

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#24779
Avatar

Try holding Ctrl+Alt+Shift down when you refresh. It instructs ocPortal to clear all the template and block caches, and should work.

Back to the top
 
Posted
Rating:
#24796
Avatar

This does sound pretty bizarre- I'm tempted to think that this might actually be a "transparent proxy cache". In other words, some computer between the server and your own could be cacheing the page.

Your line of investigation is very good. In your position I would continue it by trying to re-use the block with different parameters - because there's no way that ocPortal could cache that and it'd have to load up the template.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#24801
Avatar

If the block is showing a 'no entries' message, it's using BLOCK_NO_ENTRIES.tpl instead – could this be the problem?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#24806
Avatar

Community saint

Hmm that could be the problem. I will try editing that block. Thank you.

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#24810
Avatar

Community saint

Ctrl+Alt+Shift ← That did fixed it.

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#24818
Avatar

Community saint

yay that command works great, I am so happy its working now.

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#24835
Avatar

Community saint

Working with out the command now.
Although I found a faster way to do it. I copied all the templates to my pc and am editing one by one using php designer and then uploading them when I get them done and viewing the page and it works. I have almost every block you can have on the main page just to test this.
I hope to have at least 1 skin for download by this weekend.

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#24836
Avatar

:)

Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: