HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


[Solved]Probation - Is she still on parole? and a couple others

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#46462 (In Topic #10140)
kgw
Avatar

Well-settled

O.K. I asked a friend if I could put her on "Probation", I assured her I would fix her account when I was done playing. She posted in "General Chat", and I "Warned her". I fiddled around and fixed her account afterwords. Now when she goes into forums "General Chat" her "Add Topic" button is missing! She can add a new topic in all other forums except for the one I put her on probation in! Whats the fix?

Also, The user name above the avatar, how can I get them to align left?


Last edit: by kgw

5 billion Chinese and I had to get a girlfriend that can nag in English.
Back to the top
 
Posted
Rating:
#46465
Avatar

O.K. I asked a friend if I could put her on "Probation", I assured her I would fix her account when I was done playing. She posted in "General Chat", and I "Warned her". I fiddled around and fixed her account afterwords. Now when she goes into forums "General Chat" her "Add Topic" button is missing! She can add a new topic in all other forums except for the one I put her on probation in! Whats the fix?

Is it possible that you changed the permissions to this forum separately?
Probation applies to all forums, so shouldn't affect any individual forum separately.
I don't think you used the silencing feature did you?

Also, The user name above the avatar, how can I get them to align left?

Look for '.ocf_topic_poster_name' in ocf.css (edit via the theme tools inside ocPortal).


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#46468
kgw
Avatar

Well-settled

I am begining to think these errors being thrown are sitegrounds.
Let me kind of explain.
First. You know how you guys say "Make a back Up"? Well, oops.
So for fun I decided to try your "Beta". In Ver 4 My admin zone and status link pointed back to the start page. It also threw an error. I killed that and went back to Ver 4, the error is gone, but the Admin Zone and the Status link point to the start page and NOT there respective links.
So here's My Theory.
I have Ocportal at Community.Mysite.com. It hates me. So I am going to install it to mysite.com/community.
My main page is Wordpress so Ocportal is secondary.
The wordpress is my blog and OCportal I am using for my community.
I'll let you know what happens.

5 billion Chinese and I had to get a girlfriend that can nag in English.
Back to the top
 
Posted
Rating:
#46469
Avatar

In Ver 4 My admin zone and status link pointed back to the start page.

Did you run the debrand tool?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#46470
kgw
Avatar

Well-settled

Debrand Tool? I haven't seen anything on that and I have been re-reading through your install pages.
I have noticed that when I use, mysite.com/community It throws a page can not be displayed error.
I have been doing fresh installs as I have not had OCportal officially on line yet.

5 billion Chinese and I had to get a girlfriend that can nag in English.
Back to the top
 
Posted
Rating:
#46471
kgw
Avatar

Well-settled

OK Fresh install (Latest Version, Non Beta), just a click thru………
Admin Zone and Status point to
/adminzone/index.php?page=start
What are the correct links?

Not getting the "ocf_topic_poster_name" Error.
I am stymied. Everything else appears to be working.

5 billion Chinese and I had to get a girlfriend that can nag in English.
Back to the top
 
Posted
Rating:
#46472
Avatar

Community saint

Looks correct, here's one of mine:

Code

http://xxx.xxx.com/adminzone/index.php?page=start

"no violence, no hate, no pain, no enemies
just peace, unity, tolerance and love" - The Beloved

OCP V7 | Advocating monetary reform - FreeOurMoney

Need OCP friendly hosting? Look no further:
Web Hosting, Reseller Hosting, and Dedicated Servers w/cPanel - Elief! - Official hosting partner for ocPortal.
Back to the top
 
Posted
Rating:
#46474
kgw
Avatar

Well-settled

Mine takes me to the front page of the site, I see no difference clicking it. Just like the Status page does. I did get the status page to work once but have no clue how.

5 billion Chinese and I had to get a girlfriend that can nag in English.
Back to the top
 
Posted
Rating:
#46475
Avatar

Do you have an .htaccess file either in the ocPortal directory or a directory above it?

If so try disabling that temporarily.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#46476
kgw
Avatar

Well-settled

"Internal Server error" when disabling .htaccess in the root. If I enable the htaccess in the ocportal it throws an internal to.

"File does not exist: /home/kindagre/public_html/community/error_500.htm"

5 billion Chinese and I had to get a girlfriend that can nag in English.
Back to the top
 
Posted
Rating:
#46479
kgw
Avatar

Well-settled

I dont know what to do. I got your online installer to work and installed it from there. I also installed it in the main directory (/public_html)

Code

[b]Parse error[/b]: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in [b]/home/kindagre/public_html/wolfscommune/sources/config.php[/b] on line [b]127[/b]

I think it must be Siteground.

5 billion Chinese and I had to get a girlfriend that can nag in English.
Back to the top
 
Posted
Rating:
#46486
Avatar

Hi kgw,

I'll get a reply to you on all this. I'm super-busy before Christmas though, so it might take a few days.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#46496
kgw
Avatar

Well-settled

No worries Mr. Graham. But is there a way I can test siteground servers? I think half of my problems are there taxing there cpu's again.

On your automatic update you have "1000" for FTP transfer, if I put that numer over 150 it white pages.

5 billion Chinese and I had to get a girlfriend that can nag in English.
Back to the top
 
Posted
Rating:
#46504
Avatar

Community saint

kgw: drop me a PM with credentials you would like and I'll setup a temp OCP4 instance for you on my server.

"no violence, no hate, no pain, no enemies
just peace, unity, tolerance and love" - The Beloved

OCP V7 | Advocating monetary reform - FreeOurMoney

Need OCP friendly hosting? Look no further:
Web Hosting, Reseller Hosting, and Dedicated Servers w/cPanel - Elief! - Official hosting partner for ocPortal.
Back to the top
 
Posted
Rating:
#46513
kgw
Avatar

Well-settled

Will do, but I need it to run on my server as I can't afford to keep switching them :-) This from siteground

SiteGround said

The "Page not found" error though is a result of a problem with the script. You are getting page not found due to the rewrite rules in the .htaccess file for your WordPress installation. The actual error however is:
 
[Sun Dec 21 00:45:07 2008] [error] [client 87.118.135.131] Premature end
I moved Wordpress from the root and installed OCportal and it still throws errors.
When I try Ocportals .htaccess I get "Internal Server Error".

Now my members are complaining they want OCportal back after my test run. So up it goes, and I will try to fix there errors! Grrrrrr……..

5 billion Chinese and I had to get a girlfriend that can nag in English.
Back to the top
 
Posted
Rating:
#46515
Avatar

Community saint

I never did like siteground, in my personal opinion from personal experience they are one of the worst hosts.

Although what you said in your post above reminds me of when I tried mkportal, I got lots of complaints from members, my members want me to stick with ocportal and I am going to its better so its kind of a win win thing for me.

Any way good luck.

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#46519
kgw
Avatar

Well-settled

Well I got the admin and the status to throw a

Code

The requested page ([tt]error_500[/tt]) is missing
on admin zone and Status.
Hear ya on siteground.
The fights on to get OCportal to work because of my members and the help here. These people aren't condescending like most other CMS groups. Not to worried about the admin zone and status as I can take a bloody nose once in a while :-D

5 billion Chinese and I had to get a girlfriend that can nag in English.
Back to the top
 
Posted
Rating:
#46555
kgw
Avatar

Well-settled

For people following this, as per site I used Recomended.htaccess and changed to .htaccess.
I then Manually started killing stuff line by line.

Code

# ocPortal needs uploads; many hosts leave these low
php_value post_max_size "16M"
php_value upload_max_filesize "16M"

# Turn insecure things off
php_flag allow_url_fopen off
php_flag register_globals off

# Put some limits up. ocPortal is stable enough not to cause problems- it'll only use higher limits when it really needs them
php_value memory_limit "-1"
php_value max_input_time "60"


# Set ocPortal to handle 404 errors. Assume ocPortal is in the root
ErrorDocument 404 /index.php?page=404
this stop ALL internal errors on all pages except for Adminzone and status.

5 billion Chinese and I had to get a girlfriend that can nag in English.
Back to the top
 
Posted
Rating:
#46575
Avatar

Debrand Tool? I haven't seen anything on that and I have been re-reading through your install pages.

Never mind, this messes with the Admin Zone front page so potentially could have been a cause.

the Admin Zone and the Status link point to the start page and NOT there respective links.

Mine takes me to the front page of the site, I see no difference clicking it. Just like the Status page does. I did get the status page to work once but have no clue how.

Looks like you've got this fixed. To clarify, it was almost certainly caused by Wordpress's htaccess putting some weird redirection rules in place.

I'm glad you got ocPortal's working right.

Not getting the "ocf_topic_poster_name" Error.

What I said about this was about how to align the poster's name left.

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/kindagre/public_html/wolfscommune/sources/config.php on line 127

Not sure about this one. I know technically the case (broken PHP code in the ocp4_config table), but I think some form of corruption will really be to blame. I think it's not happening for you anymore?

No worries Mr. Graham. But is there a way I can test siteground servers? I think half of my problems are there taxing there cpu's again.

The installer would have flagged up any major problems, so I don't think there's a big problem at the hosting end. We try and not pass the buck back to the web hosts - usually there are workarounds to weird hosting setups, so I'm happy to keep searching for a cause if you are.

On your automatic update you have "1000" for FTP transfer, if I put that numer over 150 it white pages.

Ah right, that does indicate the server's being rather slow. It could be a number of things- CPU, hard disk, or it could just be the host's FTP server isn't as fast as others.

this stop ALL internal errors on all pages except for Adminzone and status.

These are the same thing (front page to the Admin Zone is the same as the 'Status' link in the Admin Zone menu).

I'm not sure exactly what is causing this, but it's likely a block on this page. If you go to the CMS zone, then the Comcode Pages icon, then go through and edit the adminzone:start page. Chop bits out till it works.
I suspect chopping out [block]main_staff_new_version[/block] will make it work. If this is the case the server is having problems communicating with our own (to check your version is up-to-date).


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#46587
Avatar

kgw said

O.K. I asked a friend if I could put her on "Probation", I assured her I would fix her account when I was done playing. She posted in "General Chat", and I "Warned her". I fiddled around and fixed her account afterwords. Now when she goes into forums "General Chat" her "Add Topic" button is missing! She can add a new topic in all other forums except for the one I put her on probation in! Whats the fix?

I was a bit confused about this at the time, but I realise what caused it now.

Silencing can't be reversed. It has to auto-expire at the set time. We'll change this in 4.1.4, out very soon.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Expand