HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


[Solved]Critical fault

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#72337 (In Topic #15174)
Avatar

Community saint

After processing to install the addon Author I got this error:

Critical error – bailing out
This is an error that has been elevated to critical error status because it occured during the primary error mechanism reporting system itself (possibly due to it occuring within the standard output framework). It may be masking a secondary error that occured before this, but was never output - if so, it is likely strongly related to this one, thus fixing this will fix the other.
Unfortunately a query has failed [SELECT COUNT(*) FROM ocp_authors LIMIT 1] [Table 'xxx_xxx.ocp_authors' doesn't exist] (version: 7.1.1, PHP version: 5.2.17, URL: /adminzone/index.php?page=start)

The problem is now I can't use the whole admin zone!!
Tryed to set back a system backup, but this is not working.
Some one has a idea for a solution please?

Thanks Harry


Last edit: by Harry-S


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#72343
Avatar

Community saint

Same problem I had when trying to install the gallery addon.

You are missing the "ocp_authors" table in the db.

The quick fix: if you have a test server with ocP on it and it has that table you could import it into your db like I did. That allowed me to access admin again.

Or, wait for the fix from Chris.

Steve
Back to the top
 
Posted
Rating:
#72344
Avatar

Community saint

yes I know, I have checked the database. Shame a me, but I have no test server at the moment. So I need to wait for Chris to solve my problem.

Thanks anyway.


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#72352
Avatar

Community saint

oke after setup a test server…. yes i know :) … I could tranport the missing table, so now admin zone is working again.

But there are more missing tables I saw.  Like ocp_prices. So i need again copy from test. Its keep you from the street en the pub… haha


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#72382
Avatar

You really should not copy tables around manually, the chance of getting the structure correct (such as semantic definition within the db_meta table) are low, and if a module is not installed and it's table is already there, it could theoretically crash on installation (leaving missing config options, permissions, etc). At the very least it is going to lower the chance of bug reports being reproducible by creating an inconsistent state.

If you visit the authors module by going to /site/?page=authors it will install the missing database stuff.

I do not know why it did not auto-install though, I will run some more tests.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#72384
Avatar

Community saint

Chris, thanks for reaction, but its not only the authors addon who missed tables, I came today also ocp_sales, ocp_prices and ocp_ pstore_customers who are not in the database after install them from addon section.
I have installed a blanc testserver, from there database I have copy the missing tables. And now its working all without any problem. This in connection witch the points addon.

Oke it's not the way how it has to go, but its working. :dry:


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#72385
Avatar

If pointstore is not installed those tables should be missing.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#72386
Avatar

Community saint

Thats the point, I had installed the point store...


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#72389
Avatar

Ah right.

When you installed it did you do it via the green plus – or by using the checkbox and button?

Was it uninstalled through the Setup Wizard originally, or did you uninstall it yourself manually?

Was the above done on an earlier version?

Has it been explicitly re-installed before (i.e. been uninstalled, then reinstalled, then uninstalled, then failed to reinstall a second time)?

Were there any errors at any point, such as timeouts, or generally things that went away when refreshing?

Could you attach a copy of the imports/pointstore.tar file so we can examine it.

Could you attach a copy of your addons_files table (structure and contents)?

Do you have the 'single public zone' option on?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#72391
Avatar

Community saint

Attachment
Pointstore.tar
» Download: pointstore.tar (273 Kb)
Attachment
the export addon_files
» Download: ocp-addon_files.sql (917 Bytes, 104 downloads so far)
Chris I use the leatest version in a new clean install. The author and point store are installed afterwards by clicking the green plus sign in the addon section of admin. After the install from author mod The whole admin zone was not visble, error see my first post. After that I copyed the table from a fresh standaard test server on the same domain and own database, the problem was solved.

After that I installed the same way the point store mod. No problem with admin zone, but when I want to the pointstore configuration I got the error: ocp_prices not found in database. The same for ocp_pstore_customers and ocp_sales.  Not more.

I have setup from addon also installed two other mods and have no problem with them.

I use the single-zone methode.
So all with all, the problems came after the the normal setup when the site was already setup and online.


Last edit: by Harry-S


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#72392
Avatar

If you could get me these:
Could you attach a copy of the imports/pointstore.tar file so we can examine it.

Could you attach a copy of your addons_files table (structure and contents)?

then that will definitely help me investigate.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#72393
Avatar

Community saint

Is attached now


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#72394
Avatar

thanks!


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#72395
Avatar

Community saint

I have the same by the following addon, also afterwards installes, when I want to make a quiz I got :

Unfortunately a query has failed [SELECT * FROM ocp_newsletters ORDER BY id] [Table 'studio_base.ocp_newsletters' doesn't exist] (version: 7.1.1, PHP version: 5.2.17, URL: /cms/index.php?page=cms_quiz&type=ad&keep_session=1219392387
)

So this mean, that all the afterwards installed addons from 7.1.1 gives the same problem on my server.


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#72398
Avatar

I have done a number of tests now, and couldn't see a problem. However, I may have fixed it already for another user(s) on the latest subversion version, so I've attached the latest file where the fix would be.

Attachment
sources/addons.php
» Download: addons.php (28 Kb, 122 downloads so far)


Please try this file and let me know if uninstalling then reinstalling the newsletter addon fails to fix the quiz error.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#72405
Avatar

Community saint

Chris,

I have uploaded the fix, unstalled the quizz mod thru addon zone. After this reinstalled.
When I hit Quizzes in content management, i got the same error again:

Code

Unfortunately a query has failed [SELECT * FROM ocp_newsletters ORDER BY id] [Table 'studio_base.ocp_newsletters' doesn't exist] (version: 7.1.1, PHP version: 5.2.17, URL: /cms/index.php?page=cms_quiz&type=ad)

Harry


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#72408
Avatar

The issue is on newsletters, so that's the one you need to reinstall. Then test quizzes. It's a flaw in the detection of the dependency between them – somehow newsletters was only 50% installed, enough for the quiz code to try and use it.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#72412
Avatar

Community saint

Chris thanks, its working now!!


http://digiflash.nl Photo community  (dutch)
Back to the top
 
Posted
Rating:
#72413
Avatar

Phew


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: