HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


short URLs - need more info

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#54131 (In Topic #11810)
Avatar

Honoured member

hi. I am running the 4.2 RC1.

I have a very basic, new, not modified in any way install. (I tweaked some layout things in the template that's all) Haven't added any actual content of my own in yet…have lots to, but I want to make sure the URLs will be right in any hard-coded links I need to set.

I just moved the site from it's testing folder to it's permanent home basically it was in /new - and now it's the site root). I turned on the Short Urls and the new style short urls - set the .htaccess in, and put the base url of the site correct to the new spot (removed the /new). And cleared the cache.

Everything is fine and functioning.

The short URLs won't work.

Well, they do, but you have to type them in manually, they aren't automatic anywhere. so all the long urls still show all over the site…but if you re-word them in the location bar, they do work.

did I miss something?

I'm on the elief hosting and everything…looking to go live. Any help with anything I might still need to do is appreciated.

www.dimestoreproductions.com
Back to the top
 
Posted
Rating:
#54165
Avatar

Honoured member

I have updated to RC2 - the short URLs are still not working as described. Any help would be appreciated.
Back to the top
 
Posted
Rating:
#54167
Avatar

Fan in action

Do clean_urls work?

If I've helped you, please click 'points' and show your appreciation!
Back to the top
 
Posted
Rating:
#54168
Avatar

Honoured member

can you tell me where to look to give that answer?
Back to the top
 
Posted
Rating:
#54174
Avatar

Fan in action

There are two types of short-URLs:
  • Clean urls (zone/index.php?page=rules -> zone/pg/rules)
  • URL monikers (like here where text is used to identify entries & categories instead of IDs and codenames)
Options for both are found on the site-options configuration screen. Turn of monikers and see if the clean urls still work. Maybe you can diagnose what the problem is from that.

If I've helped you, please click 'points' and show your appreciation!
Back to the top
 
Posted
Rating:
#54177
Avatar

Honoured member

hmmmm, yes, I had already turned that off…in fact, I can turn them all off and produce the same site-conditions.

Short Urls
Monikers
new style short url

when all are off, I can use either:

http://www.dimestoreproductions.com/site/start.htm

or

http://www.dimestoreproductions.com/site/index.php?page=start

same as if they are all on. The second of those is what SHOWS though. I want the short ones to show.

If I turn on monikers, it uses words in the urls…

Forum - Dimestore Productions

but i'm leaving it off till the short urls are showing correctly.

i mean, I'm assuming the .htaccess (which i've got the preffered one going) is working and everything, or the .htm urls wouldn't work at all. I don't know what to do to get them to SHOW in the site's showing of urls though…if turning it on isn't actually changing anything.
Back to the top
 
Posted
Rating:
#54204
Avatar

"Clean urls" needs to be on.

If you go to PHP-info, what does "SERVER_SOFTWARE" say?

Also, if you disabled mod_rewrite using the config_editor.php script, that would block it from working.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#54209
Avatar

Honoured member

Chris Graham said

"Clean urls" needs to be on.
Do you mean Short URLs? under Set Up -> Site Options -> advanced? that is definitely on.
If you go to PHP-info, what does "SERVER_SOFTWARE" say?
Lightspeed
Also, if you disabled mod_rewrite using the config_editor.php script, that would block it from working.
I have not blocked mod_rewrite there, and i checked and it's set to 0.

The rewrites are actually WORKING, they just aren't showing…I'm waiting to figure this out to add anything else/do anything else on the site.

The one thing I was wondering is: When I set up the database, I did it in a /new folder on the site, so I could leave the old site up and running till I was ready. Then I moved the files when I switched, using the config editor to take the /new out of the base url. As it says not to use the new style urls if you're not on the base, I did not turn on any of the url stuff till after I moved it.

It's just weird cause the URLs work if you manually type them in…

Appreciate your help figuring this out.
Back to the top
 
Posted
Rating:
#54211
Avatar

Honoured member

could it be because I have added one zone but not added anything to the htaccess for that zone?

Is there any info on WHAT to add to htaccess when you add a zone? For right now, I can try deleting the zone…
Back to the top
 
Posted
Rating:
#54212
Avatar

Honoured member

deleting the zone didn't work….still same behavior.
Back to the top
 
Posted
Rating:
#54215
Avatar

This should fix it:
Attachment
sources/urls.php
» Download: urls.php (27 Kb, 91 downloads so far)


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#54219
Avatar

Honoured member

Well, I put that file in, and it didn't change the behavior. I looked at the file, compared it to the original to see what was changed, then looked on the server to make sure the file uploaded correctly with the change, and it did.

I purged the cache, checked the settings again. None of that got the URLs showing, to be the short ones. Sorry.

If you need any more info or access just ask, hope this all helps everyone in the long run….
Back to the top
 
Posted
Rating:
#54224
Avatar

Did it definitely say Lightspeed, and not e.g. LightSpeed or lightspeed?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#54226
Avatar

Honoured member

ooo, see, now that's what I get for not copying and pasting…it says…

   LiteSpeed
Back to the top
 
Posted
Rating:
#54227
Avatar

Honoured member

I can confirm that changing that in the file you sent, fixes the problem, and the URLS now show perfectly.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: