HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


[RESOLVED] in v6 pressing "Launch upgrader" button on admin page does nothing in firefox

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#67618 (In Topic #14411)
Avatar

Community saint

Clicking on the "Launch upgrader" button does nothing in firefox. Launches ok on IE8.


Last edit: by temp1024

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#67622
Avatar

Probably you have a popup blocker.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#67624
Avatar

Community saint

Chris Graham said

Probably you have a popup blocker.

It is enabled, so you are probably right.

Sorry about that false alarm. I'm seeing so many errors at the moment since my 6.0.1 upgrade that I just threw that on the pile without thinking too much about it.

I have a couple more real errors coming your way soon.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#67662
Avatar

Community saint

I just realised that I have the pop-up blocker on but the "Emoticons popup" link still pop-up. That's strange.

Must be some slight difference between "Emoticons popup" and the "Launch upgrader" button.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#67663
Avatar

Community saint

Allow me the luxury of butting in here …
  • Firefox 4
  • One site with 'narrow' box will NOT launch the upgrader
  • Other site with 'wide' box launches upgrader without a problem

Hope that helps.

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#67664
Avatar

Community saint

Fletch said

Allow me the luxury of butting in here …
Your more then welcome. After all, this is a public forum  :P .

Fletch said

  • Firefox 4
  • One site with 'narrow' box will NOT launch the upgrader
  • Other site with 'wide' box launches upgrader without a problem

Hope that helps.

 :thumbs:
This just gets stranger and stranger. At least it doesn't look like a false alarm after all.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#67673
Avatar

Just had a look. It did work on the default Admin Zone front page with Firefox 4 for me. But I don't have any blocker addons installed. If it behaves differently on different sites my first suspicion is the popup blocker is configured with the site that works as an exception.
The button is generated via Javascript and opens into a new window via a simple form target. Maybe the blocker thinks Javascript generated buttons are suspicious.
If it is an additional popup blocker I think the moral is that these aren't included because they can break normal web standards behaviour ;).


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#67681
Avatar

Community saint

I've had a look in a v5.0.3 test environment and I can confirm that the problem is not with any pop-up blocker.

Mouse movement is not registering properly over that button and as a result what is recognised as a clickable area is mostly the outer edges of the button.

So if you move-around your mouse on the button you will see that it will only highlight, and therefore become clickable, around the edges. Looks like its the way that specific button is defined as I don't see that problem with any other buttons.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#67720
Avatar

Well done. That was indeed the problem (and it'll be a Firefox bug probably). I normally click near the top of buttons so did not notice, lol.
It will be fixed, but the fix will be in the next release and hence won't be noticed until after that upgrade.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#67826
Avatar

Community saint

Resurrecting this one. The new version (6.0.2) doesn't seem to have fixed the FF issue for the button.

  • IE 9 — no problems
  • Chrome 10 — only top of button is functional
  • Opera 11 — only top of button is functional

and finally:
  • Firefox 4

Launch Upgrader - narrow box


Launch Upgrader - wide box


Any ideas?

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#67829
Avatar

Community saint

v6.0.2 contains the fix, but you will not be able to use/see it until the next patch (v6.0.3?) comes along.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#67836
Avatar

Community saint

*grin*, chicken/egg deal as I can't see if it's fixed on mine either until 6.03 is released as mentioned by temp1024. Prior to the fix, I used Firebug to expand the adminzone status screen to full screen width and that gave me more clickable real estate on the button.

Given this issue and the other with the titles Fletch, were there any issues with your upgrade that may have resulted in gremlins?

"no violence, no hate, no pain, no enemies
just peace, unity, tolerance and love" - The Beloved

OCP V7 | Advocating monetary reform - FreeOurMoney

Need OCP friendly hosting? Look no further:
Web Hosting, Reseller Hosting, and Dedicated Servers w/cPanel - Elief! - Official hosting partner for ocPortal.
Back to the top
 
Posted
Rating:
#67848
Avatar

Community saint

SoccerDad said

Given this issue and the other with the titles Fletch, were there any issues with your upgrade that may have resulted in gremlins?
Nothing I can shake a stick at, SD!

No alarms, no warnings. The file integrity check, in the main, pointed out overrides and outdated files that I've since deleted or 'sorted'.

I'll keep on truckin' and see where it gets me …

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#68218
Avatar

Community saint

The egg has finally caught up to the chicken.

Works for me, so I'll mark this topic as RESOLVED.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: