HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


[Resolved] Errors while opening chat lobby page as adminESOLVED]

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#69332 (In Topic #14683)
Avatar

Community saint

When I go to the chat lobby page (as admin) I get the following errors:

in Firefox

Code

An error occurred when loading this screen onto the web browser. You are being notified of this as you are staff. If you believe this is a bug in the website software, please contact ocProducts with full details. More details are available in your browser's error console. The error was:

157: chat_lobby_convos_tabs.childNodes[i].getAttribute("id") is null
.../themes/mytheme/templates_cached/EN/javascript_chat.js

In IE

Code

Message: Can't move focus to the control because it is invisible, not enabled, or of a type that does not accept the focus.
Line: 439
Char: 2
Code: 0
URI: .../themes/mytheme/templates_cached/EN/javascript.js


Last edit: by temp1024

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#69336
Avatar

Community saint

Tried to confirm this for you mate but was unable to do so. Deatils for reference: For testing I used FF 4 and IE 9 under Win7 and FF 4 under Linux. Site is running OCP 6.1.1. Logged in as the actual admin account.

I did bump into something different, however, I'm pretty sure it's related to me having the sound disabled on VirtualBox for my Win7 installation. Got this while attempting to create a new chatroom, logged in admin:

"no violence, no hate, no pain, no enemies
just peace, unity, tolerance and love" - The Beloved

OCP V7 | Advocating monetary reform - FreeOurMoney

Need OCP friendly hosting? Look no further:
Web Hosting, Reseller Hosting, and Dedicated Servers w/cPanel - Elief! - Official hosting partner for ocPortal.
Back to the top
 
Posted
Rating:
#69350
Avatar

Community saint

I'm running v6.2RC1. That smURL bug was reported and fixed a few weeks ago here: View topic: [RESOLVED] "smURL is null" error in chat lobby - ocPortal .


Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#69351
Avatar

Community saint

Kewl, thanks for the heads up!

"no violence, no hate, no pain, no enemies
just peace, unity, tolerance and love" - The Beloved

OCP V7 | Advocating monetary reform - FreeOurMoney

Need OCP friendly hosting? Look no further:
Web Hosting, Reseller Hosting, and Dedicated Servers w/cPanel - Elief! - Official hosting partner for ocPortal.
Back to the top
 
Posted
Rating:
#69355
Avatar

I'm including a possible fix for the posted issues in v7.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#69394
Avatar

Community saint

Upgraded to v7.

The Firefox error has gone, but the IE error still remains although its @ Line: 446 now.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#69401
Avatar

Hopefully this'll fix it.

Attachment
» Download: CHAT_LOBBY_IM_AREA.tpl (2 Kb, 109 downloads so far)


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#69405
Avatar

Community saint

That seems to have done the trick Chris, Thanks!.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: