HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


[RESOLVED - 3 items] - 6.0b1 - Mega LOGIN problem

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#66069 (In Topic #14131)
Avatar

Community saint

It MAY or MAY NOT be coincidental, but after uploading the bundled '6-fix' that you rolled out, I cannot login to my site …

… which made me check the table to see WHY I wasn't 'confirmed' …

… only to discover I apparently WAS!

So, it was off to the 'Disaster Recovery' tute where I followed the 'db' method.

NADA

Then chose the sneaky 'backdoor' method:

SUCCESS

But, on removing the 'backdor' users.php I was blocked from logging in once again. This time being identified as a 'Guest'.

The 'backdoor' has been reinstated and is still in place, but I'd rather it wasn't. So, can anybody please advise where and what I should do next.

Thanks


Last edit: by Fletch

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#66075
Avatar

Community saint

Additional to LOGIN problem - (not necessarily related) - after logging in using the 'backdoor' and attempting to run ocP tools:
An error has occurred

PHP NOTICE [8] Undefined variable: install_php_file in /home/fletch/public_html/anglo/sources/hooks/modules/admin_c
leanup/page_stats.php on line 107 (version: 6.0 beta2, PHP version: 5.2.15, URL: /anglo/adminzone/index.php?page=admin_cleanup&type=rebuild)

Expand: Stack trace: Stack trace:


Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#66079
Avatar

Hi Fletch,

I'm going to look into this now. I suspect there may be some issue with the persistent caching on your server. If that's the case it can be disabled easily.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#66080
Avatar

Community saint

Chris Graham said

I'm going to look into this now.

Thanks, Chris.

If it helps any, the following is the 'other face' of the same problem …


 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#66081
Avatar

Attachment
sources/hooks/modules/admin_cleanup/page_stats.php
» Download: page_stats.php (4 Kb, 96 downloads so far)


Page stats cleanup fix attached (unrelated issue).


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#66082
Avatar

Could you e-mail me FTP details and an account I can try to login with please Fletch? (chris@ocportal.com).

Regarding not being able to log out, the back-door will have that effect.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#66084
Avatar

Community saint

Done

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#66085
Avatar

Community saint

I may as well add this here, too. Running ocP cleanup tool for 'Topics', I get this …
An error has occurred

Unfortunately a query has failed [SELECT id FROM ocp5_f_polls 500 LIMIT 0] [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '500 LIMIT 0' at line 1] (version: 6.0 beta2, PHP version: 5.2.15, URL: /anglo/adminzone/pg/admin_cleanup/rebuild)

The stack trace is HUGE - it looks like every topic in my Forum is replicated - so not attached. But if you need elements of it, I can extract them.

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#66086
Avatar

(Fix attached)

Attachment
sources/hooks/modules/admin_cleanup/ocf_topics.php
» Download: ocf_topics.php (3 Kb, 77 downloads so far)


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#66087
Avatar

Community saint

That fixed it.

Thanks.

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#66088
Avatar

Hi,

I think this may be a cookie problem. I think the session cookies aren't sticking and it's falling back to username/password cookies which probably already existed but wouldn't stick either if they didn't.

I can't see anything wrong with your cookie configuration though.

I would try two things:
  1. Delete the cookies for your domain name and any variants of it. See if that fixes the problem for you.
  2. If the problem is not fixed, see if the "ocp_session" cookie is saving. The firefox "Web Developers Toolbar" extension has a good cookie viewer feature. If it's not saving I'd try another browser and see if that makes a difference and also try blanking out your cookie domain and path in your info.php file.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#66092
Avatar

Community saint

Chris Graham said

I would try …
  1. Delete the cookies for your domain name and any variants of it. See if that fixes the problem for you.
  2. If the problem is not fixed, see if the "ocp_session" cookie is saving … if it's not saving I'd try another browser …

Thanks Chris. You nailed it.

For some unfathomable reason my FF appears to have been set to only clear cookies for the last 4 hours. So, each time I used the 'clear recent history' tool, I wasn't touching the 'corrupt' session cookie that had lodged itself comfortably on my system.

I am now able to login using the 'normal' sources/users.php and the 'backdoor' has been removed.

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: