HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Removing "</ br>" from side menu

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#68672 (In Topic #14580)
Avatar

Community saint

I am trying to set the blocks on the side with no spacing between them. I want to eliminate the "</ br>"  from between the blocks but I am not able to - no matter how many times I go in an remove them they always come back.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#68673
Avatar

Community saint

If I am understanding your issue correctly, the <br /> is places there if you have blank lines between your blocks. For example, the following will will place a <br /> between the blocks:

Code

[block="1" ]side_shoutbox[/block]

[block]side_news[/block]
While this will not:

Code

[block="1" ]side_shoutbox[/block]
[block]side_news[/block]

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#68675
Avatar

Community saint

temp1024 said

If I am understanding your issue correctly, the <br /> is places there if you have blank lines between your blocks. For example, the following will will place a <br /> between the blocks:

Code

[block="1" ]side_shoutbox[/block]

[block]side_news[/block]
While this will not:

Code

[block="1" ]side_shoutbox[/block]
[block]side_news[/block]
Yes I want to get rid of the spaces between blocks and it sounds so simple to go in and remove the space either in WYSIWYG mode or SOURCE mode but I haven't been able to make it show up right. Here is the source code I want to get rid of every "</ br>" except the one before the ocPortal logo.

Code

<span class="ocp_keep_block">[block=&quot;main_features&quot; type=&quot;tree&quot; caption=&quot;Features&quot;]side_stored_menu[/block]
</span><br />
<span class="ocp_keep_block">[block=&quot;main_content&quot; type=&quot;tree&quot; caption=&quot;Content&quot;]side_stored_menu[/block]
</span><br />
<span class="ocp_keep_block">[block=&quot;main_community&quot; type=&quot;tree&quot; caption=&quot;Community&quot;]side_stored_menu[/block]
</span><br />
<span class="ocp_keep_block">[block]side_stats[/block]
</span><br />
<span class="ocp_keep_block">[block]side_users_online[/block]
</span><br />
<span class="ocp_keep_block">[block]side_personal_stats[/block]
</span><br />
<div style="text-align: center;">
    <a class="link_exempt" href="http://ocportal.com/?from=logo" rel="" target="_blank" title=" : (this link will open in a new window)"> <img alt="Powered by ocPortal" src="http://ocportal.com/uploads/website_specific/ocportal.com/logos/a.png" title="Powered by ocPortal" /> </a></div>
<br />
{$SET,interlock,_false}
There must be something that requires them to maintain the space that I don't know about, as I said, I have gone in multiple times and deleted them, saved the work and gone back in and they are right back in there.

In previous versions the blocks would interlock but it seems like the Features, Content and Community blocks ".menu_block .standardbox_title_panel" wont interlock without space between but the Site Statistics, Users Online and admin blocks ".standardbox_t_panel" will interlock as without space between like on previous versions.

You can see a screenshot as displayed on my other website showing the left panel display- you can see the gaps between the top 3 blocks and the tight fit for the lower blocks.


Last edit: by friendly


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#68676
Avatar

Community saint

I see what you mean.

I haven't really started looking at my side panels yet, so I haven't really paid attention to those.

If it worked in earlier versions then it looks like a bug may have crept in (I can't see why it would be a deliberate change).

 Sorry I don't have any other ideas.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#68706
Avatar

Community saint

Still searching for the source of the issue...


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#68708
Avatar

I'll take a look when I can, but for now you may wish to disable WYSIWYG. There were some changes to fix issues with block alignment.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#68709
Avatar

Community saint

Chris Graham said

I'll take a look when I can, but for now you may wish to disable WYSIWYG. There were some changes to fix issues with block alignment.
I appreciate it Chris, I know you are swamped with everything else. The site is in development and has a ways to go before its live.

I know my backgrounds worked perfectly with 6.0.3 and I think with 6.1 (could be wrong there) but the new 6.1.1 did not like what I had in there and maybe it was because when upgrading I choose the 'update theme' option?

I did notice that the CSS must have changed for the top 3 titles in the side panel.

Thanks, will be interested in what you know about correcting this when you get a chance.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#68816
Avatar

Right, I think there are 3 things at play here:
  1. We changed how the WYSIWYG editor handles lines-breaks. This is actually to avoid confusion, it is now more representative of what you see. The line-breaks after blocks are implied so we put them in the XHTML in the WYSIWYG so you do actually see each block is given it's own line. It is stripped back out when saving.
  2. We defaulted panel box trays to 'on', and I see that breaks the interlock now. I have attached a fixed template.
  3. Yes other CSS changes probably did get merged in, we did a few to smarten things up.

Attachment
» Download: STANDARDBOX_panel.tpl (3 Kb, 165 downloads so far)


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#68845
Avatar

Community saint

Chris I downloaded the fix and replaced the STANDARDBOX_PANEL.TPL code with the new code, cleared the cache and went to my home page to see the results and …no change showing up that I can see. There is still no interlocking going on even after I went back in and removed the "</ br>" tags

I do notice that at the bottom of the panel in WYSIWYG mode reads:

Code

{$SET,interlock,_false}


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#68862
Avatar

Right, it's hard to say without looking. The interlock stuff in terms of SET,interlock is now only there for IE6, and the other browsers do it via CSS…

Code


/* Precedence (!important) for browsers that support the > and + selectors; precedence stops it relying on .interlock being right */
html>body .standardbox_wrap_panel { /* Runs before the below selector, the best we can to given we don't have multiple levels of important or negation in CSS; it's needed to take precedence over the .interlock selector */
   border-top: 1px solid #8ba4ca !important; /* {$,wizard, 61% seed + 39% W/B} */
   margin-top: 5px !important;
}
{+START,IF,{$NOT,{$MOBILE}}}
   .standardbox_wrap_panel + .standardbox_wrap_panel {
      border-top: 0px !important;
      margin-top: 0 !important;
   }
   /* Otherwise (IE6) will use the following, which depends on Tempcode correctly tracking the template inclusion orders via .interlock */
   .interlock {
      border-top: 0px;
      margin-top: 0;
   }
{+END}

It's rather complex, but more stable. .standardbox_wrap_panel + .standardbox_wrap_panel means "a standard panel box with a standard panel box before it" and you can see how that has a style to remove the border and margin, to make it sit close. IE6 does not support this CSS syntax unfortunately.

It only works if the standard panel boxes have no line breaks between them in the output XHTML, but as you were so careful to remove them, you probably don't have them. Just to be sure I would check in Firebug, see if there are any 'br's actually shown in the final output between the boxes.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#68866
Avatar

Community saint

Chris I am viewing it in FIREFOX/3.6.17 and IE 8.0.6001. I will email you the username/password for this website so you can see it firsthand if you wish.

Also I am including the XHTML code readout from firebug which as you can see includes the line breaks for the top three boxes :

Code

<div class="float_surrounder">
        <div class="menu_block">
    <div class="standardbox_wrap_panel ">
    <div style="height: auto; width: 100%;" class="standardbox_classic standardbox_t_panel" id="Features">

            <h2 class="standardbox_title_panel">

                Features
            </h2>

            <div class="standardbox_main_classic">

    <div class="menu_type__tree">
        <ul class="nl">
            <li class="current has_no_img">

        <a href="http://davidlfriend.com/site/index.php?page=start" title="Home: ">Home</a>

</li>
<li class="non_current has_no_img">

        <a href="http://davidlfriend.com/site/index.php?page=help" accesskey="6" title="Guide: ">Guide</a>

</li>
<li class="non_current has_no_img">

        <a href="http://davidlfriend.com/site/index.php?page=rules" title="Rules: ">Rules</a>

</li>
<li class="non_current has_no_img">

        <a href="http://davidlfriend.com/site/index.php?page=guestbook" title="Guestbook: ">Guestbook</a>

</li>
        </ul>
    </div>

<br>
<div class="edit_menu_link">
    <a title="Edit menu: main_features" href="http://davidlfriend.com/adminzone/index.php?page=admin_menus&amp;type=edit&amp;id=main_features&amp;redirect=http%3A%2F%2Fdavidlfriend.com%2Fsite%2Findex.php%3Fpage%3Dstart%26redirected%3D1&amp;wide=1&amp;clickable_sections=0">Edit menu</a> <a title="Edit menu: main_features" href="http://davidlfriend.com/adminzone/index.php?page=admin_menus&amp;type=edit&amp;id=main_features&amp;redirect=http%3A%2F%2Fdavidlfriend.com%2Fsite%2Findex.php%3Fpage%3Dstart%26redirected%3D1&amp;wide=1&amp;clickable_sections=0"><img src="http://davidlfriend.com/themes/default/images/menus/menu.png" alt="" class="inline_image"></a>
</div>

        </div>
    </div>

</div>

</div>

 <div class="menu_block">
    <div class="standardbox_wrap_panel interlock">
    <div style="height: auto; width: 100%;" class="standardbox_classic standardbox_t_panel" id="Content">

            <h2 class="standardbox_title_panel">

                Content
            </h2>

            <div class="standardbox_main_classic">

    <div class="menu_type__tree">
        <ul class="nl">
            <li class="non_current has_no_img">

        <a href="http://davidlfriend.com/site/index.php?page=catalogues&amp;type=misc" title="Catalogues: ">Catalogues</a>

</li>
<li class="non_current has_no_img">

        <a href="http://davidlfriend.com/site/index.php?page=downloads&amp;type=misc" title="Downloads: ">Downloads</a>

</li>
<li class="non_current has_no_img">

        <a href="http://davidlfriend.com/site/index.php?page=galleries&amp;type=misc" title="Galleries: ">Galleries</a>

</li>

        </ul>
    </div>

<br>
<div class="edit_menu_link">
    <a title="Edit menu: main_content" href="http://davidlfriend.com/adminzone/index.php?page=admin_menus&amp;type=edit&amp;id=main_content&amp;redirect=http%3A%2F%2Fdavidlfriend.com%2Fsite%2Findex.php%3Fpage%3Dstart%26redirected%3D1&amp;wide=1&amp;clickable_sections=0">Edit menu</a> <a title="Edit menu: main_content" href="http://davidlfriend.com/adminzone/index.php?page=admin_menus&amp;type=edit&amp;id=main_content&amp;redirect=http%3A%2F%2Fdavidlfriend.com%2Fsite%2Findex.php%3Fpage%3Dstart%26redirected%3D1&amp;wide=1&amp;clickable_sections=0"><img src="http://davidlfriend.com/themes/default/images/menus/menu.png" alt="" class="inline_image"></a>
</div>

        </div>
    </div>

</div>

</div>

 <div class="menu_block">
    <div class="standardbox_wrap_panel interlock">
    <div style="height: auto; width: 100%;" class="standardbox_classic standardbox_t_panel" id="Community">

            <h2 class="standardbox_title_panel">

                Community
            </h2>

            <div class="standardbox_main_classic">

    <div class="menu_type__tree">
        <ul class="nl">
            <li class="non_current has_no_img">

        <a href="http://davidlfriend.com/site/index.php?page=members&amp;type=misc" title="Members: ">Members</a>

</li>
<li class="non_current has_no_img">

        <a href="http://davidlfriend.com/site/index.php?page=groups&amp;type=misc" title="Usergroups: ">Usergroups</a>

</li>
<li class="non_current has_no_img">


        <a href="http://davidlfriend.com/site/index.php?page=chat&amp;type=misc" title="Chat lobby: ">Chat lobby</a>

</li>
<li class="non_current has_no_img">

        <a href="http://davidlfriend.com/site/index.php?page=pointstore&amp;type=misc" title="Point-store: ">Point-store</a>

</li>

        </ul>
    </div>

<br>
<div class="edit_menu_link">
    <a title="Edit menu: main_community" href="http://davidlfriend.com/adminzone/index.php?page=admin_menus&amp;type=edit&amp;id=main_community&amp;redirect=http%3A%2F%2Fdavidlfriend.com%2Fsite%2Findex.php%3Fpage%3Dstart%26redirected%3D1&amp;wide=1&amp;clickable_sections=0">Edit menu</a> <a title="Edit menu: main_community" href="http://davidlfriend.com/adminzone/index.php?page=admin_menus&amp;type=edit&amp;id=main_community&amp;redirect=http%3A%2F%2Fdavidlfriend.com%2Fsite%2Findex.php%3Fpage%3Dstart%26redirected%3D1&amp;wide=1&amp;clickable_sections=0"><img src="http://davidlfriend.com/themes/default/images/menus/menu.png" alt="" class="inline_image"></a>
</div>

        </div>
    </div>

</div>

</div>

<div class="standardbox_wrap_panel interlock">
    <div style="height: auto; width: 100%;" class="standardbox_classic standardbox_t_panel" id="Site_statistics">

            <h2 class="standardbox_title_panel">

                Site statistics
            </h2>

            <div class="standardbox_main_classic">

<ul class="compact_list">
    <li>
        Community:<br>
        <ul class="compact_list associated_link_to_small">
            <li>Members: 3</li><li>Topics: 2</li><li>Posts: 3</li>
        </ul>
    </li>
</ul>

        </div>
    </div>

</div>

<div class="standardbox_wrap_panel interlock">
    <div style="height: auto; width: 100%;" class="standardbox_classic standardbox_t_panel" id="Users_online">

            <h2 class="standardbox_title_panel">

                Users online
            </h2>


            <div class="standardbox_main_classic">

    <a href="http://davidlfriend.com/site/index.php?page=members&amp;type=view&amp;id=admin" class="ocf_gcol_3">admin</a>,  0 guests

        </div>
    </div>

        <div class="standardbox_t_panel standardbox_links_classic community_block_tagline"> [

                <a href="http://davidlfriend.com/site/index.php?page=onlinemembers">Details</a>

        ] </div>

</div>

<div class="standardbox_wrap_panel interlock">
    <div style="height: auto; width: 100%;" class="standardbox_classic standardbox_t_panel" id="admin">

            <h2 class="standardbox_title_panel">

                admin
            </h2>

            <div class="standardbox_main_classic">

        <div class="community_block_tagline">

    [&nbsp;<a href="http://davidlfriend.com/personalzone/index.php?page=myhome&amp;id=2" title="Account: admin, 76.104.219.185">Account</a>&nbsp;]<br>

[&nbsp;<a href="http://davidlfriend.com/site/index.php?page=members&amp;type=view&amp;id=admin" rel="me">My Profile</a>&nbsp;]
<br>

[&nbsp;<a href="http://davidlfriend.com/site/index.php?page=points&amp;type=member&amp;id=2">My Points</a>&nbsp;]
<br>

[&nbsp;<a href="http://davidlfriend.com/adminzone/index.php?page=start" accesskey="I">Admin Zone</a>&nbsp;]
<br>

[&nbsp;<form action="http://davidlfriend.com/index.php?page=login&amp;type=logout" method="post" class="inline"><input type="submit" value="Logout" class="buttonhyperlink" accesskey="l"></form>&nbsp;]<br>
        </div>

        </div>
    </div>

</div>

<div style="text-align: center;"><a rel="" href="http://ocportal.com/?from=logo" target="_blank" title=" : (this link will open in a new window)" class="link_exempt">

<img alt="Powered by ocPortal" title="Powered by ocPortal" src="http://ocportal.com/uploads/website_specific/ocportal.com/logos/a.png">

 </a></div>
    </div>


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
Posted
Rating:
#68869
Avatar

Re: whispered access…

Ah got it. We styled the menu blocks to not interlock and look a bit different. You didn't merge the CSS so you would not have noticed the positives but would the negatives. Probably should have communicated this one better.

In BLOCK_SIDE_STORED_MENU.tpl remove <div class="menu_block">...</div>.

Btw - gorgeous tree painting.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#68870
Avatar

Community saint

Chris Graham said

Re: whispered access…

Ah got it. We styled the menu blocks to not interlock and look a bit different. You didn't merge the CSS so you would not have noticed the positives but would the negatives. Probably should have communicated this one better.

In BLOCK_SIDE_STORED_MENU.tpl remove <div class="menu_block">...</div>.

Btw - gorgeous tree painting.
Last time I upgraded I did the upgrade theme also but you mentioned I didn't get the merged CSS?

…and Wow, the little change works perfectly! Thanks Chris!

This new website is about my personal artwork. I have been painting, as a hobby, since I was 11. Most of that time I haven't had time to really work on it seriously but since I've have been unemployed from the architectural industry for more than a year now I have had more time to work up new paintings.

That 'Red Tree' you saw was done about 3 months ago.

Thanks again for the fix.


Art and Imagination
of David L Friend

http://davidlfriend.com

  My Art Gallery
powered by ocPortal
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: