HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Redirect Loop

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#104934 (In Topic #20469)
Avatar

Fan in training

Redirect Loop error after installing ocPortal

I installed ocPortal for the first time today and upon completion of the installation I was given two options; to configure the site or go to the site. I chose to configure the site and then was presented with a redirect loops error in chrome. I also tried opening in Firefox to the same demise. Has anyone experienced this? Any tips?


The webpage at http://www.plastikreality.com/adminzone/index.php has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
 
Learn more about this problem.
Error code: ERR_TOO_MANY_REDIRECTS
Back to the top
 
Posted
Item has a rating of 5 (Liked by thepryme)  
Rating:
#104937
Avatar

Community saint

I think it would be more likely that there is a problem with the domain level .htaccess file.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#104938
Avatar

Fan in training

I don't believe I have a domain level .htaccess. Also this is something particular to the way ocPortal works as I've hosted many other CMS on the same hosting with out issue. 
Back to the top
 
Posted
Item has a rating of 5 (Liked by thepryme)  
Rating:
#104939
Avatar

You gave ocPortal a base URL which your server redirects from. Either you gave it 'www.' and it redirects to without it, or the opposite. If it's not an .htaccess file doing it, something else in the server configuration is.

Other CMS software may not enforce the correct base URL, but ocPortal does this for SEO reasons.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#104940
Avatar

Fan in training

Great, thanks for this response. I'm using dreamhost and they have an option to "add www." to the domain which I initially had set but just removed that. That doesn't appear to have corrected the problem. Is there a specific config file in ocPortal that I should look to change what it's set to?
Back to the top
 
Posted
Item has a rating of 5 (Liked by thepryme)  
Rating:
#104941
Avatar

Community saint

It now works for me, so its probably just a caching issue.

Try it in a Chrome incognito window. That should bypass the cache.

Do you have a Samsung Galaxy S / Galaxy S II ? If so, why not check out my ScreenFree FM Radio .
Back to the top
 
Posted
Rating:
#104942
Avatar

Fan in training

Awesome, thanks so much. It must've been that setting in dreamhost funking things up! 
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: