HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


problems with saving configurations

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#60513 (In Topic #13139)

Honoured member

Hi,
In adminzone / setup /configuration when I attempt to make any changes either to block oprtions or feature options and then try to save it I am getting an error 406:

Code

Not Acceptable
An appropriate representation of the requested resource /adminzone/index.php could
not be found on this server.
I don't appear to missing any files, when I check with upgrader.php and there doesn't seem to be any permission problems either. Can you tell me what else to check or how to fix this?

Just now notice that I'm also receiving an error 501 when try to save changes to adminzone / setup / configuration / site options as well.


Last edit: by chipster
Back to the top
 
Posted
Rating:
#60529
Avatar

It sounds like Suhosin or mod_security. Our recommended.htaccess (if renamed to .htaccess) file may solve it.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#60535

Honoured member

Oh no, it didn't like that at all.  When I renamed it and then try to access the site I got a 500 error.
If it helps at all, when I first try to install ocp on my server I received a message the exec had been disabled in my php.ini file and that ocportal may not function correctly, so I created a php.ini file and dumped in my home directory that looks like:

Code

disable_functions = symlink,shell_exec,proc_close,proc_open,popen,passthru,escapeshellarg,escapeshellcmd,ini_alter

and the error went away.  I really don't understand what is going on at all.  I have two different installs of ocp. the first has been up for months and worked perfectly, but even it now gives me the same error message when I try to execute certain functions.  
I just looked and don't see and kind of error file that I can look at. Would it help if I posted the contents my phpinfo.php?
Back to the top
 
Posted
Rating:
#60539
Avatar

Hi,

It'd probably be swiftest if you file a free bug report ticket with us, with server access details, and I'll take a look for you.

Chris


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#60551

Honoured member

Hi Chris,
Thanks. Seems like the techs where all my sites are hosted had made several changes to the php installation, which messed with more sites than just mine.  Seems they've had a change of heart and re-instituted the old php.ini files and all seems well now.
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: