HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Problem Saving any settings

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#58657 (In Topic #12793)
Avatar

Community saint

Hi guys,

I did a fresh install of 4.3.1 on a new site and all seemed ok until last night. Any time I try to change any settings just about anywhere in the site I get:

Expand: Click Here Click Here

I am also getting strange stuff in some URL's, for instance when I try to edit the zone menu I get this:

Expand: Click Here Click Here

I do get to the menu editor but when I make changes and click save I get the 404 error above and the URL is:

Expand: Click Here Click Here

I entered my site info in my profile if one of the admins wanted to look at it.

Rick Henson

OCP 4.3.2 & 5.0.1
PHP 5.2.5
MySQL 5.0.51a
FireFox 3.6.8
Back to the top
 
Posted
Rating:
#58659
Avatar

Community saint

You can remove this topic if you want. I had just installed this and had done little modifications so am just reinstalling. Will let you know if I continue to have problems.

Rick Henson

OCP 4.3.2 & 5.0.1
PHP 5.2.5
MySQL 5.0.51a
FireFox 3.6.8
Back to the top
 
Posted
Rating:
#58671
Avatar

Hi,

This is very likely to be caused by Suhosin, which our (recommended).htaccess should work around.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#58685
Avatar

Community saint

Thanks for the response Chris, my problem is that with PHP 5 .htaccess files are very problomatic. If I use the recommended.htaccess file my site is inoperative with the following error:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.Please contact the server administrator, webmaster@successmentors.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.


Apache/1.3.42 Server at www.successmentors.com Port 80


I have reloaded the system and the problem that I am having now is that I cannot increase the upload file limits, again because of the .htaccess issues with PHP5. I have a stripped down PHP.ini file that you can see below:

Code

[PHP]<br />;;;;;;;;;;;;;;;;;;;<br />; About this file ;<br />;;;;;;;;;;;;;;;;;;;<br />; This file controls many aspects of PHP's behavior. In order for PHP to<br />; read it, it must be named 'php.ini'. PHP looks for it in the current<br />; working directory, in the path designated by the environment variable<br />; PHPRC, and in the path that was defined in compile time (in that order).<br />; Under Windows, the compile-time path is the Windows directory. The<br />; path in which the php.ini file is looked for can be overriden using<br />; the -c argument in command line mode.<br />;<br />; The syntax of the file is extremely simple. Whitespace and Lines<br />; beginning with a semicolon are silently ignored (as you probably guessed).<br />; Section headers (e.g. [Foo]) are also silently ignored, even though<br />; they might mean something in the future.<br />;<br />; Directives are specified using the following syntax:<br />; directive = value<br />; Directive names are *case sensitive* - foo=bar is different from FOO=bar.<br />;<br />; The value can be a string, a number, a PHP constant (e.g. E_ALL or M_PI), &#111;ne<br />; of the INI constants (On, Off, True, False, Yes, No and None) or an expression<br />; (e.g. E_ALL &amp; ~E_NOTICE), or a quoted string (&quot;foo&quot;).<br />;<br />; Expressions in the INI file are limited to bitwise operators and parentheses:<br />; | bitwise OR<br />; &amp; bitwise AND<br />; ~ bitwise NOT<br />; ! boolean NOT<br />;<br />; Boolean flags can be turned &#111;n using the values 1, &#111;n, True or Yes.<br />; They can be turned off using the values 0, Off, False or No.<br />;<br />; An empty string can be denoted by simply not writing anything after the equal<br />; sign, or by using the None keyword:<br />;<br />; foo = ; sets foo to an empty string<br />; foo = none ; sets foo to an empty string<br />; foo = &quot;none&quot; ; sets foo to the string 'none'<br />;<br />; If you use constants in your value, and these constants belong to a dynamically<br />; loaded extension (either a PHP extension or a Zend extension), you may &#111;nly<br />; use these constants *after* the line that loads the extension.<br />;<br />; All the values in the php.ini-dist file correspond to the builtin<br />; defaults (that is, if no php.ini is used, or if you delete these lines,<br />; the builtin defaults will be identical).<br /><br />; ocPortal needs uploads; many hosts leave these low<br />post_max_size=&quot;200M&quot;<br />upload_max_filesize=&quot;200M&quot;<br /><br />; Turn insecure things off<br />allow_url_fopen=&quot;off&quot;<br />register_globals=&quot;off&quot;<br /><br />; Put some limits up. ocPortal is stable enough not to cause problems- it'll &#111;nly use higher limits when it really needs them<br />memory_limit=&quot;-1&quot;<br />max_input_time=&quot;60&quot;<br /><br />; This unavoidably kills filedump folder creation, and stops us controlling our script execution time<br />safe_mode=&quot;off&quot;<br /><br />; Sandbox ocPortal to it's own directory<br />; open_basedir=&quot;/tmp:/home/blah/public_html/ocportal/&quot; Customise this line for your server, or leave it commented out


I have added this to just about every conceivable location but so far to no avail. When added to the adminzone it does then show the increased upload size in the settings but I am still limited to 2m total or I get the File Rejected error. I have included the PHP.ini in the following locations:
Root
adminzone
cms
forum
personalzone
site
uploads
uploads > downloads
uploads > incoming

If you have any other thoughts about the PHP.ini file or its required location I would sure love to here them.

As always thanks for all that you do for us!!!

Rick Henson

OCP 4.3.2 & 5.0.1
PHP 5.2.5
MySQL 5.0.51a
FireFox 3.6.8
Back to the top
 
Posted
Rating:
#58689
Avatar

Hi,

If you take a look in our FAQ you'll find an example php.ini…

ocPortal.com - ocPortal/ocProducts FAQ

(under How do I set PHP settings on a CGI server?)


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#58690
Avatar

Community saint

Ya I tried using that verbatim and my site crashes again, that is why I ended up using the one that I posted above. With the one above it does alter the limits to the 200m that I have entered in the admin area and it does not crash my site.

The problem is that I can't seem to find the location to actually allow the uploads of that size. As stated above I have put that php.ini in all of the places listed in your FAQ plus a few others:
Root
adminzone
cms
forum
personalzone
site
uploads
uploads > downloads
uploads > incoming

Admin says I can upload 200meg but when I go to the upload page the limit is still 2m.

I guess my only other option is to start looking for another host that has not upgraded to PHP 5 yet but the problem with that is eventually all hosts will upgrade at which time this script won't work any more.

Thanks for trying,

Rick Henson

OCP 4.3.2 & 5.0.1
PHP 5.2.5
MySQL 5.0.51a
FireFox 3.6.8
Back to the top
 
Posted
Rating:
#58691
Avatar

Community saint

Damn, after using that php file my site is back to not saving any settings as stated in the first post. I have gone back and removed those files and cleared the caches like last night but to no avail. I guess I try one more reload...

Rick Henson

OCP 4.3.2 & 5.0.1
PHP 5.2.5
MySQL 5.0.51a
FireFox 3.6.8
Back to the top
 
Posted
Rating:
#58692
Avatar

Hi,

I don't mind taking a look to see if I can solve it - if you want to submit a free ticket with ftp details.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#58695
Avatar

Community saint

Hey Chris,

Sorry for sounding frustrated but I am. I have submitted a ticket. Please feel free to post the problem here for all to profit from, I don't mind the embarrassment, I am sure it is something stupid that I am doing but I am about to pull out what little hair I have left.

As always thanks…

Rick Henson

OCP 4.3.2 & 5.0.1
PHP 5.2.5
MySQL 5.0.51a
FireFox 3.6.8
Back to the top
 
Posted
Rating:
#58701
Avatar

Sometimes it feels like developing for PHP is like being an architect who builds houses on foundations of jelly  :lol: (that's "jello" for Americans…)

I have resolved the problem, which was two-fold.
  1. The php.ini was needed in the data directory. I checked our FAQ and it did not say this, so that's our fault and I've amended it. It wasn't the case prior to 4.2, but now we have the nice flash uploader, almost all uploads get piped through there.
  2. I had to put the .htaccess back, as the '406' errors were being caused by ModSecurity, which our plain.htaccess file works around (recommended.htaccess would also, but on your kind of server [PHP as CGI], causes '500' errors… Jello ;)).

It wasn't actually Suhosin causing the problems, it was ModSecurity, and presumably also your servers low default PHP settings.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#58702
Avatar

Community saint

Thanks Chris, you guys are the best, don't let anyone tell you different. I was beginning to think I was going crazy.

Rick Henson

OCP 4.3.2 & 5.0.1
PHP 5.2.5
MySQL 5.0.51a
FireFox 3.6.8
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: