HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Problem downloading an exported addon in Internet Explorer

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#107770 (In Topic #21004)
Avatar

Community saint

<edit>
Important! If you downloaded and installed the YouTube Channel Integration addon from the links that were available here, you should delete the .tar file, uninstall the addon, and install it again through Adminzone>Structure>Addons>Import non-bundled addon(s) by downloading it from the ocPortal addon repository. 
</edit>

Hey Chris,

Just thought I'd mention this other oddity in the addon export process. I noticed this problem after exporting an addon in ocPortal, but I don't think it's a bug with ocPortal. It seems like something odd happening with downloaded .tar files in Internet Explorer (it works fine in Chrome). After exporting the addon and ocPortal goes back to the Addons screen with a message and link at the top of the page that states:

Your addon has been created. You may download it


On the web server, the file is correct. It is named YouTube_Channel_Integration_Block-12052015-1405.tar and is 65024 bytes in size and an uncompressed tarball of the addon files. If I click the 'download it' link using Internet Explorer, it gives me a gzipped archive of the tar file and is 12,150 bytes in size:

<edit>removed attachment since it links to outdated file</edit>

You can extract this archive and add a .tar extension to the extracted file to get the original file as it is on the web server. In other words, Internet Explorer is taking the uncompressed tarball, stripping the extension off, and adding it to a gzipped archive with the same name as the original tarball.

If I download the same link in Chrome, I get the correct tar file (note...I added an underscore to the end of the file name manually after downloading):

<edit>removed attachment since it links to outdated file</edit>

I'm not sure what is happening with the download in Internet Explorer and a quick Google search didn't reveal much (I'll keep looking, though) so I'm not sure if this is something that can be detected and worked around in ocPortal. I don't think I have any browser toolbars, extensions, or addons that would cause this; I'll have to take a closer look. If nobody else is experiencing this oddity, I'll assume there is some setting or some extension installed in my Internet Explorer v11 that is affecting the download.


Last edit: by Jason Verhagen
Back to the top
 
Posted
Item has a rating of 5 (Liked by Jason VerhagenLiked by KingBast)  
Rating:
#107789
Avatar

http://blogs.msdn.com/b/wndp/archive/2006/08/21/content-encoding-not-equal-content-type.aspx

It's hard to follow, but essentially I think it is this…

  1. Your Apache is set to gzip stuff
  2. IE thinks that a tar file specified with a gzip transfer encoding is actually a server bug (specification of file type rather than of actual transfer encoding), so it leaves the transfer stream gzipped

Try this in .htaccess:

Code

<IfModule mod_setenvif.c>
SetEnvIfNoCase Request_URI \.tar$ no-gzip dont-vary
</IfModule>

I will add to Composr so that this is standardised while it goes through beta testing.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#107791
Avatar

Community saint

Thanks! Once again, spot on. Disabling gzip for .tar files in .htaccess lets the .tar files download normally in Internet Explorer.
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: