HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Points work for me, but not for other users

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#31315 (In Topic #7154)
Avatar

Well-settled

Yet another issue.  I was not going to use the points store on my site, but as users started using the site, I realized that by turning off points completly they would never get past the newbie stage.  I turned the points system back on and disabled all the point store options.  The problem is that I seem to be accruing points, but no one else is.  Any ideas?

Thanks,
Adam


ModelerX.com - Post your models in the gallery and chat about 'em in the forums.  Building the largest online community of modelers with your help.

Back to the top
 
Posted
Rating:
#31322
Avatar

The best way to debug this is to look at the points profile of a member who "isn't accruing points". It'll give a breakdown of how their point tally is calculated, and then you can investigate deeper if you think the calculation is wrong.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#31323
Avatar

Well-settled

For instance, one user has this breakdown:
Posts: 28 x 5
Points given: 200 x 1
Voting: 2 x 15
Ratings: 0 x 5
Visiting: 100 per daily-visit
Joining: 40 + 27 x 25

It says that he has these points:
Points used: 0
Points left: 0
Points given: 0
Gift points left: 52




ModelerX.com - Post your models in the gallery and chat about 'em in the forums.  Building the largest online community of modelers with your help.

Back to the top
 
Posted
Rating:
#31326
Avatar

The member is in a usergroup where they don't have permission to use points. This is confusing - we'll clear it up.

In the meantime, please check your specific permissions :).


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#31328
Avatar

Well-settled

So the Newbie usergroup can't obtain points by default?


ModelerX.com - Post your models in the gallery and chat about 'em in the forums.  Building the largest online community of modelers with your help.

Back to the top
 
Posted
Rating:
#31329
Avatar

Point permission is on by default, but perhaps it's something you disabled when you disabled points? Regardless, it wouldn't hurt to check.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#31331
Avatar

Well-settled

k… I'm having a little trouble finding where to check.  I looked in the group settings, the point settings, and a few other places.  Sorry, but could you point me in the direction of where I need to look.

Thanks.


ModelerX.com - Post your models in the gallery and chat about 'em in the forums.  Building the largest online community of modelers with your help.

Back to the top
 
Posted
Rating:
#31333
Avatar

I suppose this could be an upgrade problem actually. We added the permission at some point in an upgrade, so perhaps it didn't go through right.

Please try putting this into OcCLE:

Code

:require_code('database_action'); add_specific_permission('POINTS','use_points',true);

Does that make things work right in the points profiles?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#31336
Avatar

Well-settled

After hitting go... it looks like it just sits there.


ModelerX.com - Post your models in the gallery and chat about 'em in the forums.  Building the largest online community of modelers with your help.

Back to the top
 
Posted
Rating:
#31339
Avatar

The answer to your question which I didn't answer directly - It should just be under the 'Points' specific-permission section.
http://baseurl/adminzone/index.php?page=admin_permissions&type=specific&id=points
Looking back at what you said, I think it may be you were looking at the wrong place, because there is no 'Group settings' section of specific-permissions.


If you still can't find it, we can continue under the possibility the specific permission is missing…

If you have a popup blocker, there might have been an OcCLE error message that the popup blocker stopped appearing. The other way to run an ocPortal command(s) is by editing data_custom/execute_temp.php, changing:

Code

function execute_temp()
{

}
to:

Code

function execute_temp()
{
   add_specific_permission('POINTS','use_points',true);
}

That execute_temp.php file is just a place to put temporary code you want to run just once.
Load it up by URL when you're done editing, and it'll run.

I think the error OcCLE gave could well have basically been the equivalent of ocPortal saying "this specific permission already exists", but you'll know for sure after running execute_temp.php.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#31343
Avatar

Well-settled

That's what it was.  I remember changing that setting now because I was not going to use the points store.  Sorry for the trouble, but thanks for pointing me in the right direction.


ModelerX.com - Post your models in the gallery and chat about 'em in the forums.  Building the largest online community of modelers with your help.

Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: