HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


ocUpgrader: "fwrite(): supplied argument is not a valid stream resource"

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#48934 (In Topic #10674)
Avatar

Fan in training

Hi,

I installed ocPortal a few days ago, and in the admin zone I found that 4.1.6 is available. I started the upgrader but cannot get past the step to deploy the tar file. After inserting the tar URL and clicking Proceed, I get this error page:


Expand: ocPortal upgrader error message ocPortal upgrader error message




In my Web hoster's admin pages I found this message in the error log file:


Expand: Web hoster's error log file message Web hoster's error log file message




As I am not a professional Web developer, these messages do not help me much. Apparently it would make no sense to increase the maximum value for memory_limit to about 4GB (even if I knew how to do this).

Is there any obvious reason for these errors, or how do I troubleshoot this further?

Thanks and regards,
Christoph
Back to the top
 
Posted
Rating:
#48938
Avatar

Hi,

Does that upgrade error happen each time you try?
It looks like it might be a one-off, if the server's temp directory got cleaned up whilst the file was being downloaded.

If you haven't removed any addons you can manually download the upgrade tar and extract it to the server.

The memory error is due to an altered version of PHP called 'Suhosin'. ocPortal tries to turn off the memory limit, but Suhosin misreports that as it trying to put the memory limit as 4GB.
I think though you can ignore this, as it probably is just be logging it rather than blocking ocPortal.
The next patch release will try and detect Suhosin's memory limit and if there is one try and set it to that rather than disabling.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#48948
Avatar

Fan in training

Hi Chris,

Thanks for your reply.

The issue happens each time I try. Indeed it seems that my Web host uses Suhosin as they mention this in some of their help files.

I will follow your advice and try ignoring this error message or else extracting the tar manually to the server.

Thanks,
Christoph
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: