HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Missing comconde thing again

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#27256 (In Topic #6281)
Avatar

Well-settled

A language entry is missing: MISSING_RESOURCE_COMCODE (ocPortal version: 3.0.11, PHP version: 4.4.4, URL: /site/pg/userguide_comcode) I'm sure we tackled this before and there may even have been a bug fix but meant updating something I'd customised or something like that.

In essence once every now and then I'm getting this error - I presume from SE robots because as far as I can tell there is no link to a comcode user guide on the site, I removed the link due to the volume of references to OC portal in it.

So how is Google or whoever finding this dead link? Any ideas?



D.

Back to the top
 
Posted
Rating:
#27258
Avatar

It's linked to next to form fields that support it. The error is probably happening due to the new lang/EN/critical_error.ini being omitted during an upgrade.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#27261
Avatar

Well-settled

"It's linked to next to form fields that support it."

Could you explain that again please?



D
Back to the top
 
Posted
Rating:
#27265
Avatar

In a form, if a field supports Comcode, there will normally be a little "c" next to it, which will link to the Comcode help page.

Back to the top
 
Posted
Rating:
#27266
Avatar

Well-settled

So there's no real escaping the thing then..

Mmm.


Thanks


D
Back to the top
 
Posted
Rating:
#27267
Avatar

If you really want to remove all links to the page, you could edit all FORM_* templates which contain the link, to remove it. I wouldn't advise this, however, as it would mean that people would not have any Comcode reference to fall back on if they don't know Comcode.

Back to the top
 
Posted
Rating:
#27949
Avatar

Well-settled

OK, have left it for quite some time and ignored the "An error has occured" emails while waiting for a significant improvement to the script to make an update worthwhile.

Well we're now on 3.17, which should be a major step forward from my current 3.11.

So tried downloading 3.17, failed, tried 3.16 and got:

Fatal error: Class 'Hook_attachments_news' not found in /home/ocp/public_html/sources/global.php(234) : eval()'d code on line 1

Let's try 3.15…

Fatal error: Class 'Hook_attachments_news' not found in /home/ocp/public_html/sources/global.php(234) : eval()'d code on line 1


I don't think I need say much, as you can probably guess how I feel and what my intentions now are. And I never did see any sign of the commercial non-branded version

Thanks anyway, I appreciate all the work and effort that's gone into OCP.


D.
Back to the top
 
Posted
Rating:
#27958
Avatar

We're really sorry about this bug, and that it's gone unnoticed for two patch releases. Unfortunately this is the first we've heard of it so only now can we patch it:
ocPortal - Entry: Attachment permission bug

It's only been about 3 months since you started posting feedback, so I don't think it's fair to expect a major new version in this time – it would be 3 years between major software versions for many companies. We have to base our decisions on practicalities, so we implemented the most requested features in 3.1, and only features that we could safely do without potentially introducing a lot of bugs across the system (which disparate changes like the ones you requested would inevitably do). We do the major 'risky' work in one go for major releases because they get fully tested – and such testing takes months in itself.

ocPortal is open source so there's no dependency on ocProducts whatsoever – any competent programmer could make changes for the cost of the work.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: