HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Memory Problem

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#35696 (In Topic #8048)

Non-joined user

Memory problem

Hi Guys,

I've just installed ocportal to trial it before purchase. I'm getting the following error & need some advice on how to fix it:

Fatal Error: allowed memory size of 8388608 bytes exhausted (tried to allocate 87052 bytes) in var/www/html/cms/sources/symbols.php on line 1431

Thanks Phil.



Back to the top
 
Posted
Rating:
#35700
Avatar

ocPortal's minimum requirements state a PHP memory requirement of at least 12MB. Please try renaming the included recommended.htaccess file to .htaccess - the file will try and raise the limit.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#35704
Joe
Avatar

Honoured member

If you get an Internal Server Error, the only other option is to ask your webhost to kindly increase the limit, if possible.

Most hosts probably wouldn't do this, but it's worth a shot! :)

Back to the top
 
Posted
Rating:
#35716

Non-joined user

Thanks for the advice guys,

I'll try your suggestions now.

Back to the top
 
Posted
Rating:
#35771

Non-joined user

Just to let you know how I got on:

Renaming file to .htaccess didn't work but I contacted the hosting company & they have increased php memory to 16MB.

Thanks Guys.

Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: