HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


mail not being sent

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#24130 (In Topic #5772)
Avatar

Community saint

I just tested the registration system on my site and found that verification emails are not being sent out. Even though at the end of registration a message appears stating that a verification email has been sent.

It never arrived.

I also tried emailing a member with the same results: onscreen confirmation of message sent but message never received.

Even stranger is the fact that this worked on a previous install.

Any ideas Chris:)

Back to the top
 
Posted
Rating:
#24141
Avatar

Make sure the e-mail/SMTP settings in this installation are the same as those of the previous installation. :)

Back to the top
 
Posted
Rating:
#24144
Avatar

Community saint

 :| I'm not using smtp…I can't remember what the previous installations settings were :(

I'll check the config file.
Back to the top
 
Posted
Rating:
#24152
Avatar

Community saint

 O_o I've tried smtp and still no joy.
Doesn't ocportal use phpmail by default?
I think I'll sleep on it and try again in the morning.
Back to the top
 
Posted
Rating:
#24153
Avatar

Yes, if you don't check the SMTP checkbox, ocPortal will try to use PHP's mail function.

Back to the top
 
Posted
Rating:
#24162
Avatar

Community saint

Hi Phil,
SMTP disabled and still no joy - I think I will re-install as I am still at the testing phase.
That should keep m ebusy tomorrow morning. ;)
Back to the top
 
Posted
Rating:
#24192
Avatar

I'd advise looking at the mail server's logs but possibly you don't have access to them if it's not your own server. If there is no error message displayed, from ocPortal's point of view, the message was sent (it reached the server's mail own queue).


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#24212
Avatar

Community saint

Thanks Chris, I'll get onto my hosting company.
Back to the top
 
Posted
Rating:
#24217
Avatar

Well-settled

Quick question on a similar subject, where do I change the email thingy for CC stuff, as I keep getting a response from my host that such a mail couldn't be sent.

Am recieving some emails OK but it's trying to send via CC_admin or something, at my SUB domain and I cannot create a sub-domain email account. I can have as many email accounts as I want, but not for sub.domain.com

??
Back to the top
 
Posted
Rating:
#24222
Avatar

Community saint

Hi dateofBirth,
You can change your email address here:
adminzone/configuration/site options:
the cc address is under Logging near the bottom. ;)
Back to the top
 
Posted
Rating:
#24223
Avatar

Well-settled

Aha, under setup.. thanks.  :$

D
Back to the top
 
There are too many online users to list.
Control functions:

Quick reply   Contract

Your name:
Your message: