HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Login Problems

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#71839 (In Topic #15099)
Avatar

Community saint

Since upgrade to 7.1.1 some members denied access

Hi everyone,

I just finished the upgrade to 7.1.1, and two members (so far) have complained that once they log in, when they try to access the forum, they receive the following message.

Your login as “username” must be confirmed before you may enter this high-security area (you do not currently have a confirmed session).

I have checked general settings, permissions, and banned IPs but can't seem to find the problem.

Any ideas will be greatly appreciated.

Thanks,
doc
Back to the top
 
Posted
Rating:
#71841
Avatar

Community saint

My 'login' woes continue apace. I will document everything carefully when I've settled my holiday visitors and can spend some time at the 'puter.

At the moment it is very frustrating, and it has only started occurring since upgrading to 7.1.1. Double-checking my settings ought not to be necessary, especially if I've not changed anything - other than to upgrade!

Yes, I have three different sites, all running off the same domain. But if that is seen as a problem now, why wasn't it a problem previously?

And if it has suddenly become a problem because of something 'new' introduced via 7.1.1, then can we be told this prior to upgrade so that we have a chance NOT to upgrade?

Thanks for reading.

bummer

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#71842
Avatar

Community saint

Sorry you are having troubles, Fletch.  :(

I noticed that a file called FLAGRANT_DEFAULT_TEXT.tpl is also missing in the themes/default/templates. I just uploaded it from a previous backup and everything seems to work. It affects some of the adminzone. :)
Back to the top
 
Posted
Rating:
#71854
Avatar

Community saint

Terry,

I am not sure if this will help any, but I found that somehow "Require session" had been unchecked when I upgraded. By checking that, it seemed to fix the problem. I tested it several times and that fixed the issue.

Back to the top
 
Posted
Rating:
#71857
Avatar

Community saint

I am not sure if I should edit this as "Resolved" cause I am not 100% certain that is what fixed the problem. It is the only thing that I could find that was changed, and when I ticked the box, the problem went away.  ;)
Back to the top
 
Posted
Rating:
#71879
Avatar

Community saint

psydoc said

… but I found that somehow "Require session" had been unchecked when I upgraded.

Say where …?

 O_o

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#71880
Avatar

Community saint

Terry, I thought you were a mind reader…uh, er…wait, no, I've got it…I wanted you to guess…no, that's no better.  :$  sorry, I forgot to post that little bit.

Right here…

Back to the top
 
Posted
Rating:
#71883
Avatar

Community saint

psydoc said

sorry, I forgot to post that little bit.

I shall test it - of course.

But I can't see that that would be the solution. My reasoning:
  • can't think of the forums as being a zone with 'sensitive powers'
  • would want a forum to be visible to all visitors (guests)
  • the two above negate the reason to 'force' them to login

If, for some obscure reason ticking this option makes the login problem go away, I shall get back to this thread and say so!


Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#71884
Avatar

Community saint

I don't know why it worked for me, but when unchecked, everyone in the usergroup "local hero" could not view the forum and received the error message posted above. I looked at that usergroup's permissions, and they all seemed correct. I just stumbled over the fact that "Require session" was not ticked while working on the current theme.

I don't care how obscure the reason, it works.

An interesting note: They could log in on the start page, but when they tried to enter the forum, they received another login screen. When they attempted the login, they received the error message.  O_o

I hope it helps, Fletch. :)
Back to the top
 
Posted
Rating:
#71886
Avatar

Community saint

psydoc said

I hope it helps, Fletch. :)
Nope, it didn't. But it was worth a try.

Checking that option was, as I thought, a complete block to my site, so only the 'sensitive' ones are now checked.

There are other things I am investigating at the moment. Although most of my woes appear to be connected to IE9, this may well be a bit of a red herring. I've noticed similar things happening in FF, Chrome and Opera.

Once again, looking for common denominators (other than me, the dumb@ss user), I find it is a combination of ocPortal, my web hosts and my ISP.

I am attacking the problem from a different angle now; starting with the third of those listed above.

Will keep this thread updated …!

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#71890
Avatar

Community saint

After reading your post, I thought it might not work.  :(  

I think the only reason it may have worked for me is that everyone except guest must login to view most of the site. I also have different permission even with logged-in members.

Sorry I was not of any help. I look forward to reading your updates.

 :thumbs:
Back to the top
 
Posted
Rating:
#71901
Avatar

Hi guys,

I don't believe we've made any core changes that could affect this. I have just reviewed the revisions on the files that handle login, and there's nothing relevant there.

There have been big problems with the Facebook Connect addon. If you've been using that, try logging out of Facebook and clearing cookies for your site. If that fixes it, you can reimport the latest version of the addon which has fixes.

Generally checking what cookies you have helps. I have recorded a screencast to show how to do this and how it generally ties into the database:
2011-07-18_1205 - ocProducts's library

It you have conflicting cookies (possibly Fletch's situation), you will find the session IDs not matching up to anything in the sessions table (but they will match to a session ID in a different database), or possibly them being in there but tied to Guest (this is what happens when the server reads the session, and says "ok, I don't recognise this, but I'll save it as a Guest session for you").


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#71918
Avatar

Community saint

Thanks for investigating, Chris.

My problems appear to be coalescing into a combination of my ISP and IE9.

The first has admitted - at last - that there is a 'problem' in 'my area', whatever the hell that means. The second continues to throw its toys out of the pram. The latest hissy-fit that IE has thrown my way is its refusal to run Adobe Flash Player, demanding I install the latest version, which I already have! Uninstalling and reinstalling using Adobe's tools hasn't made a difference - yet!

I've ripped IE9 apart, uninstalled, reinstalled, reset, cleared ALL cookies, diabled all BHO's, accelerators and add-ons, and anything else I could think of. Having said that, it will probably take a while for the browser to settle down now, so I think I will give it a bit more time.

I am encouraged with the cookie retention in FF, Chrome and Opera, so hopefully I can now cautiously eliminate my ocPortal configuration - I think!

(Will report back when 'fings have been sorted - just in case somebody else does a search on the subject and is looking for a solution.)

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#71961
Avatar

Community saint

(My apologies to psydoc for hijacking his thread, but I thought it best to allow the thread to continue under its original title so that a search would throw up all the items that appear in it.)

Still having problems with logging-in, inasmuchas I am required to login each time I open the site(s) - in any browser. This is the setup:
  • shared hosting
  • single domain
  • multiple sites under subfolders
  • each 'site' has its own database

The following are my settings for each of the sites:
main website [AIP]

domain : www.[mydomain].com
cookie_domain : .www.[mydomain].com
base_url : http://[mydomain].com/anglo
cookie_path : /anglo
pass_cookie : aip_member_hash
user_cookie : aip_member_id

=========================


a.n.other website [CTR]

domain : www.[mydomain].com
cookie_domain : .www.[mydomain].com
base_url : http://[mydomain].com/ctr
cookie_path : /ctr
pass_cookie : ctr_member_hash
user_cookie : ctr_member_id

=========================


test website [TTS]

domain : [mydomain].com
cookie_domain : .[mydomain].com
base_url : http://[mydomain].com/test
cookie_path : /test
pass_cookie : tts_member_hash
user_cookie : tts_member_id

I have now become totally frustrated with the whole situation. I do NOT wish to have to keep logging in each time I fire up my own sites. The malaise has spread to all browsers, so I have to assume it is the configuration that is at fault.

Can anybody spot an error in the setup for each of the sites, or offer advice for an alternative or how to rectify the current situation?

 :o

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#71962
Avatar

Do the *_member_hash/*_member_id cookies show up in the browsers cookie list? Chrome is easiest to check this in (as per my video).
If so, does telling chrome to delete the ocp_session cookie, and then refreshing, log you in? (it might force you to confirm your login though).


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: