HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Localhost wont connect!

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#49412 (In Topic #10773)
Avatar

Fan in training

Hi Im totally new here. Im using my laptop as a server while I learn how to use ocportal.

So far Ive only installed the programme and then played around with it for a few hours. I turned my laptop on today with the intention of further exploring ocp, however now I cannot start it.

Shouldnt I be able to find it through localhost? Wampserver is up and running but localhost will not open.

What am I doing wrong?

Any advice would be greatly apprecited.
Back to the top
 
Posted
Rating:
#49433
Avatar

Community saint

Any specific and/or particular error message? Have you tried replacing localhost with:

  1. 127.0.0.1
  2. IP address of the laptop

?

"no violence, no hate, no pain, no enemies
just peace, unity, tolerance and love" - The Beloved

OCP V7 | Advocating monetary reform - FreeOurMoney

Need OCP friendly hosting? Look no further:
Web Hosting, Reseller Hosting, and Dedicated Servers w/cPanel - Elief! - Official hosting partner for ocPortal.
Back to the top
 
Posted
Rating:
#49458
Avatar

Fan in training

the ip address 127.0.0.1 brings up the local host page and under "your projects" is "ocp4" however when I open it, it shows what appears to be the website I made, which is only a couple of broken links.

How do I get ocportal to open?
Back to the top
 
Posted
Rating:
#49472
Avatar

Community saint

Couple of things to verify as computers can be sneaky lol:

  1. MySQL is running (wouldn't hurt to restart)
  2. Apache is running (wouldn't hurt to restart)

Try accessing the site directly:

http://127.0.0.1/ocp4
(assuming "ocp4" is the directory where ocPortal lives).

Just a quick web server (Apache) 101: Apache will have a directory configured to be it's "document root"; that is, a directory where Apache starts looking for sites when someone enters "http://address.or.hostname.com". Generally speaking, any pages/sites that you are trying to access like thus: "http://address.or.hostname.com/SITE" will be a (sub)directory under the document root. From a troubleshooting perspective then, determine what the document root is for your WAMP Apache install and OCP should be a subdirectory under that, something like:

c:\apache\www_root\ocp4

"no violence, no hate, no pain, no enemies
just peace, unity, tolerance and love" - The Beloved

OCP V7 | Advocating monetary reform - FreeOurMoney

Need OCP friendly hosting? Look no further:
Web Hosting, Reseller Hosting, and Dedicated Servers w/cPanel - Elief! - Official hosting partner for ocPortal.
Back to the top
 
Posted
Rating:
#49489
Avatar

Fan in training

Accessing the site directly gives me the same page I got earlier with the broken links and the following message which I forgot to mention last time:

"This site is still being installed. If you are the one installing it, you may login and open the site to the public when you are ready. "

I can open the ocp4 file its under c:\wamp\www\ocp4.

What should I do here?
I dont see any launch ocp file or anything similar.

Both MySQl and apache seem to be running.
I prob should mention that I have installed Apache several times. I installed it twice manually because I could not figure out why ocportal would not install untill I read a very helpful bit of advice you wrote in the forum View topic: FTP? Do I need a hosting service before I can install ocportal - ocPortal.com

Basically I tried to remove the version of apache I installed but not all the files coiuld be removed. I then installed wamp and followed your instructions.
Everything worked fine, I played around with my site for a couple of hours then closed it, leading to my current predicament of not being able to access ocportal.

Should I just reinstall everything?
Back to the top
 
Posted
Rating:
#49496
Avatar

Community saint

Ahh, ok, Site Closed, that IS ocPortal telling you that. You should be able to login with your admin account. Additionally, if you'd like to open the site, head to:

Adminzone –> Setup –> Configuration –> Site Options

and uncheck the Closed Site box.

"no violence, no hate, no pain, no enemies
just peace, unity, tolerance and love" - The Beloved

OCP V7 | Advocating monetary reform - FreeOurMoney

Need OCP friendly hosting? Look no further:
Web Hosting, Reseller Hosting, and Dedicated Servers w/cPanel - Elief! - Official hosting partner for ocPortal.
Back to the top
 
Posted
Rating:
#49508
Avatar

Fan in training

Ok…but how do I log in?

All the links including "login" are broken.
Am I missing something totally obvious here?

Back to the top
 
Posted
Rating:
#49509
Avatar

Community saint

Yikes, sounds like something is toasted off for sure...might be time to start over. When you say the links are broken, is there a specific error you are getting?

"no violence, no hate, no pain, no enemies
just peace, unity, tolerance and love" - The Beloved

OCP V7 | Advocating monetary reform - FreeOurMoney

Need OCP friendly hosting? Look no further:
Web Hosting, Reseller Hosting, and Dedicated Servers w/cPanel - Elief! - Official hosting partner for ocPortal.
Back to the top
 
Posted
Rating:
#49510
Avatar

Fan in training

No matter which link i click I get this error:

Internet Explorer cannot display the webpage
   
   Most likely causes:
You are not connected to the Internet.
The website is encountering problems.
There might be a typing error in the address.
 
   What you can try:
     Diagnose Connection Problems  
 
     More information

Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: