HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


HTTPS...... do what?

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#96198 (In Topic #19116)
Avatar

Fan in action

Missing configurations

As the description says. Missing configurations.


I am trying to setup the HTTPS by page selection. I just bwant the HTTPS enabled for login, join and eccommerce etc.... I followed the following tutorial info:
  1. Go to the Admin Zone, Setup section, Configuration icon, Security options, 'General' box, and turn on 'HTTPS Support'.
  2. Go to the Admin Zone, Security section, SSL/TLS (HTTPS) configuration icon, and tick (check) the boxes for the following pages… :join, :login, :purchase, :shopping, site:members. (These are the pages that purchases or passwords happen on – but you can enable for other pages too if you like)
Step 1..... No issue. Found it and checkmarked it.
Step 2..... Does not exist and I have tried everything including rebooting my computer lol. But no avail.

Before you suggest it, I really do NOT want to setup the WHOLE website as https. just were it is needed.

Did I inadvertantly discover a bug? hope I am just missing a step.

Thanks for the help!










Back to the top
 
Posted
Rating:
#96203
Avatar

Community saint

You said included rebooting your computer but did you try clearing the cache on the website with Wesite Clean Up Tools found in admin under tools?
Back to the top
 
Posted
Rating:
#96204
Avatar

Community saint

mrqwolf said

Did I inadvertantly discover a bug? hope I am just missing a step.
I don't think it is a bug and I don't think Duck's 'clearing cache' will help either, although it is good to get into the habit. I am running 9.0.6, so I quickly ticked the box to 'enable' SSL/TLS, went to the Admiin 'Security' drop-down menu, selected the config option and got this, without needing to clear my caches …



… so I can't figure out what went wrong with your install.

Hope somebody else can throw some light on the matter.

 :thumbs:

Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#96205
Avatar

Fan in action

No I had not, but I have now and still is not there.

Thanks for trying though!
:-)
Back to the top
 
Posted
Rating:
#96206
Avatar

Fan in action

Thanks fletch but ya that is not there at all. I double/triple checked to make sure step one stuck and it is. but still nothing like what you pic shows.


:(
Back to the top
 
Posted
Rating:
#96207
Avatar

Community saint

mrqwolf said

Thanks fletch but ya that is not there at all. I double/triple checked to make sure step one stuck and it is. but still nothing like what you pic shows.

Bummer!

Chris might have a take on this …


Take my advice. I'm not using it!

View my working ocPortal site (version 9.x.x) at Anglo-Indian Portal
Back to the top
 
Posted
Rating:
#96209
Avatar

Fan in action

hope so, i'm lost lol
Back to the top
 
Posted
Rating:
#96226
Avatar

Hi,

You'll need to go to install the 'ssl' addon. The Setup Wizard probably removed it.

I will mention this for the next version of the tutorial.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#96227
Avatar

This is kinda silly really. We made that HTTPS option before the ssl stuff was moved into an addon. For v10 we'll remove the option, it's redundant now.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#96229
Avatar

Fan in action

Good morning Chris,

I looked for an addon that did ssl but did not see it. I will check it again.

Thanks!
Back to the top
 
Posted
Rating:
#96230
Avatar

In the addons list within ocPortal already, not within the addon directory here.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#96233
Avatar

Fan in action

I found it already included in the system. I was looking un der downloads on the ocportal site.

Thanks chris!
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: