HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


How to change encoding in header?

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#51348 (In Topic #11212)
Avatar

Fan in action

It just remains ISO-8859-1...

I am trying to make a Bulgarian version of a site. So, I copied the EN language directory into BG and set up the site to use the Bulgarian pack.
I changed the encoding there to UTF-8 (also tried utf-8 - lower case), but still in the meta tags it has ISO-8859-1 and the text is all broken.
Where do I edit this setting?
Back to the top
 
Posted
Rating:
#51349
Avatar

Hello,

If you're just editing .ini files manually then the .lcd language cache files will likely still be there.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#51351
Avatar

Fan in action

I tried through the editor in the admin screen, then rebuilt all caches from "Tools" - still no change.
Back to the top
 
Posted
Rating:
#51352
Avatar

So other strings change correctly, but the 'charset' string isn't applying?


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#51355
Avatar

Fan in action

I hadn't changed anything else, but now that you mentioned it - I went and changed some stuff, re-built the caches again and none of the changes show anywhere.
In "installation options" the language is set as BG, and I have a directory called BG for the language files.
Back to the top
 
Posted
Rating:
#51356
Avatar

Fan in action

p.s. in the /lang-cached/BG directory there are only two files. One of them is global.lcd and it starts as:
a:798:{s:7:"charset";s:5:"utf-8";s:3:"dir";
which I guess is the serialized values and utf-8 shows there, but it seems the cache isn't being used for some reason? I tried to disable language cache from settings - still no change.
Maybe I haven't told the system to use BG as default language, but apart from the option in info.php is there anywhere else this can be set?
Back to the top
 
Posted
Rating:
#51357
Avatar

Yes there are a few ways. Possibly your member profile is set to EN. Possibly you have it set to detect language from your browser settings and that's saying EN.
You can also force it with &keep_lang=BG on the URL.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#51359
Avatar

Fan in action

I disabled the ability of users to select languages. Now, in my profile I don't see a way to change the language. Still, it's in English. Before I log in (i.e. - the default) is also in English.

In info.php I have the line:
$SITE_INFO['default_lang']='BG';
which doesn't seem to do anything.
Back to the top
 
Posted
Rating:
#51361
Avatar

Could you zip up your lang and lang_custom please and I'll try them myself and see if it happens for me too.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#51362
Avatar

Actually, did you try the keep_lang thing? Did that work?

I think the problem might just be that the option you changed disabled selection, but your profile selection has already saved.
Sorry for the confusion there.
You might need to change it manually in the database- the f_members table. Or, put the option back on, change to BG, then put the option back off.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#51364
Avatar

Fan in action

keep_lang worked, but only while it was in the URL so I still had the problem.
I followed your other advice (enable the feature, switch language, disable) and it worked. In another browser (where I was checking as an anonymous user), I deleted cookies and it shows as UTF-8 too. So, thanks, it seems to be working now.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: