HTML Logo by World Wide Web Consortium (www.w3.org). Click to learn more about our commitment to accessibility and standards.

Moving forward with Composr

ocPortal has been relaunched as Composr CMS, which is now in beta. ocPortal 9 will be superseded by Composr 10.

Head over to compo.sr for our new site, and to our migration roadmap. Existing ocPortal member accounts have been mirrored.


Help please!

Login / Search

 [ Join | More ]
 Add topic 
Posted
Rating:
#47518 (In Topic #10345)
Avatar

Fan in training

Hello all,
After searching for a system to use on my site I finally came across Ocportal and admired it. Uploaded the quick installation stuff then went to mysite/install.php, waited for such a long time then this message displayed in my browser:

http://mysite.com/ocportal/install.php?skip_disk_checks=1

Then I thought it might be a problem with the quick stuff, so I went for the manual installation. Uploaded everything, chmodded as described, and then ran mysite.com/ocportal/install.php, again waited for a long time and same thing.

I was so willing to use it but I can't :(

Any help will be much appreciated…
Back to the top
 
Posted
Rating:
#47529
Avatar

Hi,

Am I right assume the URL you posted in your post above was shown in the address bar, and the main page was blank or showed a message about 'maximum execution time being exceeded'?

On the face of it it looks like your server is severely overloaded. When the first screen of the installer starts it runs some basic checks (the quick installer finishes these a lot faster than the quick installer, and should take only about 1 second to do it). If the checks did not complete within 30 seconds it redirects to the URL you posted which skips the checks entirely. If it still doesn't work, either the server is severely overloaded or something else is wrong.

That 'something else' is hard for me to say right now, as I don't have much evidence to work from at the moment. If you can let us know more about your server, if you've run other PHP systems on it in the past, whether it generally seemed slow yesterday, and perhaps give a screenshot showing the problem, we might be able to help some more. This is new to us, there hasn't been a similar problem reported before.

Potentially it could be some kind of 'infinite loop' which can theoretically happen if some kind of error happens inside the error display mechanism (so it keeps trying to generate errors when it can't display it's errors, forever). However, this would not seem likely as nobody else has reported it as of yet and the installer is very mature.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#47534
Avatar

Fan in training

Help please!

Hi. Thanks for your reply.

It doesn't display a message about memory or anything else, just a blank page. What happens is: I, after uploading either the quick installation or the manual package, go to my browser and type: www.mydomain.com/ocportal/install.php. After that it starts waiting and the progress bar in my browser acts so that it is trying to do something. I wait like 30 minutes maybe more, the progress bar still progressing. Finally it displays http://mysite.com/ocpo...ll.php?skip_disk_checks=1 I tried to install both auto and manual like 4, 5 times always the same score.

I have been using Dreamhost for over two years now, being not an expert, by following the instructions, I installed many systems on my various domains, like, Joomla, Drupal, cmsmadesimple, egroupware etc. Faced no such problem.

Thanks very much.
Back to the top
 
Posted
Rating:
#47535
Avatar

Hi,

I'd be happy to take a look for you. I know DreamHost is a good host, so I'd definitely like to get to the bottom of this.

If you'd like me to take a look please:
  1. check our server access policy
  2. send FTP access details to chris@ocportal.com.


Become a fan of ocPortal on Facebook or add me as a friend. Add me on on Twitter.
Was I helpful?
  • If not, please let us know how we can do better (please try and propose any bigger ideas in such a way that they are fundable and scalable).
  • If so, please let others know about ocPortal whenever you see the opportunity.
  • If my reply is too Vulcan or expressed too much in business-strategy terms, and not particularly personal, I apologise. As a company & project maintainer, time is very limited to me, so usually when I write a reply I try and make it generic advice to all readers. I'm also naturally a joined-up thinker, so I always express my thoughts in combined business and technical terms. I recognise not everyone likes that, don't let my Vulcan-thinking stop you enjoying ocPortal on fun personal projects.
  • If my response can inspire a community tutorial, that's a great way of giving back to the project as a user.
Back to the top
 
Posted
Rating:
#47546
Avatar

Fan in training

Sent the e-mail, copy below:

''Hello Chris,
I am sending this e-mail to you regarding our correspondance at the Ocportal forums. In case you don't remember what the post about, I incorporate your last reply below:

''Hi,

I'd be happy to take a look for you. I know DreamHost is a good host, so I'd definitely like to get to the bottom of this.

If you'd like me to take a look please:
I uploaded the files and tried installing at domain.com/ocportal. Failed. Afterwards I did some playing around to solve the problem so I may have damaged things, not sure. It still doesn't work though.

Then for you to be able to look at a fresh one I reuploaded all the files - made no chmod - to domain2.com, too. I touched nothing on that domain. (www.domain2.com) It does the same thing on that domain too, i.e. waiting for a long time then doing nothing. I contacted Dreamhost support as well but so far no reply. I think it will be better if you look at domain2.com since it's all virgin, as it came from Ocportal.com

I created an ftp username for you

user: ********
password: *******

I am grateful both for your interest and time.

Regards''
Back to the top
 
Posted
Rating:
#47627
Avatar

Fan in training

THANKS!

Hello again,

After Chris's great help my problem has just been solved. Well actually it has not thoroughly but the source of the problem was found. It was due to a server problem of Dreamhost. They are taking care of the problem now.

If Chris wasn't there that would never have been solved even found.

Thanks VERY much Chris!
Back to the top
 
Posted
Rating:
#47636
Avatar

Community saint

Yay glad its fixed for you. :)

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
Posted
Rating:
#47830
Avatar

Community saint

Yeah, the one thing that finally sold me on ocPortal was Chris. You won't find a more helpful admin/developer anywhere.

Legends of Nor'Ova: A site powered by ocPortal; home of the Legends of Nor'Ova tabletop RPG wiki and community.

Like ocPortal? Want to thank Chris and gang somehow? Then help out in the chat room! It really needs your help! Just open it in a tab everytime you open your web browser, and when you hear a "ding", check it out!

"Those who want help should first be willing to give help."
Back to the top
 
Posted
Rating:
#47835
Avatar

Community saint

mythus said

Yeah, the one thing that finally sold me on ocPortal was Chris. You won't find a more helpful admin/developer anywhere.
I'll second that one!!

"no violence, no hate, no pain, no enemies
just peace, unity, tolerance and love" - The Beloved

OCP V7 | Advocating monetary reform - FreeOurMoney

Need OCP friendly hosting? Look no further:
Web Hosting, Reseller Hosting, and Dedicated Servers w/cPanel - Elief! - Official hosting partner for ocPortal.
Back to the top
 
Posted
Rating:
#47838
Avatar

Community saint

mythus said

Yeah, the one thing that finally sold me on ocPortal was Chris. You won't find a more helpful admin/developer anywhere.

Ya he is very friendly and fun to talk to.
I even had/have a crush on him.
 :$

I run http://otakuplayground.com and am hopping to make themes and other things for ocportal even though I no longer use it for otakuplayground.com I still love it and feel it could go far with the right help. It needs themes and needs people to advertise for it.
Back to the top
 
1 guests and 0 members have just viewed this: None
Control functions:

Quick reply   Contract

Your name:
Your message: